Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

stargazine_ep3_banner.thumb.jpg.5533fb830ae914798f4dbbdd2c8a5853.jpg

Recommended Posts

The second bugfix release for series 0.19.

Thank you very much to community for bug reports, feature requests and contributions!

Full list of changes between versions 0.19.1 and 0.19.2:
- Added support DMS and DD formats for parallactic angle feature
- Added altitude limitation filter for AstroCalc/Graphs[AltVsTime/ME] tools
- Added visual improvements for AstroCalc/Graphs tool
- Added new time intervals for AstroCalc/Ephemeris tool
- Added computation of ephemeris for all naked-eye visible planets into AstroCalc/Ephemeris tool
- Added GUI for select the color of ephemeris markers into AstroCalc/Ephemeris tool
- Added 2 new scripts (Saturnian and uranian analemmas)
- Added 'k Pup' designation to star HIP 37229 (GH: #706)
- Added information about progress of loading on splash screen (GH: #719)
- Added a new skylore for Stellarium: Anutan
- Added support catalog "Southern Stars embedded in nebulosity" (Van den Bergh and Herbst, 1975 - VdBH)
- Added support "Catalogue and distances of optically visible H II regions" (Dickel+, 1969 - DWB)
- Added distances for few LDN objects
- Added support removing shortcuts through config.ini file (GH: #724)
- Added extraInfoString to StelObject: Allows extra info injected by plugins or scripts.
- Added display of Apex/Antapex points (GH: #737)
- Added "observers" for all planets with moons (GH: #736)
- Added IAU constellation abbreviation to object info
- Added 3 new actions
- Added settings for Script Console (GH: #741)
- Added Vanuatu (Netwar) skyculture (GH: #762)
- Added few asterisms (GH: #753, #768)
- Added new one time step into AstroCalc/Ephemeris tool (GH: #758)
- Added few new DSO textures (GH: #756, #780)
- Added support Vec3d into scripting engine
- Added a Messier Marathon script (GH: #771)
- Added support for short weekday display modes in bottom toolbar
- Added GUI option to toggle permanent orbit drawing
- Added hyperbolic comet C/2019 Q4 (Borisov) [2I/Borisov] into default ssystem_minor.ini file
- Added a scripting function for refraction (GH: #778)
- Fixed coloring text issue when formatting output is on
- Fixed saving properties for external software/remote computer in Telescope Control plugin (GH: #702)
- Fixed behaviour of selected ephemeris marker when sorting not for date (AstroCalc/Ephemeris tool)
- Fixed sorting date and time columns for AstroCalc/Ephemeris and AstroCalc/Phenomena tools
- Fixed crash on destruction of static QWidget (GH: #720)
- Fixed small difference of values issue for different time zones for Date and Time column in AstroCalc/Ephemeris tool (GH: #717)
- Fixed stupid conversion bug in hmsToRad function (GH: #716)
- Fixed an asymmetry w.r.t. to the ecliptic latitudes (Moon age)
- Fixed Search Tool/Lists behaviour for VdBH catalog
- Fixed distances for few DSO (GH: #708)
- Fixed Gregorian date issue for AstroCalc (GH: #711)
- Fixed support GPS on macOS (GH: #712)
- Fixed coefficient for the duration of mean tropical year
- Fixed issue for images in description for landscapes: set search directory (GH: #735)
- Fixed tooltip behaviour for Date and Time dialog
- Fixed star name to its source spelling (GH: #729)
- Fixed compiling with GPSD 3.19 [API 8.0] (GH: #733)
- Fixed encoding script files in Script Console (GH: #742)
- Fixed drawing names of asterisms
- Fixed aFOV display in Oculars plugin
- Fixed visual issue in Script Console (white background) with Qt 5.13
- Fixed links for scripting docs (SUG)
- Fixed screen flashing during solar eclipse (GH: #747)
- Fixed core.resetOutput(); method behaviour (GH: #750)
- Fixed AltGr behaviour for some languages on Windows
- Fixed clipping issue for LabelMgr.labelObject (GH: #776)
- Fixed weekday computation
- Fixed rendering planets orbits (GH: #773)
- Fixed error in shape of asterism Red-Necked Emu (GH: #769)
- Fixed proper removing of default secondary shortcut (GH: #764)
- Fixed cross-id error in DSO catalog
- Updated appdata.xml file
- Updated outdated code for names of days and months
- Updated Observability plugin
- Updated list of proper names of stars (IAU approved list)
- Updated Moon age calculation: let's use geocentric coordinates only for compute of the Moon age
- Updated AstroCalc/PC tool: simplification and colorification for graphs
- Updated AstroCalc/Phenomena tool: small speed-up
- Updated the default color space: StelToneReproducer now use sRGB as target RGB color space (GH: #718)
- Updated GUI for Satellites plugin
- Updated common names for DSO
- Updated common names for stars
- Updated packaging for macOS: Let's use macdeployqt for creating a MacOS bundles
- Updated nomenclature support: Let's use compressed nomenclature data to reduce an installation package
- Updated translations
- Updated planetary nomenclature
- Updated Sardinian skyculture
- Updated file handling in Script Console
- Updated HDPI features: enabled scaling fonts on High DPI monitors (GH: #546)
- Updated default shortcuts: changed default shortcut for copying selected object information (Ctrl+C -> Ctrl+Shift+C) to allow use Ctrl+C shortcut for text edit fields for whole planetarium (GH: #748)
- Updated getInfoMap method [scripting engine]: enhanced the getInfoMap method for the Sun (get eclipse data; GH: #747)
- Updated Chinese (Simplified) and Russian translations for Windows installer (GH: #755, #779)
- Updated Bookmarks tool
- Updated default exoplanets and pulsars catalogs
- Updated behaviour on Windows: disable HiDPI scaling in manifest (GH: #763)
- Updated Oculars plugin: improve RA/Dec output for CCD frame
- Code refactoring: type checking/casting clarifications
- Removed FOV plugin (the feature was moved into core of planetarium)

Homepage + links to downloading binary packages: https://stellarium.org

  • Like 3
  • Thanks 2

Share this post


Link to post
Share on other sites

Hi Alex

Thanks again for the continued hard work.
I have had a few issues with the latest version as follows.

When attempting to import comets using the import elements dialog, I get a strange issue once I try and click "Get orbital elements".
I select Comets and select the bookmark but when I click the button to import them and bring up the next dialog nothing happens. This works fine in the previous version however.

The other issue that I have had this evening when doing a fresh install on a windows 10 pro system is that I get a strange SSL issue when trying to download the additional star catalog updates.
I am unsure at this stage as to if this is an issue with the fact that it was being done from within a virtual machine as I am the process of recording a tutorial.

Any help on these would be great

Mark

Share this post


Link to post
Share on other sites

I've had a (quick) look and I can't find the answer - how do I copy the oculars from one pc to another?

I already have a master config.ini file that I copy to other pcs / laptops to keep them all setup the same, but this doesn't copy the sensors and telescopes from the oculars plugin.

Share this post


Link to post
Share on other sites

@Jonk see modules/Oculars/ocular.ini file in same place as config.ini

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi Alexander,

I just installed v19.2 on my new laptop (Win10 Pro, i7, 16M RAM), but am having a couple of issues:

  1. The extra star catalogues won't install from within the application (Configurations Window Extras tab), so I copied the cat files 5 to 8 from a previous instal (v15.2) on another laptop to the Appdata/stellarium/stars/default directory, but they have no effect on stars displayed when I run the application. When I check the Configurations Window Extras tab it is updated to 'get cataloque 9 of 9' but when I hit the button it errors with the message 'Error downloading stars 8 Error creating SSL contect ()' 
  2. I copied my occulars.ini file into the modules/oculars folder and initially all seemed correct, but then I noticed that the off axis display is not showing for my QSI camera, even though all the correct details are entered. I tried creating a new sensor, but the OAG overlay is still not showing.

Any ideas how to resolves these please?

Geof

Edited by geoflewis

Share this post


Link to post
Share on other sites
17 hours ago, geoflewis said:

The extra star catalogues won't install from within the application (Configurations Window Extras tab), so I copied the cat files 5 to 8 from a previous instal (v15.2) on another laptop to the Appdata/stellarium/stars/default directory, but they have no effect on stars displayed when I run the application. When I check the Configurations Window Extras tab it is updated to 'get cataloque 9 of 9' but when I hit the button it errors with the message 'Error downloading stars 8 Error creating SSL contect ()' 

Yes, this is known issue - https://github.com/Stellarium/stellarium/issues/786

The problem with creating SSL context caused by wrong version of openSSL libraries within Stellarium package (It's sad, but the problem was found a week after release ūüėē ). I've pushed the fix of problem today (https://github.com/Stellarium/stellarium/commit/9c87c1495b859bb83dcac17f01163dc248c6e8d9) and it will be available for testing in next beta (tomorrow/next weekend?).

Some workaround for you: https://www.cloudynights.com/topic/681465-stellarium-star-catalog-manual-installation-instructions/

17 hours ago, geoflewis said:

I copied my occulars.ini file into the modules/oculars folder and initially all seemed correct, but then I noticed that the off axis display is not showing for my QSI camera, even though all the correct details are entered. I tried creating a new sensor, but the OAG overlay is still not showing.

This is other bug, caused by refactoring the code and founded after release - https://github.com/Stellarium/stellarium/issues/784

The fix available in beta versions.

  • Like 1

Share this post


Link to post
Share on other sites
6 minutes ago, alexwolf said:

Yes, this is known issue - https://github.com/Stellarium/stellarium/issues/786

The problem with creating SSL context caused by wrong version of openSSL libraries within Stellarium package (It's sad, but the problem was found a week after release ūüėē ). I've pushed the fix of problem today (https://github.com/Stellarium/stellarium/commit/9c87c1495b859bb83dcac17f01163dc248c6e8d9) and it will be available for testing in next beta (tomorrow/next weekend?).

Some workaround for you: https://www.cloudynights.com/topic/681465-stellarium-star-catalog-manual-installation-instructions/

This is other bug, caused by refactoring the code and founded after release - https://github.com/Stellarium/stellarium/issues/784

The fix available in beta versions.

Hi Alexander,

I think that I've eventally got the star cats working via manual download. I'll look out for the beta for the OAG overlay.

Many thanks,

Geof

Share this post


Link to post
Share on other sites
1 minute ago, geoflewis said:

Does installing the beta overwrite all the existing settings meaning that I'll have to import them again, or will they survive the update?

Yes and no - just read the proposals by installer ;)

Share this post


Link to post
Share on other sites

Well I downloaded and tried to run it, but got about 20+ errors, which were all meaningless to me so I gave up.....ūüėē

Share this post


Link to post
Share on other sites
2 minutes ago, alexwolf said:

Which errors? O_o

I don't know, just lots of boxes all telling me that something wasn't working. I just clicked ok to them all then exited the install, so as not to mess up what I already have

Share this post


Link to post
Share on other sites
On 20/10/2019 at 20:22, alexwolf said:

@Jonk see modules/Oculars/ocular.ini file in same place as config.ini

I would like to do the same but I am unable to locate the folder, never mind the file.
The only folder inside the Stellarium folder that starts with 'M' is Models. I have the latest version installed 0.19.3

Share this post


Link to post
Share on other sites
8 minutes ago, pooky2483 said:

I would like to do the same but I am unable to locate the folder, never mind the file.
The only folder inside the Stellarium folder that starts with 'M' is Models. I have the latest version installed 0.19.3

These features are specific to each user and so are located in the Users files and not the main Stellarium program location. Try here

C:\Users\[Name]\AppData\Roaming\Stellarium

Alan

Share this post


Link to post
Share on other sites
Posted (edited)
15 minutes ago, symmetal said:

These features are specific to each user and so are located in the Users files and not the main Stellarium program location. Try here

C:\Users\[Name]\AppData\Roaming\Stellarium

Alan

I have just looked and I don't have an 'AppData' folder.
m2zgfXch.png

I am also using Kubuntu (Linux), so I would need to know the location to copy the file to.
There is a 'Roaming' folder, but that contains wireless info for internet

Edited by pooky2483

Share this post


Link to post
Share on other sites

AppData is a 'hidden' folder so on the screenshot above select the 'View' Menu at the top and under 'Show/Hide' section select 'Hidden items'.

Can't help with the Linux location but I'm sure someone else can help. :smile:

Alan 

Share this post


Link to post
Share on other sites
Just now, symmetal said:

AppData is a 'hidden' folder so on the screenshot above select the 'View' Menu at the top and under 'Show/Hide' section select 'Hidden items'.

Can't help with the Linux location but I'm sure someone else can help. :smile:

Alan 

So, that;s why I could not find it. In Linux, it's easier to identify a hidden folder ~ '.hidden', theres a 'dot/full stop' in front of the folder name.
I should be able to locate the same or similar folder in Linux as the folder structure should be almost identical.

Share this post


Link to post
Share on other sites

Glad you've found it. You're right I suspect in that the Linux folder layout will be very similar.

Alan

Share this post


Link to post
Share on other sites

I've also just opened the file in text editor and the oculars list only goes up to 255.
I am currently putting in all the eyepieces from RotherValleyOptics to try them out and I'm not sure if I've entered more than 255 or not and I'm thinking that 255 is the cut-off amount (255 being 11111111 in binary).
It could possibly be something for @alexwolf to consider in increasing the number, if possible.

 

Share this post


Link to post
Share on other sites

I am unable to locate the oculars folder in Ubuntu, does anyone know where it is located?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By alexwolf
      Today we released version 0.20.1 of planetarium. Thank you very much to community for bug reports, feature requests and contributions!
      Full list of changes:
      - Added new language - Luxembourgish (lb)
      - Added proper properties for Angle Measure plugin
      - Added configurable colors for Angle Measure plugin
      - Added GUI adaptations for Angle Measure plugin
      - Added evaluates scripts in individual context (Scripting Engine)
      - Added new planetary nomenclature
      - Added use properties in Satellites plugin
      - Added overloaded Labeling functions with colors specified as Vec3f (Scripting Engine)
      - Added display proper file paths and line numbers on script errors (Scripting Engine)
      - Added test for low precision hms time conversion function (GH: #1043)
      - Added spiky stars option
      - Added checkbox to the option settings in Script Console to clear the output text before a script is run
      - Added implementation of telescope syncing in INDI client (GH: #1048)
      - Added dirty flag, set by signal from QTextEdit (Script Console)
      - Added code to set TAB stop width at 4 characters (Script Console)
      - Added code to avoid losing names after Cancel in some QFileDialog (Script Console)
      - Added implementation of FSM to tranfer properly between dirty/filename states on load, save, clear, edit, expand actions (Script Console)
      - Added special case Catalogs/Other in GUI for objects without identifier (DSO Catalog v3.9)
      - Added Oculus plugin (disabled by default; GH: #1056)
      - Fixed ANGLE support for Windows package (GH: #1035, #1034)
      - Fixed keyboard navigation in Oculars plugin (GH: #1036)
      - Fixed Russian translation for Windows installer
      - Fixed data blunder: severely wrong slope for upcoming comet (GH: #1033)
      - Fixed flipping galactic/Supergalactic labels on Southern hemisphere (GH: #1028)
      - Fixed translations 'Set FOV to XXX degrees' when language is changed
      - Fixed possible segfault in SolarSystem class
      - Fixed building Stellarium without scripting
      - Fixed (restored) fading switch effect in Satellites plugin
      - Fixed (inverted) realistic/iconic mode labeling in Satellites plugin
      - Fixed (renamed) properties to better follow conventions in Satellites plugin
      - Fixed visualization mode in Satellites plugin
      - Fixed time conversion for low precision form (GH: #1042)
      - Fixed jerking an animation of movement of Solar system bodies (GH: #1041)
      - Fixed name for SH2-308 (DSO Catalog v3.9)
      - Fixed filter properly objects by catalogs (DSO Catalog v3.9; GH: #1052) 
      - Fixed few wrong objects in DSO catalog (DSO Catalog v3.9)
      - Fixed WUI of Remote Control plugin
      - Updated fix for ghost comet in ortographic projection issue (GH: #389)
      - Updated list of contributors
      - Updated code: simplified RegExp results handling
      - Changed Vec3f& to Vec3f asreturn type for functions called from scripts in some classes (Scripting Engine)
      - Re-implement getDecAngle, fixing some inconsistencies (GH: #1051)
      - Removed Abell planetary nebulae catalog (DSO Catalog v3.9)
      Binary packages you may download at https://stellarium.org website
    • By Dinglem
      So I had a free day yesterday and decided to sort out my equipment and update my astro laptop software packages. I downloaded the latest Stellarium and managed to get it to sync with APT. I installed my Xmas present from my sweetheart (Optolong L-eNhance filter) how did she know it's what I wanted??? I recently installed the free trial version of Pixinsight on my main laptop so after watching a few YouTube videos decided to get some Dark and Bias frames to create some masters ready for my next session.
      The weather was good yesterday and it stayed clear here as the sun started to set, so I set everything up outside hoping the apps were wrong and it wouldn't get cloudy. As it got darker I launched Sharpcap and completed a polar allingment, I used Stellarium and APT to slew to Vega and checked the focus was good. I then used Goto++ in APT to slew to NGC 7380 (Wizard Nebula), I set PHD2 off guiding and then I had my first issue; my laptop would not connect to my Lyn Astro dew controller so I manually set the temperature to quite low as it wasn't too damp at that time. So I started capturing 5 minute subs went inside and remoted into my astro laptop from my main laptop to check how it was going, all appeared good.
      I recently set up a Rpi NAS at home so I'm able to transfer data to it and then to my other laptop on the go, so after I'd got a few subs I opened them in PI to check the quality, they looked ok to me. after about an hour PHD2 started binging a lost star warning so I went outside and the clouds were starting to cover the sky, I then took loads of flat frames using my main laptop, Notepad and 3 sheets of white paper and decided to take some more darks in case it cleared. I then set about trying to process the 9 subs I'd managed to capture with the 200 flat frames the master bias and dark frames I'd created earlier. Despite the lack of subs I'm quite pleased with the result, I have done a quick Histogram stretch, and the knowledge I have gained, I'm definately going to purchase PI when I can afford it.
      So this morning I thought I'd sort out the issue with the connection to the Lynx Astro dew controller, you won't believe it, my Astro Laptop will not turn on, it's been playing up for a while I suspect the battery has died. So just when I thought I was getting on top of this frustrating hobby I get another spanner in the works. So do I gamble and order a new battery then discover it is the laptop that has failed, do I set up another old laptop I have and hope it will be ok, do I set up my Rpi3 with Indigo or do I buy a mini PC as I know my way around windows?
      Anyway here's the calibrated stacked image as it is in PI with a quick stretch.

    • By Stargazer33
      Hi, having recently bought a mobile (cell) phone tripod adaptor, I thought I would have a go at setting up my custom landscape view in Stellarium.
      I have watched all the videos on YouTube and read all the threads on here and I think I've done everything correctly, but the custom landscape doesn't appear in the list.
      I have tried this on my laptop (running Vista SP2) and my (very old) PC (running XP SP2). Neither of these work!
      I have  included a screen shot of what I've done. I have obviously forgotten or missed something really basic, but for the life of me I can't see what.
      Any help/advice would be much appreciated.
      Thank you & a Ho, Ho, Ho! 

    • By dragorom7
      Hello, i am new to this forum, i made my account here because i need help.
      So few weeks ago i ordered a USB to Serial cable to be able to Control my Telescope with my computer using stellarium.
      It arrived today.
      So i made my Star Alignment, then i plugged the cable to my Telescope and Computer, i installed the Cable driver and ASCOM Platform + ASCOM Celestron Driver.
      I started DriverConnect.exe and put the Celestron Driver i downloaded, and did the properties informations ( had to tick on "Advanced Setup" and "Show All COM Ports" ) and i put "COM8" on "COM Port", then i pressed "OK" and then "Connect"
      Result:
      Create              Creating device
      Connected           Connecting to device
      Error               System.Exception: Connect to COM1 failed, no Celestron scope detected
         to System.Dynamic.ComRuntimeHelpers.CheckThrowException(Int32 hresult, ExcepInfo& excepInfo, UInt32 argErr, String message)
         to CallSite.Target(Closure , CallSite , ComObject , Boolean )
         to ASCOM.DriverConnect.ConnectForm.btnConnect_Click(Object sender, EventArgs e) in C:\ASCOM Build\Export\ASCOM.DriverConnect\ConnectForm.cs:line 268
      Dispose             Disposing of device
      ReleaseComObject    Releasing COM instance
      ReleaseComObject    Completed release. Count: 0
      GC Collect          Starting garbage collection
      GC Collect          Completed garbage collection
       
      "Connect to COM1 failed, no Celestron scope detected"

      In Stellarium i set-up everything, the plug-in and restarted the app, then added my telescope  and i says it's "connected" but i can't find my telescope.
       
      Telescope:
      Celestron NexStar 127SLT
      The Cable i bought:
      https://www.amazon.com/Telescope-CP2102-Adapter-Control-Console/dp/B077G37VL1/
      PC Specs:
      Windows 10 Pro, GTX 970, 8GB Ram(DDR4), i7 6700 3.4Ghz
       
      Looking forward for your help, thanks in advance,
      dragorom7.
    • By PlanetGazer
      So I'm referring to the main astro-softwares that you use during your sessions on your phone or tablet, and found that most of people use mainly those two softwares on their phones. Laptop versions of the software are different products and are not the focus of this topic.
      So which do you use and why?
       
      My experience:
      I personally have Stellarium plus, and the free version of SkySafarai, so I have an understanding of how the user-interface of both works, I have been researching the extra features in the SkySafari Pro, and have figured the following so far (please correct me if I'm wrong):
      * I'm aware that both let you control your GoTo telescopes
      * I personally find current version of Stellarium to be more user friendly and easier to navigate the sky manually , could be the configured settings though
      * SkySafari has more options to the search bar, e.g. "Tonight's Best" based on your location, also a menu of Messier catalog with a highlight of those currently visible at your time and location, others like best deep sky objects
      * SkySafari has this wonderful feature of creating an observing list, very helpful to plan your session and share and download with/from others
      * Stellarium Plus has a database of around 1.69 billion stars,while SkySafari 6 Pro has around 100 milion starts (don't think it's important as most of them aren't visible in amateur telescopes, I think I read somewhere that only 25 million stars are possible to observe with our telescopes, up to 15th mag, wonder if any of you have tried to push this limit)
√ó
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.