Jump to content

Banner.jpg.5ed196c1e70861ebc79109e023c96067.jpg


R26 oldtimer
 Share

Recommended Posts

Has anyone done this with a celestron mount yet? Had a quick scan through the thread and couldn't see anything.

 

I suspect there are many similarities with the wiring etc, but I'd be interested to know if anyone has already done it before blowing anything up lol

Link to comment
Share on other sites

On 10/02/2021 at 08:39, bthoven said:

Thanks a lot for showing how to do it. I recently bought AZ-GTi and I love it. I also have my 6 years old Skywatcher Virtuoso. The initial position (Altitude = my location latitude, Azimuth points north) gives point and tracking hit and miss; but AZ-GTi point and tracking is great.

My components are: DT-06, 12v-to-5v fixed stepdown with onboard female USB port, 6P6C RJ12. Setup parameters same as shown in this thread.

I assembled it last night in such a way to allow me to utilizing the 5V through the step-down female USB port for some other devices, if necessary.

Tested indoor last night, can connect and slew the mount with Synscan Pro, but the slew responses seem having quite a delay. I'll try it outside under real sky if the weather permits.

The photo is showing my final connection diagram before I assembled it (my way of avoiding my own confusion).

Will find a nice box for it and may shorten the cable after the successful testing. Sorry for my terrible soldering skill.

Thanks a again.

ps. I'm not sure if I can create virtual comm port on my PC to make wireless connection to the mount, and drive it with Stellarium in either direct connection or Ascom?

diagram.jpg

DT_06.jpg

Virtuoso.jpg

I now know why there are delays in responses from the mount. The DT-06 is not suitable for Virtuoso because communication between the mount and Synscan Pro app has some pre-amble data to be recognized and weeded out before the real data can take effect. That's why I got the hit and miss, thus delay, communication between Synscan Pro app and Virtuoso mount. In summary, pure/transparent serial communication of DT-06 doesn't work. I need to use NodeMcu loaded with a program written for Virtuoso mount.

reference: DIY WiFi Adapter for SkyWatcher telescope mounts - ATM, Optics and DIY Forum - Cloudy Nights

Edited by bthoven
add information
Link to comment
Share on other sites

Update: I've replaced the DT-06 stock firmware with a program (SkyWatcherWiFi.ino) at this GITHUB and now it is working fine. It can even find the mount without using a fixed IP option; though it showed found device as an IP address (192.168.4.1), instead of displaying "Virtuoso". Everything is working smoothly.

 

I do not have to put resistors in both Rx and Tx lines because DT-06 has onboard resistors.

 

In summary, I flash your firmware into DT-06, then connect from 6p6c cable:

- 12V step down to 5v ---> DT-06 Vcc

-  GND -->DT-06 GND

-  Rx --> DT-06 Tx

-  Tx --> DT-06 Rx

 

Thank you very much

Edited by bthoven
Link to comment
Share on other sites

  • 1 month later...
On 10/02/2021 at 03:39, bthoven said:

Thanks a lot for showing how to do it.

Hello @bthoven. I see that you 've posted your efforts here: https://www.cloudynights.com/topic/656206-diy-wifi-adapter-for-skywatcher-telescope-mounts/page-2

Although this diy built is meant to be free and accessible  to every amateur astronomer, and besides the pleasing fact that the word is spread out to other fora, it would be great if there were at least some credits and a link to this thread in your posts at CN

Link to comment
Share on other sites

I don't know if my lx90 diy  wifi is relevant to anyone but I found this on ebay. 

HF Elfin-EW10 WIFI Serial Server to Ethernet Modbus TPC RJ45 RS232 to WIFI. 

I chose this as its cased and can take a 12v feed from the aux port on the mount . 

They are a little over budget at about £10

Works great with sky safari plus on my android phone. 

 

Edited by dnl
Link to comment
Share on other sites

  • 1 month later...

hi. thanks for the detailed instructions. this is a great post!

I have followed everything to the letter and also acquired some basic soldering skills thanks to this post. I have to report success! (using the buck converter)

However i am not 100% there. few issues i would like to share to see if i am alone:

1) there is some lag/delay in the commands. I use a joystick with ascom/synscan app  on my pc or when i connect with the synscan app on my iphone. Fine tuning position becomes really difficult as there is a unclear amount of delay between a button press and a reaction from the mount (HEQ5) with the home made adapter. I dont have this delay when in serial cable and i did not have the delay when i used the official Synscan Wifi adapter that i lost hence i tried this route. I tried to change the various timeout settings but nothing really made it close to the old setup. For info the diagnostics function in the synscan advanced menu gives me good results with responses of less than 200ms.

2) i would like to use the adapter in remote site mode as my central AP to connect all my gear (mini pc, mount, and camera (yes it is over wifi) and control PC with remote desktop. however when connecting to the Doit (or any renamed AP) devices can connect to the DOIT network but they cannot talk to one another. I cannot ping any device, cannot discover  any IP address on the wifi network and for sure cannot remote remote desktop into my minipc. this is rather annoying as this was a setup i could achieve with the original Skywatcher adapter and my minipc cannot act as a hotspot thanks to Win10.!

 

Anyone sharing the same limitations?

Thanks

  

Link to comment
Share on other sites

Hi there is definitely a latency with the direction buttons,  to the point they become unusable. My experience is that most of these problems are because of the way smartphones work (I have to turn off GSM data in order to connect to the mount) and touch buttons.

I haven't used the skywatcher module but my diy adapter produces the same problems as the integrated module in my azgti. Definitely use a mini pc or laptop, use the key board's physical arrow buttons to slew around,  even better use APT's goto++ function to find a target. It also works (almost fine) with my phone in conjunction with skysafari.

Almost every problem goes away when using pc and physical buttons (the same applies to the az-gti)

Link to comment
Share on other sites

hi thanks for the response. 

 

1) i use APT goto++ and that works fine with Wifi with the adapter. not yet fully convinced of the Autoguiding though in that mode given we need some low latency for that.

2) however in the 2 (or 3) star alignment process (before launching APT!) then the arrow buttons (HW or SW) via the minipc still cause this troubling latency that as use say make it unusable. Alignment is key for me since i need it to perform the polar alignement fine-tuning via the synscan app. Again quite different from the original SkyW module.

3) regarding AP mode i believe that it is only operational if the TCP server is on. So if we have UDP on 11880 then that mus disable the AP mode of the DOIT firmware. Maybe there is a better Firmware out there that can keep both services up (tasmota?) and still work on the serial - wifi  

4) alas i found a workaround to set my miniPC as a hosted network (by loading win 8 wifi adapter drivers on it!) making point 3) above less of an issue...

Link to comment
Share on other sites

16 minutes ago, totoantibes said:

then the arrow buttons (HW or SW) via the minipc

Are those physical buttons from a normal keyboard or touch buttons?

The autoguiding commands go through just fine, that's one more reason to suspect directional button issues.

Sorry if I can't be of any more help, that's because in my case every wifi related problem with the diy module seems to replicate with the inbuilt module of the azgti

Link to comment
Share on other sites

  • 3 weeks later...

I am on to something. I think the "Doit" firmware that is installed on the dt-06 chip is introducing the delays. Unfortunately the code for the firmware is not available anywhere.

I have compiled a simpler version of a UART bridge code with a small buffer for the UDP packet transmission to the serial port and i have impressive response times in the Synscan Mobile App. 

All the attempts have a response time <50 ms.!! while with the Doit firmware i average at 200ms.  this is still in development before i do the final wiring and soldering and coding! 

The test i did is based on https://github.com/roboremo/ESP8266-WiFi-UART-Bridge that was mentioned earlier in the thread. 

(i will not go into how to build/install etc. esp8285 chips)

https://github.com/roboremo/ESP8266-WiFi-UART-Bridge/blob/master/v1.1/sketch_esp_WiFi_UART_Bridge.ino

I did a couple of fixes in the code to make it work before burning it to the ESP chip

  1. change the port to 11880
  2. chose the UDP defines in the code 
  3. changed the buffersize to 4096 (but original should work too although prob less efficient) 
  4. corrected
    udp.beginPacket(remoteIp, port); // remote IP and port

to

    udp.beginPacket(remoteIp, udp.remotePort()); // remote IP and port

my next step is to find ways to make the STA/AP modes configurable via web interface as well as other params (like buffersize).

will keep the group posted.

  • Like 1
Link to comment
Share on other sites

  • 5 months later...

Hi stargazers,

I need help with the DT-06 connection. 

I built the adapter based on the description here (my mount is a EQ3 goto, so I modified the wiring accordingly). The module receives 3.3 V on a DC buck converter. I made the settings,

connect to the adapter at 192.168.4.1, can manage it, but Synscan App Pro can't connect to it, the error message is always "cannot connect".

I tried under iOS, Android, Windows, I get the same error message everywhere. Using Fing to discover the connection can see, that DT-06 and Phone (or PC) are in the same VLAN on Wifi (DT has 192.168.4.1, device gets 192.168.4.2).

I only use the motor controller for the connection test without the motors (no RA and Dec cables connected), but I don't think that would affect the connection.

Does anyone have an idea what could be wrong?

Thanks: Frigyes

Edited by Frigyes Hollay
Link to comment
Share on other sites

Hello, first of all you have powered your wifi board with 3.3 volts. I am not sure if there are different versions of this board, but mine had to be powered with 5 volts (see original post),  while 3.3v is the board's & mount's TTL voltage of the Rx & Tx signals. So this could be your problem.

But before you change that make sure you have the correct settings for wireless connection on the synscan app "connection settings" tab.

It looks like the app itself had some U.I. changes since my original post.

This is what it looked like then Screenshot_20211122-104344_Firefox.thumb.jpg.d2575daeab835c8e1c3cb43828a71c23.jpg

and this is what it looks like now

 

Screenshot_20211122-104404.thumb.jpg.7c442c61f0866fc349e6d506028fd2de.jpg

 

Make sure you're with "network" tab, disable auto detect (find devices) and enter 192.168.4.1 in fixed IP, like that:

Screenshot_20211122-111323.thumb.jpg.a6d383502ea09d9b26ebba6420e79e80.jpg

Edited by R26 oldtimer
Link to comment
Share on other sites

and there's the point.

I checked the DT-06's data sheet and 4.5-6V is the necessary power supply, so 3.3V isn't enough for it clearly.

Stupid mistake 🤬, I confused it with another running project of mine, that this DC buck converter was originally for,

only after I dropped the handheld and the LCD was broken, this Synscan wifi obviously overtook it.

I checked everything for hours, for this I may never realize that it needs more power.

I'll try it in the evening. The other settings were as shown in the pictures.

Thanks for the idea. 👏

Link to comment
Share on other sites

Increased voltage on 5V, unfortunately still the same story.

The blue LED on the board is flashing fast as I push the <Connecting> button in the app (where the SSID of the DT appears correctly) but there's still a "Cannot Connect" message.

This flashing tells me at least, the device and the DT try to communicate with each other.

The next, I'd give a try is to connect the motors as read somewhere as solution (even if I don't think, for a WIFI connection this shouls be a bottleneck).

Endless debuging... 💩

 

Link to comment
Share on other sites

Are you trying to connect to a smartphone or a PC running synscan app?

I have found in several occasions connection problems deriving from the smartphones power & network management. In a previous Huawei device, I had to turn off cellular data in order to connect without hickups.

Also if there are many wireless networks present you may find that your smartphone temporarily tries to connect to another network thus dropping the connection.

Best to test it on a PC running synscan app, just to make sure.

Link to comment
Share on other sites

12 minutes ago, Frigyes Hollay said:

The next, I'd give a try is to connect the motors as read somewhere as solution (even if I don't think, for a WIFI connection this shouls be a bottleneck).

If there are reports of bad connection with the unit and the handcontroller when motors are not connected, then this will definitely be happening with the wifi also.

Link to comment
Share on other sites

13 minutes ago, Frigyes Hollay said:

My next (and maybe last) idea

Perhaps there is something more. I've been trying to find a decent manual on this motor unit but didn't have any luck.

Some SW mounts use 3.3v TTL while some others use 5v TTL. Where you able to confirm that yours is 3.3v? If not, problem can be solved perhaps with a cheap TTL voltage shifter.

Link to comment
Share on other sites

Good question, try to find it. Although, I think the communication on data lines would be the next step after the conneciton btw. dt and the app has been estabilished - or am I wrong? Thanks

EDIT: by googling found that eq3 uses probably 5V TTL level. 

On the other hand, I just saw the circuit of a Synscan Wifi.

It is an ESP-WROOM-02, and a STM32 microcontroller. The ESP communicates on 3.3V and on the board I couldn't find components of a shifter, thus the motor controller should also communicate on 3.3V.

 

WIFI1.jpg

WIFI2.jpg

Edited by Frigyes Hollay
Link to comment
Share on other sites

Monitored network traffic with Wireshark. All I can see that the app is trying to reach the DT on 11880 and nothing more.

I think I just stop experimenting with it before I kill the motor controller.

Thanks R26 Oldtimer for the helping hand, clear skies!

Link to comment
Share on other sites

  • 1 month later...

Próbáltad-e másik Goto-s Skywatcher mechanikán a Wifi-s vezérlést? Nekem a Virtuoso-n és egy másik félkarún tökéletesen működik a DT-06 modullal. Igaz kicsit lassabban mint a gyári vezérlő. Kíváncsiságból feltöltöttem innen  https://github.com/vlaate/SkyWatcherWiFi/blob/master/SkyWatcherWiFi.ino  ezt a programot egy ESP8266-01S és egy 12F modulra. Kiválóan működik mindkét modullal. Mindenben olyan gyors mint a gyári vezérlő. BUÉK! Ha kell szívesen segítek.

Edited by ferbela
bővítás
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.