Jump to content

sgl_imaging_challenge_banner_31.thumb.jpg.b7a41d6a0fa4e315f57ea3e240acf140.jpg

Recommended Posts

Can confirm my second project with the lattepanda has been a success. 😁 Chuffed to bits, 

Flashed my az gti to the az/eq firmware 

Installed,, CdC, Ascom, eqmod onto my Windows 10 laptop. Plugged az gti eq mod cable from FLO into laptop and azgti, configured to cdc and eqmod,,  azgti now controlled via  cdc.. 

Disconnected the laptop,, plugged the lattepanda in its place,, had to reconfigure comm port,, working via lattepanda now,, 

Last bit of the project,, install tight vnc on laptop,, put in panda ip address,, 

Laptop,, lattepanda are connected to my smartphone hot-spot. 

I now have wireless remote desktop control of the panda,,  eq gti / eq panda is born,, 😁

  • Like 1
Link to post
Share on other sites
  • Replies 31
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Can confirm my second project with the lattepanda has been a success. 😁 Chuffed to bits,  Flashed my az gti to the az/eq firmware  Installed,, CdC, Ascom, eqmod onto my Windows 10 laptop. Pl

A bit late to this, but I also use synscan app instead of eqmod and works flawlessly with APT, Phd2 and cdc.

I'm really happy with what I have,, my goal was  Portable set up, easy set up Remote desktop with software I like, this has been achieved with using the lattepanda,, better suited to me than

Posted Images

 Mmm bit premature,, have eqmod control of telescope but no slew to target on cdc,,  bit of a nuisance,, see if can sort this out.. 

Link to post
Share on other sites

Can't you use wifi with ASCOM driver?

I controlled my AzGti via wifi from laptop with ease. You can't control camera and other bits that way, but for mount - you don't need any special hardware.

 

Link to post
Share on other sites

Problem is on eqmod side of things,, overflow message.  Don't ask how or why,, just an educated guess. 

Loaded Skywatcher windows app on the panda, changed the azgti to serial mode, connections available, az and eq,, 

Eq chosen,, set lat and long,, two star alignment,, ok. 

Slew to an object,, ok

All via remote desktop,, problem appears to be eq mod/cdc  not  Co operating. 

I can live with what I have,, mount control via synscan on laptop,, byeos, sharpcap, asi studio and hitecastro focus control, all wireless to my laptop,, 

 

Link to post
Share on other sites
21 minutes ago, vlaiv said:

Can't you use wifi with ASCOM driver?

I controlled my AzGti via wifi from laptop with ease. You can't control camera and other bits that way, but for mount - you don't need any special hardware.

I'm running full kit wifi,, this is my work around all this,, control of mount wasn't my problem 

 

Link to post
Share on other sites

You cannot use EQMOD with Synscan App Ascom driver .

Windows EQMOD is driven by EQMOD Ascom Driver and expects a serial com port.

Synscan Pro App will talk either serial (so USB to AZGTI) or via a network connection - Wired or wireless does not come into it they both use IP address given to Synscan Pro App and the App does not know what method it is using.

Synscan Pro drives the Mount and Synscan Ascom Mobile Driver talks to Synscan Pro.

CDC will talk to Ascom drivers BUT to talk to the mount via Synscan App it has to use the Ascom Synscan Mobile driver  OR (but not both) CDC will talk Ascom EQMOD driver if EQMOD is driving the mount.

I will confess I have no idea if EQMOD will drive a AZGTI (eq or not) !!!!!!!!!!!!!!!!!!!!  If someone has done it please post details 🙂

Perhaps the attached Official Sky Watchers Synscan diagram will help

🙂

daveysnscan.png

Link to post
Share on other sites
1 minute ago, stash_old said:

You cannot use EQMOD with Synscan App Ascom driver .

Well spotted - I did not realize there was EQMod involved.

1 minute ago, stash_old said:

I will confess I have no idea if EQMOD will drive a AZGTI (eq or not) !!!!!!!!!!!!!!!!!!!!  If someone has done it please post details

According to EQmod prerequisites page, it will work, but one needs to do a bit of tweaking:

http://eq-mod.sourceforge.net/prerequisites.html

image.png.732f93654db7d8cf8d92778026da97bc.png

Link to post
Share on other sites

As you can see from the diagram above EQMOD does not talk to (or didn't last time I did some hard digging) thru Synscan App. Synscan APP decides (or lets you choose) which mode (AZ oe EQ) to use. E.G. If I drove my AZEQ6 via Synscan App (wireless/wired/serial or a piece of string 🙂 ) its the App that ask's me what mode to drive the mount. I guess that the App does some AZ to EQ GoTo conversion!

 

So the best route IMHO is

 

Synscan App Pro connects to mount - wired ,serial or wireless and Synscan asks for which mode AZ or EQ

CDC - connects to Ascom Synscan Mobile App - so Synscan App must be running

Anything else that requires access to the mount must use the same Ascom Synscan Mobile app

Unless someone else has a better idea or another working option. 🙂

Link to post
Share on other sites
11 minutes ago, vlaiv said:

Well spotted - I did not realize there was EQMod involved.

According to EQmod prerequisites page, it will work, but one needs to do a bit of tweaking:

http://eq-mod.sourceforge.net/prerequisites.html

image.png.732f93654db7d8cf8d92778026da97bc.png

Has anyone actual done this - and you can only connect to the mount via COM port if using EQMOD.

Plus it would mean no Synscan App (not that it matters).

And just using EQMOD Ascom driver for CDC and anything else to drive the AZGTI

Link to post
Share on other sites

This shows how to do the Synscan App/Ascom Synscan App Mobile using EQ Mode on GTI - BUT note no EQMOD. To add CDC to this you would just ask CDC to use the same Ascom Synscan Mobile driver as used in the You Tube Video. Then you could Guide,CDC Goto etc in GTI EQ mode. Hope that helps Davy.

Unless you find some more info 🙂 LOL

Link to post
Share on other sites

OK so I ask FLO

Would this work with SW AZGTI in EQ Mode (with rel firmware) AND allow the use of EQMOD to drive the AZ GTI via the normal COM port that EQMOD requires. Plus will that then allow EQMOD Ascom driver to be used for all other Apps, - CDC APT etc

answer

Yes it will 🙂

Although we prefer the more reliable FTDI chip in our version:

https://www.firstlightoptics.com/sky-watcher-mount-accessories/lynx-astro-ftdi-eqdir-usb-adapter-for-sky-watcher-az-gti-mounts.html

Kindest regards,

Grant

So thanks Grant at FLO 🙂 - your a star

So it appears the answer is yes 🙂 to EQMOD .

Davy just dont forget the Custome Gear settings for EQMOD 🙂

Link to post
Share on other sites
2 hours ago, vlaiv said:

😁,, excellent,, you've all caught up with me now, 😁,, the cable in grant's link,, from FLO,, is the one I bought,  the azgti Ascom driver was installed to use via cdc, Ascom, eq mod controlling  the mount,, CdC connects as heq5,, thit gives an overflow message on telescope connection,, both cdc and eqmod telescope direction buttons work,, the problem is no goto slew, 

The overflow is as you said stash to do with the gearing,, I do not believe its just a case of changing this value,, as it has been noted in other posts that after a while tracking errors occur,, I believe its handshake protocol not being correct,, 

Believing I am correct,, I decided to address the challenge another way,, trying the synscan app,, 

The azgti had to go to serial mode,, to try and get comms via the synscan,, otherwise I was back to stage one,, back to my phone hot spot linked to lattepanda and,, azgti control via a second device with WiFi,, as WiFi shuts off my hot spot. 

When the az gti is in serial mode,, it works the synscan perfectly,,  for now this is ideal,, as I can operate the full mount via remote desktop,, just not with CdC at present,, but this is day one and,, its a workable set up,, 

If someone has done this,, the way I've done it,, love to chat about it,, I done plenty of searches on the subject and,, got as far as you guys have got,, but I was convinced I'd get a working system and I have,, certainly no disappointment with me,, I have given folk the chance to take it further using a latteprnda,, 

Not to say I'm giving up 😁

 

Link to post
Share on other sites

In cdc,, the mount is set as heq5/6,, when I click connect,, it brings up the  eq mod panel

Change ra and Dec rate from 1 to 4 and the North, South, East, wet buttons move the mount,,, but if I move the eq panel to other side of the desktop,, the cdc connect telescope panel shows mount connect button on red,,  and when I try the slew or try and do a goto is says mount not connected,, but eqmod  can still control mount. 

Eqmod and cdc not talking 

Link to post
Share on other sites
1 hour ago, shirva said:

just not with CdC at present

Sorry I dont get this CDC is the simplest part - What Ascom driver do you choose when you have Synscan App connected to the GTI mount - This has to be Ascom Synscan Mobile with Ascom properties as per Synscan documentation. Something like 127.0.0.1 and port 11882 but check SW doc

I use this loads and it never fails - and I am using my own USB adapter not some bought item and an old SWAZ GoTo

You are running everything on the Police Car - sorry Panada 🙂

Link to post
Share on other sites

Plus you can try AZ mode - no way that should fail - as a test.

Plus of course your Linx should be able to do all the above (as mine did) - another test.

Did CDC testing with Synscan App pro over 2 yrs ago

And that was complicated as I used 2 PC'c and/or  a Smart Tele box - all worked with CDC and Synscan App

If you load and use Synscan App pro in Emulation mode does CDC work ?

Edited by stash_old
Link to post
Share on other sites

 I retried Ascom driver in to the lattepanda,, still the same.. As the photos show,,

I connect telescope,, overflow warning appears. 

I connect scope,, eqmod window appears

I change ra and Dec motor speed to 4  eqmod control buttons move scope

 

I move eq mode window to right,, CdC connect telescope button still red,, 

Scope icon on menu red as well even though scope will move wlth eqmod buttons. 

 Right mouse skymap,, no sync cdc to scope option and will not slew or goto,, telescope not connected warning appears,,  egmod still can move scope. 

I've tried everything I can think of,, can set my heq5 up without any problem using this kit,, only difference is the mount cable and driver,, getting tired now 

 

 

IMG_20200501_212505.thumb.jpg.6ebc856526efd7ed71177818336b2b10.jpg

IMG_20200501_212347.jpg

IMG_20200501_212539.jpg

IMG_20200501_212620.jpg

IMG_20200501_212638.jpg

Link to post
Share on other sites

And you didn't have Synscan loaded did you that would screw things up no end !

Then give the Synscan App EQ mode a try with Ascom Synscan Mobile mode and CDC - nothing to loose.

What benefit do you think you will get by using EQMOD over Ascom Synscan App Mobile driver/Synscan App Pro - all software should still work - Byeos etc ?

Oh well going to watch another episode of DCI Banks - 5th this week - speak to you later.

Link to post
Share on other sites

I've took the panda out the mix and it's on a decent Windows 10 and has exact same   failure as the panda. 

CdC is switching on eqmod,, but not switching on telescope in cdc,, missing command somewhere,,,, got to be,,.. 

Need to Wait and see if anyone else goes this route,, cloudy nights had a thread,  somebody had same prob,, no answers,, folk looked to be content using the synscan app,, and folk used the raspberry pi as well,, 

Link to post
Share on other sites

No hassle to me using Ascom and synscan,, and everything works OK,, was a astronomy experiment 😁 one for developers to look at,, I'm happy with what I have working and does exactly what I want it to do,, worked out better than raspberry pi 4 set up. 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Victor Boesen
      Hi! I purchased a Raspberry pi 4 4gb not so long ago with the intention of running a NAS and some other stuff on it. I have since then considered the possibility of using it to control the alt/az position of a mount like the Skywatcher AZ GTi with a python script running on the raspberry pi. I haven't purchased the mount yet since I'd like to hear if it would be possible.
      A little more information on my main objective:
      Weather satellites and radio has recently caught my attention and I'm therefor considering to mount a directional antenna on the skywatcher AZ GTi mount which then tracks a chosen satellite across the sky. The raspberry pi would be running a program that would send the alt/az coordinates to the mount. I have thought about sending the alt/az coordinates through a TCP socket but I'm not sure how I would connect (and if it's possible) the mount to the raspberry pi or the opposite way.
      Here's a video of the current software I'm working on:
      I've seen people control mounts like the Celestron nexstar ones but it would be ideal to make the small and light weight AZ GTi perform the same job. If you have any experience with the AZ GTi mount and raspberry pi I would highly appreciate your advice:)
      Thank you in advance!
      Victor
    • By shirva
      Been getting help from old stash, setting up raspberry pi4 4gb for astronomy,, he had the patience of a Saint, 
      We got there in the end, I used the astroberry operating system put together by radek,,  Linux just isn't my thing lol, 
      The astroberry system has software such as k stars/ekos, cdc/ccdciel, oacapture, hnsky an few more,, I tried combinations of the software and found it wasn't what I wanted,,        the concept of remote desktop, from a small,, single board computer did interest me for a portable grab n go kit,, I could sit in my car and keep warm and control my kit via WiFi on a laptop 
      Came across the lattepanda,, not much bigger than the raspberry pi 4 4gb, but it's operating system is windows 10. 
      I could have went for the flagship Alpha model,, but the idea was to try the entry level panda and see what could be achieved with it, I bought mine with Windows 10 installed from the pi hut,,  £118 and was delivered within two days to Scotland,, 
      The WiFi ariel is not fitted to the board,, but just a push in fit,, not easy when you have hands like shovels. 
      Power was supplied via a phone charger b type plug, it takes full size hdmi cable, and I fitted a Bluetooth dingle to use mini keyboard /touch pad to set it up. 
      This was very easy to do, soon on to downloading Software I wanted to use, CdC, went in no problem, Ascom didn't,, I net frame work was missing,, on the panda windows,, type in,,, enable windows features,, then when next screen appears, tick,, framework box and continue,, windows will search and update the system,,  Ascom installed fine after that. 
      Eqmod installed no problem, installed hitecastro dc focuser, easy again,, backyard eos Pro and sharpcap Pro installed OK. 
      This all went pretty easily,, testing,, 
      Got it working my heq5, focuser,, initially tested backyard eos and my Canon 600d,, set up focus control ect. 
      Installed tight vnc and yet Again easily done,, I now had it connected remotely to my laptop via my smartphone hot-spot. 
      Absolutely loving it,, so much easier than setting up the raspberry pi. 
      Next up was testing my zwo asi178 mc on sharpcap Pro,, camera not recognised,, soon pinpointed that the zwo driver was not installed,, downloaded this and the Ascom driver just to be shure I had it,, I also got the asi studio suggested the other day. 
      Tried this out camera connected no problem and worked on remote desktop 
      Sharpcap recognised the camera as well,, working great on remote desktop 
      I installed tight vnc on to my linx 10" Windows tablet,, put in the panda IP address,, I now had a TV plugged into the panda at the mount, a Toshiba laptop and a tablet on remote desktop and both had control over the panda,, absolutely brilliant,, the vnc is also available on android and other os, 
      This would be great for outreach. 
      I've only installed software that I want to use,, internal memory I still have 12 gb free. 
      My next plan is to incorporate this system to my azgti,,  problem I found having set up the panda to my laptop via my phone hot-spot,, I could not connect to the azgti mount, it was either,, WiFi or hot spot on the phone,, I tried this using the raspberry pi.. 
      Had a think about it and, I believe the  easy solution to my problem is fitting the azgti cable,, I've ordered from FLO, attach this to the panda,, install azgti Ascom driver, then I should be able to control mount with ccdc,,.. Will find out if I'm right in a few days,,  should then have a portable kit I can control via remote desktop in my warm car in the winter. 
      Davy 
    • By Miguel1983
      Hi,
      since i started work on my observatory there hasn't been much time for AP, but since lunar photography is done in minutes i had a go yesterday.
      Gear:
      SW AZGTI with the Skymax127 and Sony A6300 and Baader Neodymium Moon & skyglow filter.
      100 frames taken and 50% used to stack in autostackerd.
       

       
    • By Bigwings
      I need my garage back so am selling my excess mounts.
      1. EQ5 motorised on both axis.
      No tripod this was mounted ony pier. Tracks well. 
      £100 Collect only because of weight .
      2. An older type Skywatcher AZ goto mount that came with my SkyMax 127. Good condition .
      £100 Collect please but might be able to send if you arrange courier.
      SOLDto Pitbull ...thanks
      3. AZ GTi  goto in excellent condition . Still have the box so can send at cost.
      The pic shows it with a telescope on it which is not included.
      £200
      Location just north of Newark on A1
      Clear Skies.
      Thanks for looking
      All Sold.
      mods VB please move
       
       
       



    • By alanjgreen
      I received the new ADM saddle for my AZ GTi this morning (direct from ADM). I have now fitted it to my AZ GTi mount and my Borg 107FL is now a million times more secure than it was before - its a great upgrade!
      Here are the parts received from ADM... The new saddle is longer and chunkier than the feeble standard offering.

      Here is the AZ GTi mount before I start the upgrade..

      Remove the centre circular cover which is stuck on with a sticky pad underneath. I used a small flat head screwdriver to lift the edge of the tin cover then pulled it off with some pliers (there are the remains of the sticky pad underneath to be cleaned off afterwards)....

      Remove the 4 black screws and then the standard saddle pulls off...

      Re-use the four screws to secure the ADM adapter plate to the mount...

      Use the supplied 2x 1/4×20 SHCS screws to secure the ADM dual dovetail saddle to the ADM adapter plate... (You will need an imperial Allen key)

      Test it out with the Borg 107FL...



      The leftover standard parts...

      This looks a great upgrade, my scope's ADM dovetail fits very securely into the ADM dual saddle and my peace of mind is restored!
      Alan
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.