Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_30_second_exp_2_winners.thumb.jpg.b5430b40547c40d344fd4493776ab99f.jpg

John Lawley

EQMOD SGP/PHD2 guiding - sidereel turning off during calibration

Recommended Posts

Hi - I've not posted here before as only just launched into this hobby, although I've always been massively interested in astronomy.

I had first light on my rig last night, which is:

Esprit 100, HEQ 5 Pro, ZWO EAF, ZWO mini filter wheel, skywatcher 50ED guidscope with ASI120, ZWO1600mm Pro, Lynx dew controller w 2 astro zap tapes

A big endeavour to get that lot working from zero experience, but I love a challenge and have really enjoyed the computer side (I'm a grade A nerd)...

 

So - what went well... I got the guide scope in focus (was stressing about this), and also the main scope. Even more awesomely, the autofocus routine in SGP is working perfectly :) Filter wheel also working perfectly and I'm getting lovely smooth pics from the main camera (I've already done the flats and darks while I was waiting for clouds to clear). Final good thing (well, good-ish), is that I got the platesolving working eventually, and was able to get the scope to align from Park to the Soul Nebula and centre fine. For some reason the "number of attempts" in my SGP profile hadn't applied, so it was giving up after 1 go, but I got it working in the end.

 

So the bad...

I couldn't take any data because every time it finished the platesolving and started PHD2, PHD2 would start the calibration process and then halfway through, the sidereel tracking on the EQMOD panel would turn off. Obviously, that would lead to a "lost the star" error. Is there some reason why sidereel tracking would turn off like that? I'm generally a bit confused as to whether I should be controlling the telescope from SGP (i.e. unpark) or using the park and unpark + tracking button on the EQMOD panel. Both PHD 2 and SGP are setup to use EQMOD ASCOM HEQ5/6?

So at the moment I can't do anything, because there's no way of guiding without it turning tracking off :(

 

Also I was cold. Very Very Cold.

Share this post


Link to post
Share on other sites

I never bother using the unpark option as sgp throws up a message and I click ok. I will use eqmod to park the scope though (just habit).

I would slew to your target and when it fails then just run calibration in phd.

If you have a permanent set up you only need to run calibration once unless you move your guide cam or scope.

Share this post


Link to post
Share on other sites

at the risk of causing controversy, you could try doing without EQMOD altogether.

There's an Ascom driver for Skywatcher mounts now that will work directly, 4th from bottom here - https://ascom-standards.org/Downloads/ScopeDrivers.htm .  If you install that, you can get SGP and PHD talking to the mount directly instead of through EQMOD.

if that doesn't work either, you can try connecting your guide cam to mount directly with an ST4 cable and setting PHD to guide 'on camera'

Share this post


Link to post
Share on other sites

If you make a change to your profile, you will need to re-apply the profile to the current sequence. It is not a 'live' update. Think of the profile as a template for creating a new sequence. That template sets the 'default' options but you can change/tweak the sequence via the Control Panel.

Calibration - check if you have limits enabled in EQMOD, and what is set for limits. It could be that the calibration process is pushing the scope beyond the limits and then EQMOD is turning off. If this is the case, EQMOD will flash LIMITS in the RA/DEC coordinates display.

PHD2 can sometimes be funny about where you do the calibration - a good place would the guiding assistant, it will at least give you a starting point.

 

Cold. Yep. Carbon hand warmers. Carbon back warmers. Layers. Thermals. Tea. :D:D

 

Share this post


Link to post
Share on other sites

Thanks for the replies, they are all definitely things I’ll try.

I’ve been playing with it a bit more and think it may be a communication thing as the eqmod com logs are getting RX timeout errors. It also lags a lot sometimes when I use the slew commands on the eqmod panel. I got the 5m eqmod cable and it’s plugged into a 1m usb3 hub. It behaves a bit better plugged into the laptop direct, but still seems to have connection issue and it’s that that is stopping the tracking (I think). I’ve ordered the 2m cable from FLO now so will see if that works better. Also the mount isn’t well balanced as the auto focuser and guide scope are both on left hand side. I have a pocket power box arriving this afternoon so will see if I can get a better balance when I take it all apart again 😕 

Share this post


Link to post
Share on other sites

Is the USB hub powered? If not, take it out of the loop - it will just cause more issues! 

If you need the hub, invest in a 12v powered one. It will save a lot of headaches!

 

 

Share this post


Link to post
Share on other sites

Another thing to maybe check is whether the USB ports on your laptop are timing out under power save..  

Share this post


Link to post
Share on other sites
15 hours ago, daz said:

Is the USB hub powered? If not, take it out of the loop - it will just cause more issues! 

If you need the hub, invest in a 12v powered one. It will save a lot of headaches!

 

 

It isn't - is there a model people generally use? I can't find anything that looks half decent on amazon. I'm using a Surface Laptop Pro, which is a fantastic computer other than the fact it only has one USB port (arg).

FYI - I fixed the balance issues last night, which should also help as there should be much less strain on the mount.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By AstroRuz
      Hello all,
      So I routinely have issues with guiding. Last night, I was getting some solid sub exposures of 5 minutes on the Flaming Star Nebula. When it got to about 15-20minutes of the meridian, I began getting trails on my stars. Then after the flip, I was still getting trails despite PHD reporting all's well.  I moved over to the Horsehead Nebula and tried 5 minutes there, and it behaved itself. Then I tested it on the Jellyfish Nebula and it also behaved (just about - minor trails). But it just did not want to dig it with the Flaming Star Nebula, which was practically near the zenith (about 2:30am 30/11/19).
      I tried recalibrating PHD (I use Pulseguide so the scope knew where it was). I then also recalibrated PHD at Alnitak so it was near the celestial equator (as the PHD best practices recommend). I even checked my Polar Alignment (done with a Polemaster), which was fine. I couldn't find anything wrong. 
      The guide scope was slightly off alignment with the main OTA, but that wasn't making any differences before the Meridian. 
       
      I did find the helical focuser of the Starwave 50mm guide scope I was using to have some movement in it again when I manipulated the guide camera. So that's something I need to look into. But before I start throwing money at this issue, I see the terms "flexure" and "differential flexure" coming up. Can anyone shed light on what this means please?
      I tried manipulating the OTA in its tube rings, that didn't yield any movement either. The piggyback scope is secure, the g/scope is secure in its rings as well, there's no movement in the OTA focus rack and the cameras are secure in their tubes. 
      I do have my guide rings quite far back on the body of the telescope to assist with fitting the guide scope piggyback. 
      Video of g/scope play: 
       

      Flaming Star Nebula. 5 minute sub, post Meridian Flip, about 2:50am (30/11/19). Note the plate solve compass in the top left. Drift appears to be in S/W direction.

      Position of tube rings (they're now at the focus end).
      I think I am leaning towards needing to move my tube rings (once I remember to get the tools from work). 
       
       
      Equipment:
      (brand new) Skywatcher EQ6-R Pro, SW Evostar Pro 80ED, Altair 0.8x R/F, Canon 600D, Altair Starwave 50mm Guide Scope, Altair AR130 Mono Guide Cam. 
       
       
    • By Nikolas74
      From AST Optics selling my mini guiding system that i used for my Redcat51 , i have used it also with my Esprit 100 and had excellent guiding results.
      There is a nice review here if someone wants to read :
      https://www.cloudynights.com/topic/575047-ast-mini-guide-kit-any-comments/
      Lens:    f=100mm F3.5 CCTV objective - made in Japan
      Adjustment:    by ballhead - with reliable clamping
      Dovetail:    compatible with most finder shoes
      True field of view:    2.9° x 3.8°
      Maximum guidable focal length:    1000 mm
      Focusing:    via lens cell
      Connection to camera:    C-Mount
      Lens filter thread:    M30.5mm P=0.5
      Weight:    79 grams
      Length of the objective:    44 mm
       
      PRICE : £100 (selling the mount and the CCTV lens not the camera)
      Paypal accepted buyer pays the fees
      I will cover the postage expenses
      Thank you,
      Nikolas




    • By Forunke
      Ok, so this is a really annoying bug / problem that I have with my setup:
      From time to time, in non regular intervals the image my guiding cam (ZWO ASI120) send seems to get flipped / mirrored or looks like it's from a completely different patch of sky.
      When I'm paying attention to the guide images I can clearly see that the image seems to be flipped in some way.
      It only happens for 1 frame PHD send a warning ( No star found / Star lost Mass changed) and after that everything is fine again. My gear is all connected to a single USB3 Hub which then runs via powered USB3 cable to my Pc.
      I'm not binning and have the noise reduction off (though PHD might got hickups while processing) but it still happens. Sometimes there are minutes between two events sometimes it happens 5 times in a row.
      It also seems like it's only happening during guiding, I haven't seen it happen during calibration yet...
       
      I'm completely clueless what's happening or how to get rid of it, any help / idea is greatly appreciated.
    • By kman42
      I have an EQ5 telescope mount which i use for astrophotography. I have modified it with a motorised RA axis using a bipolar stepper motor - my thread for the build is here .
      I want to expand the mount's tracking ability by motorising the DEC axis and using a guide scope/camera. I generally use the mount in fairly remote locations so would like to use a raspberry Pi for portability.
      I understand that I'll need to use a Raspberry Pi Camera Module for the guide camera. 
      The capability I want is:
      1. guide the mount along RA and DEC axes using a guide star as feedback
      2. track the mount using the RA axis only, and if possible continuously take 20-30 second exposures on the guide camera (this functionality is optional, but would assist in polar alignment of the mount)
      I don't want any GOTO capability. I am very new to RPi and need some help:
      - do I need to write code for this, or is there existing programming available for what I want to do?
      - is it possible to avoid the use of screens (in the field)? My preferred option would be to flick a switch to start and stop the guiding, with another switch for alignment mode (or something simple like this).
      - do I need to use any particular stepper motors/drivers for raspberry Pi? I'm using a bipolar stepper motor running quarter steps, with an A4988 stepper driver
      - is the RPi 3 Model B+ the unit I should buy?
      Thanks
       
    • By Cemers1
      Hi Guys, hoping someone can help me with the guiding issues Iv'e been having. First of all my setup is:
      Explore Scientific ED80 Triplet  Skywatcher EQ5 mount with synscan  Orion mini 50mm guide scope Altair GPCAM2 AR0130 Mono (as the guide camera) I did my polar alignment and 3-star alignment, which was spot on. So I set up the GPCAM2 and opened PHD2 where I selected "Altair Camera" and "On-Camera". It was all in focus, kept it on the default settings and I selected "auto select star", then it said I was guiding (I can hear the mount making small adjustments). A message popped up saying I needed to increase the max RA duration, then I needed to increase the max DEC duration, which I did gradually by 1000ms each time the message appeared. Still no progress.
      So I restarted the process with the max RA and DEC duration as 8000ms and it said I needed to eliminate the source of the problems.
      (I HAVE ATTACHED IMAGES OF THIS)
       
      I'm not sure why it not working and if I'm doing something wrong. But if someone knows where I'm going wrong, or has any advise it will be greatly appreciated!

      Oh and just let me know if you need any more info, because Iv'e probably missed something out. 
      Thanks again ?

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.