Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.



ASCOM driver for Stepper Bee

Recommended Posts

I have recently bought a Stepper Bee board and stepper motor to build a computer controlled autofocuser.

The stepper bee software works like a trean on a PC and the clumsy assembly that I made to connect the stepper motor to the focuser also works fine.

Then I started thinking it would be nice if I could find an ASCOM driver that could control the Stepper Bee. that way I could perform automatic focusing.

Before I start to develop the code myself I did some search on the internet but could not find anyone who has successfully developed such code. I found a thread about dome control with stepper bee & ASCOM however, and I am thinking perhaps the codes could be similar.

Does anyone knows of any code / plug-in that has already been develped?

Is anyone using Stepper Bee for autofocusing? I can really use some advise.



  • Like 1

Share this post

Link to post
Share on other sites

I like what your doing, I am building a feature packed focus controller to work with my SkyWatcher motor but I am having issues getting the ASCOM templates to work in Visual Studio. I'll let you know when I get it working it might help you on your quest.

  • Like 1

Share this post

Link to post
Share on other sites

That would be excellent. Apparently two German guys have developed  an ASCOM focus controller for stepper bee and seems like the code will be available soon on the ASCOM download website.

Share this post

Link to post
Share on other sites

Actually guys, the learning curve for writing ASCOM drivers is not that steep. I have about ten on my conscience at this point and find it a breeze. The templates are excellent and the code you have to write is not that complicated. I just checked the quick specs for the bee and think that it is really easy to write an ASCOM driver as there is a DLL which handles the interfacing with USB for you.

An ASCOM focuser driver needs just a few commands implemented and with the DLL behind the actual logic I would say it is good practice project.


  • Like 1

Share this post

Link to post
Share on other sites

The code is simple, I wrote a Stepper Bee ASCOM focuser about a year ago for a project I was thinking about. Unfortunately I abandoned the project when I upgraded my scope and like an idiot I deleted the code! :eek:

Share this post

Link to post
Share on other sites

I was pointed in the right direction and it was a simple check box in VS2013 under properties / compile / Register for COM interop. My driver is well under way now

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Oslet
      Sooo...I'm getting quote frustrated here. This spring I tested my HEQ5 with guiding. The synscan controller was connected to the computer trough the USB plug on the hand controller. This worked like a charm in my living room. On the new controllers you dont need the rs cable. But when I tried the whole thing with guide cameara for some live shooting, it just did not work. I get something wrong with the com port in decice manager, driver not working. I have tried 3 different drivers. The whole thing responded, connected and was guiding when i did a dummy test before the summer. So setup is pc-synscan via usb for pulse guiding. Can it be a problem with windows 10? What t h.... just happened? Where can I find a driver that works? And believe me it worked 5 months ago, argh. Thanks for any respons and support
    • By JBracegirdle
      Good afternoon,
      I'm still new to astronomy in general, my setup is explained in my previous post. I am trying to get plate solving working.
      I can get results from Astrometry.net, and I can get All Sky Plate Solver to solve when given an image file, but I am trying to get it to work with my ZWO ASI224MC direct.
      When I try "Click, Solve & Sync" I get an error "Camera array data unsupported."
      I have my camera connected with ASCOM as ASI Camera (1). The Image Type options are Raw8, Raw16 and Y8. Raw16 is selected and seems to be the default. I have tried the others and they all produce the same error. I've tried it with and without MonoBin. Binning is set to 1 and Subframe to 100% (50% tried). Filter is blank.
      I can connect to the camera in SharpCap via ASCOM (although it warns that it prefers native drivers). I've also tried the SharpCap native Plate solver with the astrometrics install from ASPS, it tries to solve takes a while, but can't find a solution. I also tried AstroTortilla, that reads from the camera but just returns "No solution in 0.0s".
      I've tried a Google search for the ASPS error but it doesn't find anything. I have checked only one application has the ASCOM camera at once. Any suggestions would be appreciated.
    • By Lenny
      Hi there,
      i recently built an autofocuser using the awesome autofocuserpro project library by Robert Brown. I’m trying to mount the stepper motor to my 6”RC linear focuser but I’m not sure who to approach it. Does anyone have any examples or solutions on how to mount my stepper ( 28PBY-48)?
      Thank you in Advance  
    • By Demonperformer
      Setting up all the software on my win10 laptop and getting things to talk to one another is a nightmare.
      I'm starting a new thread, so I can post all the problems I am having, one at a time, so issues don't get confused. This will also hopefully help anyone coming to similar situations later, as the problems and answers will not be interlaced.
      First issue: APT does not detect ZWO camera.
      I have got the camera (ZWO) drivers installed and sharpcap can see it and will connect to it properly. However, when I try to connect the camera in APT, the only CCD options it gives me are SBIG (which it isn't), QSI (which it isn't) and ASCOM. Now it shouldn't need to use an ascom driver, because the proper driver is installed, but I give it a go anyway, and this just offers me 2 simulators and 3 QHY cameras (I have one qhy driver installed for the guidecam .... I'll get to that later!). I have disconnected both the filterwheel and guide camera from the camera hub, so they cannot be interefering with the process.
      I am at a total loss ... any suggestions?
    • By AngryDonkey
      Last year I developed an 'all sky' imaging application to run my Starlight Xpress Oculus camera (for Oculus owners you can find out more here: https://groups.yahoo.com/neo/groups/allskeye/info). I have recently added 'experimental' ASCOM support for it but don't have any other cameras to really test in on. If anyone is looking for this kind of software and would be happy to carry out some beta testing please let me know. Please bear in mind:
      The software is really designed for traditional astronomical cameras using longer exposure lengths i.e. not video astronomy and am not sure how well it will work with faster CMOS cameras The software is mono only, no colour images can be processed (although it might be possible to use a colour camera to produce mono images - something I would like to test) It has been running for a while so is reasonably stable but please bear in mind that this will be a beta test so do expect problems! :-) Oh and sorry but it will only work on Windows computers from Vista onwards (no XP) Thanks,
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.