Jump to content

Banner.jpg.5ed196c1e70861ebc79109e023c96067.jpg

Telrad - common failures?


Recommended Posts

I seem to have two Telrads which have stopped working. Put new batteries in and nothing. Are there any common failures which happen, they seem pretty simple so am struggling to see what could go wrong!

Link to comment
Share on other sites

Problem no 1 solved, that was a dodgy connection to the battery holder. Just need to re solder the wires and it should be sorted.

No 2 I suspect is the potentiometer but it needs further investigation.

Thanks all 👍

Link to comment
Share on other sites

15 hours ago, Stu said:

No 2 I suspect is the potentiometer but it needs further investigation.

If it is a pot fault, then this is apparently the replacement:

image.png.c6c5f50828b5bcc65cf55009e8db9be9.png

but I can't see it on a UK site.

 

  • Thanks 1
Link to comment
Share on other sites

29 minutes ago, Ian McCallum said:

Farnell, CPC, Mouser, RS Parts, etc?

Yes, I meant the "official" part, on UK Astro sites. I'm sure there's a similar version here somewhere, but I wouldn't know enough about the specs.

Link to comment
Share on other sites

2 hours ago, Zermelo said:

Yes, I meant the "official" part, on UK Astro sites. I'm sure there's a similar version here somewhere, but I wouldn't know enough about the specs.

It's a linear 20kOhm potentiometer. Less than a pound in some places. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.