Jump to content


EQ6 R PRO problems

Recommended Posts

Not sure this is a power issue - that message usually displays on SW mounts when the serial comms pins on the microcontrollers have been fried, thanks to having been fed 12V rather than 5V. Could be 'a wiring issue with the handset' as you say. I have unfortunately managed to do that when trying to wire up a diy ftdi cable.

Have you tried @malc-c as he's pretty good at diagnosing these issues?



Edited by Padraic M
Link to comment
Share on other sites

14 hours ago, maw lod qan said:

Went out to use it, turned it on and the hand set displayed no response both axis.

This is my first mount, first problems.

Need to know the sequence of events, had you powered the mount up and then plugged in the handset.  Has anything else ever been placed in the handset port such as an EQDir cable, or wifi / bluetooth dongle.  Also does the mount have a USB port built in ? - If so then it's fitted with one of the newer ARM microcontrollers and recent posts suggest that a FET blows which then renders the board useless.  Post up some further information including answering Gus's question on the mounts condition. and then we can advise further.  Naturally if the mount is within its warranty then contact the retailer with a view of having a replacement motorboard sent to you if you are competent enough to replace them, or for the mount to be collected and repaired / replaced at the retailers expense.

Link to comment
Share on other sites

Posted (edited)

The mount is new, just over a year old.

Never been wet, in the observatory all the time. Just a bit dusty.

Running off a 12v car battery that is connected to a trickle charger full time hooked directly to electric.

Always worked perfect.

Switched it on, it started the handset routine like usual,  then up came the reading of no response both axis.

I hope just the handset wiring. It has slipped off the pier a couple times when I bumped it.

All the other info on the handset comes along lime normal.

Only the handset has ever been connected to it.


Edited by maw lod qan
Link to comment
Share on other sites

It's hard to advise as we probably have very different consumer laws here in the UK, which basically means the normal 12 month warranty is not something a retailer can hide behind if something goes faulty in month 13.  It basically means that you would expect an item to last for a reasonable amount of time based on the value, which for an EQ6 is certainly more than a year.

What happens when the mount is powered up is the handset sends out a request to interrogate the mount it is connected to, by asking for the mount firmware version.  With the older PIC microcontroller based boards there was one controller for each axis, so if one failed to respond you would get "No response DEC axis" for example.  On newer boards that use the ARM processors the message is typically both axis as the processor failed to respond.  Now with the newer boards (that have built in USB ports) a FET (Q3) appears to be a weak spot, which appears to be related to the power distribution on the board, so if the processor isn't running you would get the same response.

As the mount is just over a year old I would contact the retailer and ask what the procedure is to return the mount (or just the board and handset if that keeps shipping cost down) for repair or replacement.

One other area is to look at the power setup.  Possibly disconnect the charger whilst the mount is running.  A battery charger is different form a mains power supply adapter, and it could have had some part in this.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

49 minutes ago, maw lod qan said:

Checked online and found out my mount has a two year warranty!

Either way it turns out I should be covered.

Where's that emoji with fingers crossed?

I'd check out the power supply first, use a direct mains fed power supply.. no response from both axis means the communication from board to motors isn't getting power, take it the led power supply light is on, not flickering or dimming?

If that seems in order then contact the retailer and proceed from there

Link to comment
Share on other sites

1 hour ago, newbie alert said:

. no response from both axis means the communication from board to motors isn't getting power,

Sorry have to correct you there...  You can still have the 33v supply to the motors and the board will still give you the same "no axis" message.

The message basically means (as described above) that the handset hasn't received an acknowledgment back from its request to the control board in the mount.  The communication protocol is serial, or more correctly TTL serial where the signals levels are 5v. On older synscan mounts that lack a USB-B port, the Tx and Rx lines went directly into the PIC microcontrollers, and as can be seen in the repair thread linked above, placing the incorrect lead into the handset port blows the serial port on the PICs as they can't take 12v.  The same can happen on the newer ARM based boards as the handset communications also communicate straight to the serial port on the chip.

Power issues will cause the same response as the microcontrollers, be that PIC or ARM devices need to be powered and running, and if the 3.3v or 5v rail on the board isn't there due to a blown component  (Q3 seems to be failing on newer boards) in the power supply section of the sysnscan board that provides the 5v and / or 3.3v rails then the board will not be running and the error message will be presented. 

A lot of people use 13.8v bench PSUs in observatory setups.  If your car battery is putting out around 13v under load then that could rule out the battery being the problem, if it's below 12v, even by a few tenths, it could prevent the board form running.

I agree that checking the power supply as suggested  would be the first thing to do to rule it out. But if you get the same issue after testing with a decent 12v 60w supply that can provide the current as per the specs then contact the retailer and request a warranty replacement.  

Link to comment
Share on other sites

On 12/03/2023 at 11:31, malc-c said:

Sorry have to correct you there...  You can still have the 33v supply to the motors and the board will still give you the same "no axis" message.

Yeah sorry I should have said communication instead of power, but you can get the no response flag up if there's not enough power 

Link to comment
Share on other sites

Posted (edited)

Had to buy another voltage tester.

Tested voltage, 13.49 coming from battery. 

Double checked all the connections, then checked them again.

Made certain positive and negative connected correctly. 

Crossed my fingers, lifted my eyes to the heavens above, flipped the switch!


I'm up and running again!

Must have been a ghost!

Forgot to add, thanks for all the information you gave me!

Edited by maw lod qan
  • Haha 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.