Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_30_second_exp_2_winners.thumb.jpg.b5430b40547c40d344fd4493776ab99f.jpg

Recommended Posts

Hello!

Today we published first release candidate to version 0.19.1 - please help us testing Stellarium!

List of changes between version 0.19.0 and master (0.19.0.16926/0.19.1RC1):
- Added allow to search an inactive meteor showers in Search Tool/Lists tool
- Added 'Azimuth vs. Time' graph into AstroCalc/Graphs tool
- Added feature to show tracks for latest several selected planets (GH: #539)
- Added calculation and showing the orbital period for artificial satellites
- Added revolutions per day info for artificial satellites
- Added tools for jumping to the next or previous time of rising, transit or setting for selected object (GH: #484)
- Added new behavoir for AstroCalc/Graphs when clicking within graph area now sets current time.
- Fixed issue in script 'Mercury Triple Sunrise and Sunset'
- Fixed crash of Stellarium for eyepieces with permanent crosshair
- Fixed Stellarium crash when Remote Control plugin is working
- Fixed computation of assume radius for minor planets.
- Fixed the issue of the scrolling not working properly on Mac (GH: #393)
- Fixed crash in Scripting Engine (Hide artificial satellites through StelProperties in core.clear() method to avoid crash if plugin was didn't loaded)
- Fixed planetarium crash in HiPS (network manager delete problem)
- Fixed position problems on the Poles (GH: #391)
- Fixed scaling Telrad sign on HighDPI monitors
- Fixed surface occlusion bug even with landscape turned off in scripting engine (GH: #680)
- Fixed building with cmake -DBUILD_SHARED_LIBS=ON (GH: #683)
- Fixed error in constellation file format (Babylonian)
- Fixed Europe/Volgograd time zone settings (GH: #686)
- Fixed HiPS handling of allsky download (GH: #671)
- Fixed progress bar rendering (GH: #671)
- Fixed positive declinations issue in AstroCalc tool when option 'Use decimal degrees' is enabled (GH: #690)
- Fixed file names inconsistency
- Fixed constellation line in "Japanese Moon Stations" skyculture
- Fixed file name for constellation boundaries in Stellarium User Guide
- Fixed the user interface problems in Oculars plug-in (GH: #580)
- Fixed getting the wrong values in objects/info method for selected object for different formats (Remote Control plugin)
- Fixed refresh plots when AstroCalc dialog becomes visible again (AstroCalc/Graphs tool)
- Fixed jquery vulnerability (GH: #694)
- Fixed date and time dialog behaviour: Hour/Minute/Second spinners now correctly trigger signals dateChanged(), dateChangedByYear and dateChangedForMonth() when days, months or years are affected by it.
- Fixed update graphs in AstroCalc/Graphs tool when days change
- Updated planetary nomenclature
- Updated common names of stars and DSO's
- Updated cmake rules for Windows deployment
- Updated DSO textures
- Updated behaviour of HiPS survey if Stellarium started without network (GH: #681)
- Updated GUI for ArchaeoLines plugin (GH: #689, #682)
- Updated default pulsars catalog (v1.60)
- Updated list of asterisms
- Excluded Armintxe skyculture and landscape from default package

Download link: https://github.com/Stellarium/stellarium-data/releases/tag/beta

  • Like 2
  • Thanks 2

Share this post


Link to post
Share on other sites
9 hours ago, bottletopburly said:

@alexwolfDo you think stellarium scope will ever be integrated into stellarium  

I don't know.

Share this post


Link to post
Share on other sites
On 15/06/2019 at 17:50, alexwolf said:

jumping to the next or previous time of rising, transit or setting for selected object

Now that is nice! 

I'll download RC 0.19.1 immediately and see if I can find out how this works.

Edit:

I can't find an .exe or .msi. Just ...

     Stellarium-0.19.0.16932-x86_64.AppImage
     Stellarium-0.19.0.16932.dmg
     Source code(zip)
     Source code(tar.gz)

Am I looking in the wrong place?

Edited by Ruud

Share this post


Link to post
Share on other sites

Today we published second release candidate - with AstroCalc optimizations and small changes in GUI. Please help us testing ANGLE mode on Windows.

Share this post


Link to post
Share on other sites

Ah, two more downloadables have appeared in the assets list. So now I found stellarium-0.19.0.16932-win64.exe

I'll let you know if I run into any issues.

Share this post


Link to post
Share on other sites

Seems to be working well - I took the opportunity to finally break out Photoshop and tidy up one of my Ricoh Theta S photos for where I plan to put my observatory for use in Stellarium. The user guide (unpublished? https://github.com/Stellarium/stellarium/blob/master/guide/ch_landscapes.tex ) has some good guidance. Seems to work well!

stellarium-004.thumb.png.37bf1b308e725cba8b7b564962b7a6a4.png

stellarium-002.thumb.png.7804b116ade0419effaa70d2241bc964.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Dinglem
      So I had a free day yesterday and decided to sort out my equipment and update my astro laptop software packages. I downloaded the latest Stellarium and managed to get it to sync with APT. I installed my Xmas present from my sweetheart (Optolong L-eNhance filter) how did she know it's what I wanted??? I recently installed the free trial version of Pixinsight on my main laptop so after watching a few YouTube videos decided to get some Dark and Bias frames to create some masters ready for my next session.
      The weather was good yesterday and it stayed clear here as the sun started to set, so I set everything up outside hoping the apps were wrong and it wouldn't get cloudy. As it got darker I launched Sharpcap and completed a polar allingment, I used Stellarium and APT to slew to Vega and checked the focus was good. I then used Goto++ in APT to slew to NGC 7380 (Wizard Nebula), I set PHD2 off guiding and then I had my first issue; my laptop would not connect to my Lyn Astro dew controller so I manually set the temperature to quite low as it wasn't too damp at that time. So I started capturing 5 minute subs went inside and remoted into my astro laptop from my main laptop to check how it was going, all appeared good.
      I recently set up a Rpi NAS at home so I'm able to transfer data to it and then to my other laptop on the go, so after I'd got a few subs I opened them in PI to check the quality, they looked ok to me. after about an hour PHD2 started binging a lost star warning so I went outside and the clouds were starting to cover the sky, I then took loads of flat frames using my main laptop, Notepad and 3 sheets of white paper and decided to take some more darks in case it cleared. I then set about trying to process the 9 subs I'd managed to capture with the 200 flat frames the master bias and dark frames I'd created earlier. Despite the lack of subs I'm quite pleased with the result, I have done a quick Histogram stretch, and the knowledge I have gained, I'm definately going to purchase PI when I can afford it.
      So this morning I thought I'd sort out the issue with the connection to the Lynx Astro dew controller, you won't believe it, my Astro Laptop will not turn on, it's been playing up for a while I suspect the battery has died. So just when I thought I was getting on top of this frustrating hobby I get another spanner in the works. So do I gamble and order a new battery then discover it is the laptop that has failed, do I set up another old laptop I have and hope it will be ok, do I set up my Rpi3 with Indigo or do I buy a mini PC as I know my way around windows?
      Anyway here's the calibrated stacked image as it is in PI with a quick stretch.

    • By Stargazer33
      Hi, having recently bought a mobile (cell) phone tripod adaptor, I thought I would have a go at setting up my custom landscape view in Stellarium.
      I have watched all the videos on YouTube and read all the threads on here and I think I've done everything correctly, but the custom landscape doesn't appear in the list.
      I have tried this on my laptop (running Vista SP2) and my (very old) PC (running XP SP2). Neither of these work!
      I have  included a screen shot of what I've done. I have obviously forgotten or missed something really basic, but for the life of me I can't see what.
      Any help/advice would be much appreciated.
      Thank you & a Ho, Ho, Ho! 

    • By williamnohair
      Hi
      am posting this in case it helps anyone who has suffered the same problem as myself.
      In a nutshell: Own a Skywatcher Gti mount for some time now and used with some success, also purchased some time ago Skysafari and wanted to use both, with a problem much reported on the web and so much information out there that it can get a bit confusing and certainly in my case frustrating, after all just want stuff to work!
      After much experimenting and help from other postings this is what happens when you fire up the Gti.
      The mount generates its own wireless network and becomes the gateway, its IP address is always 192.168.4.1 you see this when making a connection with the Synscan app/program, its very similar to a normal router that serves you the Internet. Any device that then connects to this network then gets an assigned address one up from this, i.e. 192.168.4.2, .3, etc. However if you run the Safari app and go in to settings you will find it has also been allocated an address which is one up from the device you are using. In my case my Ipad was connected to the wireless network and had been given the address of  192.168.4.3.  but when I checked the IP address in the settings page of SkySafari it was 192.168.4.4 !
      If you accept this you get the error that the app cannot join the wireless network check your settings etc. If you now manually change that address to the same as the device running the Synscan app in my case .2 it should connect and work. However there is a caveat to this, I tried using an Iphone  4 and an old Ipad and they would not work together no matter what. I got the other error message that I had joined the network but the mount did not recognise the device type I had selected (Skywatcher Synscan Alt Az GoTo) and no amount of changing things would solve it. To get around this I used my trusty Win 7 laptop to run the Synscan program and things worked perfectly so it can be done don't give up!
      Sorry this is so long but I hope it helps someone out there. So to round off when you fire up the mount it becomes address no 1, any physical device gets the next address 2, any software running on the that device gets the next address 3. When you fire up SkySafari it must have the same address as the one that the SynScan app has got and this can e changed in SkySafari settings. None of this makes any sense to me as I thought software couldn't act in that way but there you are. I hope I have got this right feel free to contact me if things don't work
       
      Regards
       
      Bill
       
    • By alexwolf
      The second bugfix release for series 0.19.
      Thank you very much to community for bug reports, feature requests and contributions!
      Full list of changes between versions 0.19.1 and 0.19.2:
      - Added support DMS and DD formats for parallactic angle feature
      - Added altitude limitation filter for AstroCalc/Graphs[AltVsTime/ME] tools
      - Added visual improvements for AstroCalc/Graphs tool
      - Added new time intervals for AstroCalc/Ephemeris tool
      - Added computation of ephemeris for all naked-eye visible planets into AstroCalc/Ephemeris tool
      - Added GUI for select the color of ephemeris markers into AstroCalc/Ephemeris tool
      - Added 2 new scripts (Saturnian and uranian analemmas)
      - Added 'k Pup' designation to star HIP 37229 (GH: #706)
      - Added information about progress of loading on splash screen (GH: #719)
      - Added a new skylore for Stellarium: Anutan
      - Added support catalog "Southern Stars embedded in nebulosity" (Van den Bergh and Herbst, 1975 - VdBH)
      - Added support "Catalogue and distances of optically visible H II regions" (Dickel+, 1969 - DWB)
      - Added distances for few LDN objects
      - Added support removing shortcuts through config.ini file (GH: #724)
      - Added extraInfoString to StelObject: Allows extra info injected by plugins or scripts.
      - Added display of Apex/Antapex points (GH: #737)
      - Added "observers" for all planets with moons (GH: #736)
      - Added IAU constellation abbreviation to object info
      - Added 3 new actions
      - Added settings for Script Console (GH: #741)
      - Added Vanuatu (Netwar) skyculture (GH: #762)
      - Added few asterisms (GH: #753, #768)
      - Added new one time step into AstroCalc/Ephemeris tool (GH: #758)
      - Added few new DSO textures (GH: #756, #780)
      - Added support Vec3d into scripting engine
      - Added a Messier Marathon script (GH: #771)
      - Added support for short weekday display modes in bottom toolbar
      - Added GUI option to toggle permanent orbit drawing
      - Added hyperbolic comet C/2019 Q4 (Borisov) [2I/Borisov] into default ssystem_minor.ini file
      - Added a scripting function for refraction (GH: #778)
      - Fixed coloring text issue when formatting output is on
      - Fixed saving properties for external software/remote computer in Telescope Control plugin (GH: #702)
      - Fixed behaviour of selected ephemeris marker when sorting not for date (AstroCalc/Ephemeris tool)
      - Fixed sorting date and time columns for AstroCalc/Ephemeris and AstroCalc/Phenomena tools
      - Fixed crash on destruction of static QWidget (GH: #720)
      - Fixed small difference of values issue for different time zones for Date and Time column in AstroCalc/Ephemeris tool (GH: #717)
      - Fixed stupid conversion bug in hmsToRad function (GH: #716)
      - Fixed an asymmetry w.r.t. to the ecliptic latitudes (Moon age)
      - Fixed Search Tool/Lists behaviour for VdBH catalog
      - Fixed distances for few DSO (GH: #708)
      - Fixed Gregorian date issue for AstroCalc (GH: #711)
      - Fixed support GPS on macOS (GH: #712)
      - Fixed coefficient for the duration of mean tropical year
      - Fixed issue for images in description for landscapes: set search directory (GH: #735)
      - Fixed tooltip behaviour for Date and Time dialog
      - Fixed star name to its source spelling (GH: #729)
      - Fixed compiling with GPSD 3.19 [API 8.0] (GH: #733)
      - Fixed encoding script files in Script Console (GH: #742)
      - Fixed drawing names of asterisms
      - Fixed aFOV display in Oculars plugin
      - Fixed visual issue in Script Console (white background) with Qt 5.13
      - Fixed links for scripting docs (SUG)
      - Fixed screen flashing during solar eclipse (GH: #747)
      - Fixed core.resetOutput(); method behaviour (GH: #750)
      - Fixed AltGr behaviour for some languages on Windows
      - Fixed clipping issue for LabelMgr.labelObject (GH: #776)
      - Fixed weekday computation
      - Fixed rendering planets orbits (GH: #773)
      - Fixed error in shape of asterism Red-Necked Emu (GH: #769)
      - Fixed proper removing of default secondary shortcut (GH: #764)
      - Fixed cross-id error in DSO catalog
      - Updated appdata.xml file
      - Updated outdated code for names of days and months
      - Updated Observability plugin
      - Updated list of proper names of stars (IAU approved list)
      - Updated Moon age calculation: let's use geocentric coordinates only for compute of the Moon age
      - Updated AstroCalc/PC tool: simplification and colorification for graphs
      - Updated AstroCalc/Phenomena tool: small speed-up
      - Updated the default color space: StelToneReproducer now use sRGB as target RGB color space (GH: #718)
      - Updated GUI for Satellites plugin
      - Updated common names for DSO
      - Updated common names for stars
      - Updated packaging for macOS: Let's use macdeployqt for creating a MacOS bundles
      - Updated nomenclature support: Let's use compressed nomenclature data to reduce an installation package
      - Updated translations
      - Updated planetary nomenclature
      - Updated Sardinian skyculture
      - Updated file handling in Script Console
      - Updated HDPI features: enabled scaling fonts on High DPI monitors (GH: #546)
      - Updated default shortcuts: changed default shortcut for copying selected object information (Ctrl+C -> Ctrl+Shift+C) to allow use Ctrl+C shortcut for text edit fields for whole planetarium (GH: #748)
      - Updated getInfoMap method [scripting engine]: enhanced the getInfoMap method for the Sun (get eclipse data; GH: #747)
      - Updated Chinese (Simplified) and Russian translations for Windows installer (GH: #755, #779)
      - Updated Bookmarks tool
      - Updated default exoplanets and pulsars catalogs
      - Updated behaviour on Windows: disable HiDPI scaling in manifest (GH: #763)
      - Updated Oculars plugin: improve RA/Dec output for CCD frame
      - Code refactoring: type checking/casting clarifications
      - Removed FOV plugin (the feature was moved into core of planetarium)
      Homepage + links to downloading binary packages: https://stellarium.org
    • By dragorom7
      Hello, i am new to this forum, i made my account here because i need help.
      So few weeks ago i ordered a USB to Serial cable to be able to Control my Telescope with my computer using stellarium.
      It arrived today.
      So i made my Star Alignment, then i plugged the cable to my Telescope and Computer, i installed the Cable driver and ASCOM Platform + ASCOM Celestron Driver.
      I started DriverConnect.exe and put the Celestron Driver i downloaded, and did the properties informations ( had to tick on "Advanced Setup" and "Show All COM Ports" ) and i put "COM8" on "COM Port", then i pressed "OK" and then "Connect"
      Result:
      Create              Creating device
      Connected           Connecting to device
      Error               System.Exception: Connect to COM1 failed, no Celestron scope detected
         to System.Dynamic.ComRuntimeHelpers.CheckThrowException(Int32 hresult, ExcepInfo& excepInfo, UInt32 argErr, String message)
         to CallSite.Target(Closure , CallSite , ComObject , Boolean )
         to ASCOM.DriverConnect.ConnectForm.btnConnect_Click(Object sender, EventArgs e) in C:\ASCOM Build\Export\ASCOM.DriverConnect\ConnectForm.cs:line 268
      Dispose             Disposing of device
      ReleaseComObject    Releasing COM instance
      ReleaseComObject    Completed release. Count: 0
      GC Collect          Starting garbage collection
      GC Collect          Completed garbage collection
       
      "Connect to COM1 failed, no Celestron scope detected"

      In Stellarium i set-up everything, the plug-in and restarted the app, then added my telescope  and i says it's "connected" but i can't find my telescope.
       
      Telescope:
      Celestron NexStar 127SLT
      The Cable i bought:
      https://www.amazon.com/Telescope-CP2102-Adapter-Control-Console/dp/B077G37VL1/
      PC Specs:
      Windows 10 Pro, GTX 970, 8GB Ram(DDR4), i7 6700 3.4Ghz
       
      Looking forward for your help, thanks in advance,
      dragorom7.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.