Jump to content

Walking on the Moon

"Cannot find Java"

Recommended Posts

I am trying to install a program [Aperture Photometry Tool] that "uses Java Runtime Environment v7.0", but which "cannot find appropriate Java Runtime Environment". Control panel shows Java 7 is installed (albeit that it includes updates upto #80). And yet the program persists in saying that it cannot find Java.

I have tried the ubiquitous switch-it-off-and-on-again routine, to no avail.

Can any computer-savvy member suggest what I might be doing wrong?




Edited by Demonperformer
Link to comment
Share on other sites

I see what you are saying, but I am not quite sure how I would check the settings in APT until I have been able to load it.

Java is loaded in c:\program files\java\jre7\bin\javacpl.exe and the only limitation I can see in the instructions [http://www.aperturephotometry.org/aptool/documentation/installation-and-execution-instructions/] is that if I try to run the program from APT.bat, it will only work "if the Java bin directory is in the path of the operating system". Not quite sure what this means, but am not trying to run it from the bat file anyway.

I let Java instal itself in the default (I didn't select anything different), which I would expect to be what the program is expecting in the absence of it saying anything else.





Link to comment
Share on other sites

And to add the path...

Open a command prompt screen.

Type java -version.

Should look like this:

C:\Users\cg13650>java -version
java version "1.8.0_77"
Java(TM) SE Runtime Environment (build 1.8.0_77-b03)
Java HotSpot(TM) Client VM (build 25.77-b03, mixed mode)


Select Start -> Computer -> System Properties -> Advanced system settings -> Environment Variables -> System variables -> PATH. ... Prepend C:\Program Files\Java\jdk<YOUR VERSION NUMBER HERE>\bin; to the beginning of the PATH variable.



Select Start -> Computer -> System Properties -> Advanced system settings -> Environment Variables -> System variables -> PATH. ... Prepend C:\Program Files\Java\jdk1.8.0_77\bin; to the beginning of the PATH variable.

Link to comment
Share on other sites

Many thanks to everyone who has contributed suggestions to solve the problem, which has now been solved. And the 'gold star' for providing the solution that produced the breakthrough goes to ... [drum roll] ... Dr_Ju_ju. I thought trying a 32-bit installation would be simpler than uninstalling/reinstalling everything and it worked. Thanks, Julian.

This just leaves me with one final query ... as I now have two different versions of Java running on my computer (32-bit & 64-bit) should I uninstall the 64-bit to prevent possible clashes? Or will they both run happily together?


Link to comment
Share on other sites

I'm obviously being incredibly dumb now ...

Trying to stop java from automatically trying to update every time I switch the computer on. Found the instructions on Google, and managed to follow instruction 1 without too much difficulty. Instruction 2, however, seems to make no sense. I have checked through all the tabs (in the absence of an 'update' one), but can find nothing that will allow me to deselect this option.




Link to comment
Share on other sites

Click on Start > Run
Type the following command and press Enter: "regedit".
Go to "HKEY_LOCAL_MACHINE > SOFTWARE > Wow6432Node > JavaSoft > Java Update > Policy".
Create a DWORD (32-bit) value and named it as "EnableJavaUpdate".
    Set its value (value type - hex) to 1 to display the Update tab.
    Set its value to 0 to hide the Update tab from the Java console.

Link to comment
Share on other sites

Thank you both for your replies.

Unfortunately, neither of them worked.

However, I did a bit of digging-deeper on the internet and found this page. The short answer (for anyone who does not feel like wading through all the comments) is that, because I have both versions installed, when I access the control panel from the start menu, it automatically brings up the 64 version, which does not have an update tab. By going into explorer (or similar) and navigating to C:\Program Files (x86)\Java\jre7\bin\javacpl.exe and activating that program directly, it brings up the 32 version, which does have the update tab, and I was able to deselect the option to automatically update, which it has done although it did not like it!


[The image does not really relate to this reply, it was part of a previous reply I was working on before I discovered the answer, but I can find no way of deleting it before submitting the post]


Link to comment
Share on other sites

I spoke too soon. Although I managed to untick the box, 'apply' and 'ok' it, when I logged back in this afternoon, it did it again. EVERY time I go back into the java control panel, the box has re-ticked itself. I tried logging off and going back in as administrator. Now it would hold the unticked status between loadings of the control panel, but when I go back in as myself, it reverts to an automatically reticked status.

I am TPO'd with windows and its paternalistic attitude towards it users.

Link to comment
Share on other sites

Try this:

1. Run->msconfig (or in the Windows search box type msconfig.exe and then press enter) 
2. Click on the Startup tab 
3. Scroll down to 'Java™ Platform SE Auto Updater [ver]' and uncheck it. Sorting by Startup Item column helps to find this easier. 
4. Click Apply, then click OK, and restart the computer for this to take effect.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.