Jump to content

sgl_imaging_challenge_banner_31.thumb.jpg.b7a41d6a0fa4e315f57ea3e240acf140.jpg

Can’t get Celestron focuser to work under Windows 7


Recommended Posts

Now I’ve managed to sort out control of my EQ6-R Pro using Stellarium via EQASCOM, I’m working my way through the other equipment I want to control from my Windows 7 laptop.

I’m stuck trying to get my Celestron focuser to be recognised. This is what I’ve done so far:

  1. Downloaded the Celestron Focuser Utility Program (.exe file) from here: https://www.celestron.com/pages/manuals-software
  2. Also downloaded the December 2019 USB ASCOM driver set up from above.
  3. I ran the ASCOM driver set up and restarted the laptop.
  4. Connected focuser direct to laptop via USB. The focuser’s power light shows red and in Windows control panel it recognises the device as ‘Celestron Focuser’ but indicates no driver present.
  5. Ran the Celestron focuser utility program hoping it would connect and install the right driver so I could calibrate, but it can’t detect the focuser at all.
  6. Finally, ran APT to see if I could connect by choosing the ASCOM driver under ‘Gear’ but this doesn’t work either.

Stuck now. I’m guessing I need to somehow ‘tell’ Windows where the driver is...? 

Any thoughts? Thanks everyone

🙂
 

EDIT: I have previously had this focuser working correctly both with StarSense handset and via ASCOM (Celestron unified driver) through the aux on my old Evolution mount. However, now I’ve changed to a Sky-Watcher mount, I need it to function direct through USB.

Edited by Ade Turner
Link to post
Share on other sites
1 hour ago, Cornelius Varley said:

Im not sure sure that running win7 would be the problem. The manual suggests that the focuser can be powered from a usb port that can supply 900ma, so might not work if the usb power is inadequate. Alternatively, a 12v psu is required.

Thanks for the suggestion. As it happens over the past hour I have experimented using a separate 12v power supply, but still no joy. Even Celestron’s basic focuser utility still can’t detect the focuser. 

The focuser continues to be listed by name by Windows under devices but indicates no driver.

And the ASCOM profile explorer shows 2 entries: ‘ASCOM.Celestron.Focuser’ and ‘ASCOM.CelestronUsbMotorFocuser.Focuser’

Short of uninstalling the motor focuser entirely and going back to manual, I’m at a loss how to proceed 🙁

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Quetzalcoatl72
      I'm after a cassegrain reflector but I don't know which one to buy,
      I have a celestron c5 and it worked wonders for all fields, I now want the same but twice as powerful as my final upgrade
      I am looking at a c9.5 for £1350 or a c11 for £2000, My question is an extra 2.75" focal worth it for £750 more?
      I will likely purchase one this week
    • By Welsh Dave
      Hello Ladies & Gentleman,
      I would in need of require your assistance for my current tube that I have got. 
      I currently have a Celestron Starlight XLT tube and I am looking for a new Finderscope (This one did not come with as I bought it of one of my Uni friends). I am not fussed into the red dot sites and I would like someone similar to the EXPLORE SCIENTIFIC ES 8x50. 
      Any questions by all means ask :) 

    • By Abhishek Pawse
      Hi guys. Please tell me if collimation is required for the celestron 9.25 edge HD  after using the hyper star system( after putting back the secondary mirror in its place ). Or it holds its collimation.?
      Thanks In advance for help :)
    • By BenR
      Hello
      I am new to astronomy, and recently purchased a Celestron Starsense Explorer LT 114AZ, and just for a start, I used the finderscope to locate exactly a random star, and I looked through the eyepiece and just saw a blurry white image. I was using a 25mm eyepiece lens, and then decided to put on the 2x Barlow lens with the 25mm lens, and nothing changed. Is this normal? What should I do to improve?
      Thanks.
    • By Mike Read
      Morning,
      I currently have a Celestron 9.25" SCT and am in the process of upgrading the focuser to baader steeltrack. I have the f/6.3 FR on back order. My question is: where will the FR fit in the image train? Is it compatible?
      Thanks Mike
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.