Jump to content

NLCbanner2024.jpg.2478be509670e60c2d6efd04834b8b47.jpg

MS LifeCam Studio dismantled


Jessun

Recommended Posts

Hello,

Just picked up a Microsoft LifeCam Studio from the shop and decided to do some surgery :glasses2:.

It is quite different from the similar looking LifeCam Cinema to work on and I've attached some pictures focusing on the differencies.

Picture 1: Shows the front after the mount has been detached (three screws) and it shows the plastic front being forced off using the tiny screwdriver you will need throughout. Black trim and a tiny clear glass will come off revealing two screws under a tiny bit of double sided sticky tape.

Picture 2: This shows the piece that comes off after removing the screws you just uncovered.

Picture 3: Big leap here:rolleyes:. Basically, the microphone cover on the top and the little button is easy to remove with the screwdriver, just takes a bit of bending and off they fly. The casing consist of two cylinders, a black and a silver one and they easily slide off, one forwards and one backwards. You're now left with a familiar look, the top and bottom part of the inner casing, again held together with four screws. Once this casing is split, the circuit boards are lifted up to reveal that the cable runs through the bottom piece where the mount was. This creates some more work... The cable connects with a tiny socket - but one lead i soldered to the bord - what used to be clip on ground lead is now soldered. I left the cable on.

Picture 4: Destroy all the rings, gimbal balls etc around the cable and the protruding mount circle needs to be pretty much ripped off. i used a pair of pliers and "ate" it away bit by bit. (It needs to come off to allow the cable through, USB plug and all, but also to fit nicely in some sort of EP or extension barrel so just tear it off in little chunks.)

Picture 5: Merely shows a bit of the useless parts...

Picture 6: New feature: The CCD (or CMOS?) board is now attached to the main one by another socket. The two need to be separated in order to get to the screws that will allow you to get rid of the front lens/filter assembly. The design here is simple to work and no difficulties really.

Picture 7: Nicely separated, next remove the two screws holding the lens. (Careful these screws are tight!)

Picture 8: The blu LED is bigger and brighter than ever and needs painting over as per usual. Paint away from the CCD so you don't flick paint on it!

Picture 9: Nice big chip looking up through the barrel, here covered with a IR/UV cut filter.

And hey-ho another toy to put to the test!

/Jessun

post-28991-133877665644_thumb.jpg

post-28991-13387766565_thumb.jpg

post-28991-133877665655_thumb.jpg

post-28991-133877665661_thumb.jpg

post-28991-133877665671_thumb.jpg

post-28991-133877665677_thumb.jpg

post-28991-133877665682_thumb.jpg

post-28991-133877665688_thumb.jpg

post-28991-133877665694_thumb.jpg

Link to comment
Share on other sites

  • Replies 51
  • Created
  • Last Reply

Hi prbaxter, only as a guide camera - for which it seems just fine.

As for capture I haven't looked around yet for a program that does 1080p, the MS software that comes with it doesn't for instance.

All the best

/Jessun

Link to comment
Share on other sites

a great little guide there. I have just finished stripping one of the 720p cameras down and testing it with my main visual scope (imaging scope with goto int he post).

The images are fantastic and now have me looking to finally buy some better barlow lenses to use with it. I am looking forwards to getting into imaging with a webcam especially on a scope that can cope with being guided from the laptop as well as the view being displayed.

Link to comment
Share on other sites

  • 4 months later...

I received my LifeCam Studio yesterday and tested it before surgery with Cheese, a Linux based prog. and that gave the full 1080p HD display from the webcam. Absolutely the best webcam picture I've ever seen. Very sensitive too. I have a 1080p full HD monitor - 1960x1080 res. I wondered a little bit about destroying such a great webcam, but I bought it for AP so this evening I'm butchering it ready for that purpose. I've got to the point of trying to undo the lens unit screws but so far they wont budge. So I came back to this guide.

Link to comment
Share on other sites

With the help of some small pliers to grip the body of the screwdriver I have managed to undo the screws and remove the lens assembly. I now have a blob of matt black enamel on the bright blue LED, drying off. So far so good :icon_scratch:

I've noticed a heat sink with a cold finger onto the back of the image sensor. This is very interesting as it makes it possible to cool the sensor with a Peltier TEC. This could just make a DSO camera as well as planetary.

Link to comment
Share on other sites

There don't seem to be many TECs small enough to fit direct to the heat sink - this is one 15x15mm :- DC 3.7V 6.87W Peltier Cooler Thermoelectric Cooler Cooling TEC1-03106 | eBay

Otherwise it will need a spacer, narrow at the bottom and wider at the top to take a 20mm square TEC, which are quite common. OR a strip of copper or aluminium to connect thermally between the heat sink and the TEC. That would also make it easier to provide a heat dissipating radiator for the hot side.

I think it might be advisable to refit the screws (or tiny nuts and bolts) that held the lens assembly as these also held the sensor PCB plug into its socket and the back of the sensor against the heatsink cold finger extension.

Link to comment
Share on other sites

Look at the power - almost 7 W which is insanity :icon_scratch: you would need a very weak Peltier.
OK so a much lower power one is wanted then? How about this one (12mm square) :- DC 1.9V 0.81W Thermoelectric Cooler Cooler Cooling Peltier TES1-01701 | eBay

Or 2W same size :- DC 1.9V 2.14W Thermoelectric Cooler Cooler Cooling Peltier TES1-07103 | eBay

Link to comment
Share on other sites

0.81W looks good and easy to power and should not freeze the sensor. The OV CMOS only uses 110 mW of energy, so there won't be much of heat than that if at all.

And note that it has max ~1 sec exposures.

Thank you :icon_scratch: I'd forgotten about the webcam exposure limit when I was thinking of DSO imaging.

I'm rather puzzled that the webcam gets so hot after just a couple of minutes. Must be the signal processing chip if the sensor only uses 110 mW.

Link to comment
Share on other sites

Do we know if these and or the 720p version can more reliably get full 30fps rates if used with USB 3.0 pcie cards? It is in theory 10x faster than USB 2.0, or at least that is what is being touted for USB 3.0 by some card makers.

Would be handy to know if this finally solves the "full speed @ full size" weak spot for these cams, or whether it may be limited in the camera design itself.

Or is it just my 64 bit Win7 causing the issues maybe. Can get it sometimes, but it's not entirely consistent, and would really like to solve it.

I quite like the cams as they promise a great deal and deliver a fair bit of it too, some of the time, just not all the time; all the time would be truly useful.

I can get 20fps almost all of the time. Sometimes selecting 30fps @ 640x480 causes the cam to eject itself from the system, just needs plugging in again to reinstate it, but its a pain for all that.

Link to comment
Share on other sites

I'm hoping to have time to check mine out on some distant trees this afternoon - but the far hills have disappeared in the mist, so will have to use nearer ones. Likewise the comms mast is no good either.

Link to comment
Share on other sites

USB 2.0 camera won't go faster if connected to USB 3.0. Especially if they have hardcoded shutter settings :) 30 FPS is doable from those lifecams on subframes.

OK, so how does one get it reliably? And at what frame size are you thinking?

I've uninstalled the MS software, I got YUY2 and MJPG as options. If I use the former the rates are limited to anywhere between 7.5 and 20 and max size is about 640x480, if using the latter then 30 fps can be had but the output seems to crash registax and a few other bits of software reports it as unreadable. One or two will use it, but none that make it truly useful. MJPG is more or less a dead end so far, as I can watch the output but that is about it!

I must be doing something wrong I can only suppose?

Link to comment
Share on other sites

That sort of matches my experience, but if I switch to 30fps the camera stops output. I just tried it with two cameras in turn, one went blank and ejected itself and the other just went blank. I reset the ejected one, and saved the profile in sharpcap. Then re-selected the previously ejected camera and it worked!

However now both are dropping frames all over the place, says 30fps in selection box but actually running just shy of 15fps according to the status bar in sharpcap.

Both cams are now fully zoomed so as to match your experience but doing that has not brought the stable desired FPS, and this is in daylight too, darkness only makes it all far worse!:)

Link to comment
Share on other sites

I've managed some capture runs this afternoon with my LifeCam Studio using SharpCap.

  • 1920x1080 - 5fps - no user choice
  • 800x600 - - 10fps - maybe more
  • 640x480 - - 30fps - fastest available speed

I like the fact that selecting a lower frame size in SharpCap crops the frame to the middle bit while keeping the same resolution on the sensor. This is ideal for planetary AP as you can use full res in preview, centre the planet and then reduce the capture size to fit the planet with a suitable amount of black space around it.

I'll copy the files off later and see if they'll work in Registax - some previous AVI files I captured from the Cinema didn't work. Registax wouldn't read them.

I used a "Give Way" road sign where a lane goes onto the A303 on the hill about a couple of miles away. Firstly, direct on the scope with 2" to 1.25" reducer, then with the 2" 2x SW ED Barlow then with the 1.25" Tal x2 Barlow as well (x4). The image was pixel sharp even with both Barlows - I used 400% zoom for focussing. The GIVE WAY text was perfectly readable at x2 and x4. Pretty impressive I thought.

As with the Cinema, the Studio has a pink cast without the lens unit but, unlike the cinema, the colour is consistent across the whole of the sensor. I have not yet added an external IR/UV filter on the Studio.

EDIT... Forgot to say... I was using YUY2.

Link to comment
Share on other sites

Clear evening - for a change, so decided to try the new webcam in earnest. Got the image of Jupiter nicely on the screen in SharpCap, focussed nicely (with high zoom) and started capture. Using the ED 2x Barlow - so quite pleased with that. Slowly the image crept off the bottom of the screen so tried the slowly slew the mount - NOTHING. EQMOD/ASCOM had stopped responding. Tried re-running it but then SharpCap crashed. Tried to re-run SharpCap but kept getting an error message and shutting down. Rebooted XP several times but things just wouldn't work! I did manage to get EQASCOM running and parked the mount. Then it was time for supper. Might try again shortly or might give up!

Link to comment
Share on other sites

Don't give up! I want to see what this web cam can do ;-)
I didn't give up, I've just come in from trying to get things going again. Ran CdC, connected to EQMOD, unparked scope and slewed to Jupiter. Then tried to get Jupiter centred in the finder scope. Mount moved one way but wouldn't move back. Then it started off at full slew speed and I couldn't stop it from the netbook. I had to switch the mount off before it pulled off all the stuck on cable clips or stretched the cables. It ended up pointing towards the floor!! I tried switching back on and trying to park the scope as usual but nothing - dead! :) So I unclamped the mount and moved it to the park position by hand, turned everything off and shut the roof. I'm not in a good mood!!!!!!!!

So tomorrow I may be trying to find out what's broke. I shall be working out a test strategy first. I still have the hand controller for the mount so I guess that's first - see if it's the mount. If it is my astronomy is doomed for some time unless I can fix it myself. I can't afford to get it repaired for a month or two. :(:(

Anyway, I should have some AVI files from this afternoon of the road signs and trees which will give some idea. I can also say that I had to turn the exposure quite low on Jupiter so there plenty of sensitivity. It is just possible that I got something recorded before everything went wrong. I have brought the netbook in to transfer the files to my desktop machine and process them. I'll report back soon.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.