Jump to content

 

1825338873_SNRPN2021banner.jpg.68bf12c7791f26559c66cf7bce79fe3d.jpg

 

EQDIR connection issues


malc-c
 Share

Recommended Posts

I have an EQ5 Pro goto mount which, via the handset can be controlled from a PC running the usual planetarium software, using a serial (RS232) cable connected to COM1 and the port on the handset.

In order to simplify the connections I've followed the instructions on the EQMOD website (EQMOD) to make a USB direct connection. I've purchased an FTDI-TTL-232R-5-WE cable (this has been tested when experimenting with another project to control the shutter of my Canon camera - that worked fine), and brought home a CAT5e cable from work. To make life simpler my plan was to simply use a DVM to tone out the wires from pins 4,5,&6 on the plug and then twist them together with the Black, yellow Orange wires from the TTL cable.

I then plugged the USB cable in the PC and the CAT5e cable in the hand controller port on the Synscan unit and turned it on - pleased to say there was no smoke and nothing went bang ! I then went into device manager and changed the port setting from COM18 to COM2 (all the others were in use for some reason and I've been informed that ASCOM only sees COM1 - COM16. No matter what option I choose in the ASCOM driver I keep getting the "there is no scope connected to COM2" message. I even tried that on my netbook and got the same message after making sure I had the right COM port by checking Device Manager.

Am I missing something here, or should this work. The only difference I can see is that the EQMOD site stated that the cable is for the HEQ5 - could it be that you can't directly control an EQ5 mount without going via the handset ? Or do I need to wire the RJ45 up as shown in the RS232 version. If so then I need a 12v power source from somewhere, and this makes it more complicated than a straight single connection

Advice please

Link to comment
Share on other sites

Hi malcolm,

As a newbie to this I am sure someone will correct me but here's my two cents.

I assume you have selected 'PC Direct Mode' on the handset under Utility Functions?

Apologies if this sounds a tad partonising.

Justin

Link to comment
Share on other sites

Not having much luck are you :D

You can say that again. !!

The amount of cash I've spent (wasted) on buying all these TTL cables and breakout boards, it would of been cheaper to buy another PCI RS232 serial card for the PC and go down that route !

I can't see why it won't work... it's on three ruddy wires

Link to comment
Share on other sites

The Info I used is at the bottom of this page...

EQDIRECT

Copied here for ease of reference...

For those with HEQ5-Pro you will need to splice an RJ45 cable to the flying lead of the TTL232R. Connect as follows:

Solder Pin 4 of the RJ45 to the Black wire (GND)

Solder Pin 5 of the RJ45 to the Yellow wire (RXD)

Solder Pin 6 of the RJ45 to the Orange wire (TXD)

rj45.png

Edited by Psychobilly
Link to comment
Share on other sites

Interestingly, if you look at the diagram for the EQ5 RS232 connection it has the wires as GND, TX, RX for pins 4,5,6. If you then read the HEQ5 connections it states GND, RX, TX for pins 4,5,6 ?????????????????

OK so I tried swapping the TX and RX wires - still no joy.

I assume you leave the ports settings to default 9600, 8, 1, no parity ? - I've tried selecting various scope options in ASCOm driver, but still it won't talk to the mount -

I give up !

Link to comment
Share on other sites

Never changed port settings etc.. is this the same adpator you were using for the Shutter release?

Just connected mine up the right way round the first time using the info previously posted and it worked...

Sorry :D:p:dontknow:

Heres mine and the packet the FTDI Cable came in with the Farnell P/N as an insert...

EQDir%20FTDI.jpg

Edited by Psychobilly
Link to comment
Share on other sites

OK tried again, this time using a comm sniffer to see what's going on. Seems that the EQ 3 synscan isn't responding to the initialization

The first entry in PORT.JPG was with the synscan unit turned on, and then with the unit turned off - same response. (see attached)

There is nothing listed in the synscan manual that gives the codes, I'm guessing that the ASCOM software is expecting some form of handshake and isn't getting it so closes the port :D

post-23388-133877600563_thumb.jpg

post-23388-133877600568_thumb.jpg

Link to comment
Share on other sites

OK tried a different USB to RS232 convertor - Belkin and that failed too - Looks like it's not possible to control the EQ5 synscan unit direct from a PC without using the handset

Link to comment
Share on other sites

Interestingly, if you look at the diagram for the EQ5 RS232 connection it has the wires as GND, TX, RX for pins 4,5,6. If you then read the HEQ5 connections it states GND, RX, TX for pins 4,5,6 ?????????????????

OK so I tried swapping the TX and RX wires - still no joy.

I assume you leave the ports settings to default 9600, 8, 1, no parity ? - I've tried selecting various scope options in ASCOm driver, but still it won't talk to the mount -

I give up !

On the link page for eqdir it says:

Solder Pin 6 of the 9 way D-type Plug to the Orange wire (TXD).

Solder Pin 9 of the 9 way D-type Plug to the Yellow wire (RXD).

Solder Pins 4 & 5 of the 9 way D-type Plug to the Black wire (GND).

is that not different to what you are trying above?

Not that I understand any of this.:D

Steve

Link to comment
Share on other sites

I'm going to give up for the night. I've just tried again, but using a new breakout board based on the same chip used in the FTDI cable.

* Plugged it in to a USB port and tested the voltage on the TX and RX lines between them and GND 3.3v

* Disconnected and un-soldered the jumper, and re-jumpered the VIO to VCC

* Plugged it back in and tested the voltages again 5V :D

* Soldered a Header to the RX, TX and GND port

* Used a DVM to bell out pins 4,5,&6 of a network cable.

* Soldered corresponding wires to GND, RX and TX via header

* Plugged in the USB lead - both TX and RX leds flashed

* Plugged the RJ45 into the Hand controller port and turned on the power to the Synscan box

* Launched Cartes du Cie and opened the telescope control panel - selected the driver and clicked on connect - same error message

* Powered down and disconnected the cables and swapped over the TX and RX wires on the header (as per the EQ5 diagram)

* Re-connected and powered up the Synscan and tried again - same result.

I'm at a loss - three uSB adapters and still no joy. The only good point is that I haven't screwed up the synscan box !

Edited by malc-c
Link to comment
Share on other sites

Hi Malc, where are you'ish to the nearest county?

Thinking of a get together. We were formally introduced at SGL6!!!!!!

Hi,

I'm in Stevenage - Hertfordshire (just round the corner (ish) from StevieDVD)

Link to comment
Share on other sites

* Plugged it in to a USB port and tested the voltage on the TX and RX lines between them and GND 3.3v

It definitely won't work if the signaling level is only 3.3v - you must use the 5V version of the ftdi chip.

Also, Belkin USB-Serial converters are known non-workers when it comes to EQMOD - something to do with their turnaround delays/ buffering characteristics.

Chris.

Link to comment
Share on other sites

The first entry in PORT.JPG was with the synscan unit turned on, and then with the unit turned off - same response. (see attached)

There is nothing listed in the synscan manual that gives the codes, I'm guessing that the ASCOM software is expecting some form of handshake and isn't getting it so closes the port :D

The screenshot seems to shows you are attempting to communicate using a celestron driver? The only driver that can talk directly to the mount via an EQDIR is EQMOD. If you want to use the celestron/nexstar driver then the synscan handcontroller must remain in the loop to act as a protocol convertor (PC talks nexstar to the handcontroller, handcontroller talks Synta to the mount)

Chris.

Link to comment
Share on other sites

Yep, you need 5V.

Also, when using ASCOM via handset I can use Celestron driver but when using EQDIR module I have to use ASCOM/EQMOD driver.

Sorry if I've confused the issue malc.

Edited by Glider
Link to comment
Share on other sites

OK, re-read all the FAQ's and prerequisites, and re-installed all the ASCOM applications and latest patches and ran them again (choosing repair when prompted by the installer) - Then when tested via the planetarium software I was able to select the EQ5/6 driver in the telescope control option - BUT the program kept hanging when trying to connect...

Powered everything down and swapped the RX / TX wires to the mount (I've done this so many times I wasn't sure which way round it was (HEQ5 or EQ5 ) - connected everything back up and this time it went through and I have the TX and RX LEDS flashing on the breakout board :D:p

Seems that it must of been something corrupted in the ASCOM installation

Thanks guys for all your support - I'll go back and try the original TTL cable, but that will wait until morning - I'm wanting my bed now !!

Edited by malc-c
Link to comment
Share on other sites

Reading this thread with interest. Good luck Malcolm :D Some people have got this working so it's certainly do-able. I haven't followed all the links - is the information conflicting? I thought it was all on the EQMOD web site? Mind you, I know computers can seem like black magic, I have decades of experience and I still get "black magic" at times!

Link to comment
Share on other sites

On the link page for eqdir it says:

Solder Pin 6 of the 9 way D-type Plug to the Orange wire (TXD).

Solder Pin 9 of the 9 way D-type Plug to the Yellow wire (RXD).

Solder Pins 4 & 5 of the 9 way D-type Plug to the Black wire (GND).

is that not different to what you are trying above?

Not that I understand any of this.:D

Steve

EQ6 is 9 way D the other mounts use an RJ-45...

Link to comment
Share on other sites

Pleased to say that the original TTL cable also works. Not sure what had corrupted the ASCOM software / drivers on both PC's, but after a re-install of everything it's working fine

@Steve, the EQmod site shows a way of using a MAX232 level shifter to connect the mount to a serial port for both EQ5 and EQ6 mounts. Then underneath it has the wiring details for an HEQ5 (RJ45) using one of these TTL serial cables. The RX and TX pin outs are different, hence part of the confusion !

Link to comment
Share on other sites

Pleased to say that the original TTL cable also works. Not sure what had corrupted the ASCOM software / drivers on both PC's, but after a re-install of everything it's working fine
Great :D:p
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.