Jump to content

NLC-Banner.thumb.jpg.acb5ba835b9e8bf0718b90539633017d.jpg

Ascom connection help......


paul mc c
 Share

Recommended Posts

Not sure if this is the best place to post this,i have just upgraded to an EQ6-R Pro and purchased a new Lynx EQDIR cable to controll from the laptop,but i cant connect to EQMOD....i am getting a message "connect error port not available"any ideas how to sort this.

Thanks Paul

Screenshot (20).png

Link to comment
Share on other sites

15 minutes ago, paul mc c said:

any ideas how to sort this.

If you go into the Toolbox for Eqmod and go to the Ascom connect option. You should be able to search for the comma port there using the little binocular symbol. Once found it should connect.

  • Like 1
Link to comment
Share on other sites

Have you set the correct port for the connection in the Toolbox?

Start > EQMOD > EQASCOM > Toolbox > Driver Setup

1.png.f4e66586fb0c8fa97c1547b77c1578ab.png

2.png.09dc5a56d63fc61090f74a19f8dbfa4c.png

Set the Com Port to the number that corresponds with the Lynx Astro Cable in the Ports (COM & LPT) in your Device Manager.

 

  • Like 1
Link to comment
Share on other sites

  • Open up windows device manager and under ports confirm the LYNX EQDIR cable is registered when it is connected and that the driver has installed correctly (ie no warnings)
  • Select the PORT and right click to select PROPERTIES and then select the second tab PORT PROPERTIES
  • Confirm the BITS per second is set to 9600, databits to 8, parity NONE, stop bits 1
  • Close Device manager
  • Open EQASCOM TOOLBOX  and select DRIVER SETUP
  • Ensure the same port number that you just checked in Device Manager, and select the same baud rate of 9600

 

mod.png.c70c07c253a1f0f3aae5b076f89bd1fa.png

 

  • Click OK to close
  • Power up the mount 
  • From the toolbox select TEST CONNECTION.  EQMOD should launch and make connection with the mount.  To the right of the NSWE buttons are two sliders for RA and DEC rate.  Between them is a drop down option - select 4
  • Use the NSEW buttons to move the mount.

 

  • If the same "No connection" message comes up, power down the mount, remove the EQDIR cable and connect the handset.  Power up the mount and confirm that the handset connects to the mount and doesn't display a "NO RESPONSE " message for either or both axis 

 

 

  • Like 1
Link to comment
Share on other sites

8 hours ago, malc-c said:
  • Open up windows device manager and under ports confirm the LYNX EQDIR cable is registered when it is connected and that the driver has installed correctly (ie no warnings)
  • Select the PORT and right click to select PROPERTIES and then select the second tab PORT PROPERTIES
  • Confirm the BITS per second is set to 9600, databits to 8, parity NONE, stop bits 1
  • Close Device manager
  • Open EQASCOM TOOLBOX  and select DRIVER SETUP
  • Ensure the same port number that you just checked in Device Manager, and select the same baud rate of 9600

 

mod.png.c70c07c253a1f0f3aae5b076f89bd1fa.png

 

  • Click OK to close
  • Power up the mount 
  • From the toolbox select TEST CONNECTION.  EQMOD should launch and make connection with the mount.  To the right of the NSWE buttons are two sliders for RA and DEC rate.  Between them is a drop down option - select 4
  • Use the NSEW buttons to move the mount.

 

  • If the same "No connection" message comes up, power down the mount, remove the EQDIR cable and connect the handset.  Power up the mount and confirm that the handset connects to the mount and doesn't display a "NO RESPONSE " message for either or both axis 

 

 

Cheers Malc, done exactly what you said and success,thank you. And thanks for the other help,its much appreciated

Paul.

  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...

First clear night in a while and again i cant connect again,i originally had the same problem but with the help of @malc-cgot it going.After tidying up my cables i added a usb extension to my laptop,which turns out to be faulty,so resorted back to the original usb,and getting same can not connect message.

I have checked the com ports are the same and all the cables are not loose and still no joy.Obviously i am doing something wrong,but starting to do my head in now.

Link to comment
Share on other sites

17 minutes ago, paul mc c said:

After tidying up my cables i added a usb extension to my laptop,which turns out to be faulty,so resorted back to the original usb,and getting same can not connect message.

I have checked the com ports are the same and all the cables are not loose and still no joy.Obviously i am doing something wrong,but starting to do my head in now.

If you still have the handset, do you get any "no response" messages for either or both axis.  If  not and the handset connects and you can move the mount then that confirms the motor control board is OK.

USB extension leads can cause problems, which is why is always advisable to use active extension leads rather than passive.  I would suggest you try deleting the com port associated with the LYNX cable and repeat the instructions I gave above.  If that fails then the problem may be that the faulty extension cable has damaged the FTDI chip in the EQDIR cable and a new cable may need to be purchased.

  • Like 1
Link to comment
Share on other sites

Great news that the mount is OK.  - Everything is pointing towards the EQDIR cable or the registration of the driver. 

Open up Device manager, right click on the com port associated with the EQDIR cable, and select "Uninstall Device" and then confirm the operation.  If prompted to remove the driver as well, then do so.  Once the device has been removed, pull the USB cable out of the port and plug it back in so Windows detects the hardware and will re-install the driver and give it a com port.  You may find the port number has changed, if so then repeat the previous instructions to set the baud rate etc in both the port properties and EQMOD

  • Like 1
Link to comment
Share on other sites

44 minutes ago, CedricTheBrave said:

Baud needs to be 115200 on the pro at least mine does anyway it would not connect on anything else

Are you connecting directly to the USB port?

It works when directly into the USB port, but not when in USB hub, so may be the hub at fault 

Link to comment
Share on other sites

OK I'm confused... in post #1 you stated you are using an LYNX EQDIR cable... If your mount has an USB port (as the newer versions of SW mounts now have) then all you need is an A-B USB cable to connect the mount to the laptop.  When doing so the port settings does indeed have to be set to 115200 baud.  If you connect via the EQDIR cable, replacing the handset, then the baud rate is 9600.

Personally I never connect the mount via a hub. In the observatory I have two 5m active USB ext cables between the mount and the warm room.  One has the EQDIR cable plugged into it, with the other end directly into a USB port on the PC.  The second USB ext cable connects to a powered hub for the cameras.

  • Like 1
Link to comment
Share on other sites

Are you using a powered USB Hub? If not, you could try using an extra Passive USB Extension just for the mount, if everything else works through the hub. 

Personally, if I were you, I'd start from scratch,  uninstall all the drivers,  eqascom, etc. Set up in the daytime, in the warm, get things working and troubleshoot if needed. 

Setting up outside in the cold and trying to fix things can quickly grind you down and mistakes can be made as you get frustrated. 

When you have everything working, make sure everything connects the same everytime. All connections in the same USB ports, etc.

  • Like 1
Link to comment
Share on other sites

11 hours ago, malc-c said:

OK I'm confused... in post #1 you stated you are using an LYNX EQDIR cable.

Sorry for the confusion,what i meant is it worked when i plugged the cable from the mount straight in to the laptop and not into the hub.so i have ordered a longer EQDIR cable so i can bypass the usb hub.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.