Jump to content

 

1825338873_SNRPN2021banner.jpg.68bf12c7791f26559c66cf7bce79fe3d.jpg

 

Stellarium and Controlling my Synscan AZ GOTO Mount....aaaargh


Recommended Posts

Hey guys. I've been lurking for a week or so now.

Used to be into star gazing as a youngster and fell away. Anyway, bought myself a rubbish ebay telescope just after Christmas and thankfully, withi a fortnight decided it wasn't for me and upgraded to something with a bit more oomph - a Synscan AZ Goto Sky Watched 130p.

Anyway, I'm loving it so far - although my God, howmuch cloud? I've had it nearly a week now and only had about an hour's worth of viewing but Jupiter and it's moons plus M42, I found breathtaking - even the missus loved it, so I'm quids in here, picked a good 'un and all that.

Anyhoo....I'm trying to control the wee fella via a lappy and Stellarium and having zero joy.

I've tried a laptop and even a desktop with no luck. I set it all up (latest version obv) and if I select the correct com port on my USB-Serial adapter it says it's connected but CTRL1 does zippo.

If I change the Com to something wrong it won't say it's connected so I'm confident it's seeing it at least...

Anyway, the icing on an annoying cake is I just went through all the jive to install the Ascom stuff for CdC. Selected Celestron drivers (couldn't find Synscan ones) and press the button and it began to slew immediately - having said that, it then crashed and now says I have no Celestron scope attached but I briefly had control so a) that's much more irritating and :( it means my cable talks to the mount.

Has anybody any ideas? I saw a post from fella on here having exactly the same prob and one day he just seemed to hold down CTRL1 down for five secs, click the target again and it fired into life, but no joy with that for me.

I'm pretty au fait with PCs and will not be beaten but this is getting close after a couple of nights of trying. The scope is currently in my front room with wires trailing everywhere and it's just staring at me like a cocky teenager saying 'come on - next move"

Help?

Btw, I'm enjoying reading these forums, perhaps more than any ever. I'm hook lined and sinkered....

Cheers guys, have a nice night.

Link to comment
Share on other sites

Are you telling the handset to enter PC Direct Mode? Not sure if this applies with your set up but if it does, try not entering PC Direct Mode. That seemed to solve the problem for me.

HTH

.

Hey, thanks for the reply. Yeah tried that, don't think my setup needs it but still no movement. Hmmm.

Link to comment
Share on other sites

Just a thought but what cable are you using to connect. Is it the one that came with the scope. Not all cables (serial/USB) are equal in their suitability. Try the one from Astronomiser. Guaranteed to work.

Edited by Freff
Link to comment
Share on other sites

PC Direct Mode won't work with the ASCOM as driven by Stellarium, CdC, et al. It works with the EQMOD freeware driver system.

EQMOD is a wonderful world of its own for driving SynScan setups, but requires lots more introduction and description than we should do at the moment. Let's look at the other packages.

Stellarium (actually, its add-on utility StellariumScope), CdC, and other planetarium programs that speak the ASCOM language do the driving of the telescope through the emulation of Celestron 5i/8i. You need to select that option IF you are using a hand controller with firmware Ver. 3.xx. If you are using the older (five years or so) version V2.05, then the emulation is Celestron 5/8.

Some computer/telescope combinations are having a bit of difficulty with the latest ASCOM version, some love it. Best practice is to download and install ASCOM according to the home web site for the downloads,

Download Center

This takes a multistep process if you have XP, Vista, or 7: First download and instal ASCOM 5, then ASCOM 5.5 on top of it. You need both. If you are running WIN2K, you need ASCOM 4.1 and performance can be a bit dodgy.

With the latest ASCOM installed, start Stellarium and StellariumScope. Follow the instructions for initializing the computer/telescope installation, using Celestron 5i/8i. If you are using a serial2USB interface, you may have an inadequate chipset; many of the adapters just can't handle the telescope load. Sometimes a trial and error. Belkin definitly has a reputation to avoid.

Back to PC Direct Mode. The motivation for this feature is somewhat murky, as is its behavior. This mode, in effect, disables the hand controller and acts as a straight pipe from the computer/planetarium into the motor controller card in the mount. The historical chain of events was: Lots of folks acquired SynTrek/SynScan systems operating with firmware version 2.04/2.05, not upgradeable. The mount has great capabilities which that version of firmware could not address. So, the EQMOD project was started as a way to tap into the great capabilities of the EQ6/EQ5/Atlas/Sirius line of instruments.

http://tech.groups.yahoo.com/group/EQMOD/

This bit of freeware has enabled me to use my Atlas for satellite tracking, and there are many other awesome capabilities untapped by this wondrous package.

However, it was developed to drive the motor controller card directly; the hand controller is removed from the setup, and the computer is connected directly to the mount with a straight serial cable, DB9 at both ends. The mount, however, would be fatally injured if the serial voltage was not reduced to TTL leve. so an adapter was needed to step down the voltage. Some people built their own, some purchased a unit called EQDir from Shoestring astronomy. Then other manufacturers joined in, some building the interface into the serial cable. In any event, the handset was not a player.

Meanwhile, Synta developed and released V3.01, a new hand controller with an upgreadeable chipset. Still, not nearly the capability of EQMOD. Around V3.20, Synta introduced PC Direct Mode, where the hand controller is used as the step-down tool and passes the EQMOD data through. In PC Direct Mode, the hand controller functions are disabled except for the direction arrows. Before PC Direct Mode, you had to add a joystick or other pointing device to the lappy to drive the scope. Many of us use Rumblepad2 wireless, because EQMOD can address all of the buttons on the joystick to make it like a minicomputer at the eyepiece. However, no one knows WHAT PC Direct Mode really does under the hood, and V3.20 through V3.25 had diabolical behaviors where the hand controller would stop communications with the computer, and start wildly slewing around the sky. This seems to be fixed in V3.27.

That is the use of PC Direct Mode; not intended for the usual planetarium programs, at the moment only seems to work with EQMOD/EQASCOM utilities so if you are running StellariumScope, you won't see any response with this mode. Note also that V2.04/20.5 needed to be manually put into serial mode, while V3.xx modes are always in serial mode. Just select Celestron 5i/8i as the telescope.

Note also that WIndows Vista/7 have many reported "flaky" behaviors with the comm port management. And there are many serial2USB adapters on the market that just don't work. The Yahoo! EQ6 User's Group does a great job of helping people through the growing pains in adapting the mount to a computer connections.

EQ6 : Atlas, EQ6, SkyScan & SynTrek Mounts

I hope this can be of some help.

Edited by Skylook123
Link to comment
Share on other sites

Sorry if this is stating the obvious or is not valid but in playing around with NexRemote it seems the hand-controller uses the direct com port and you assign a virtual port to allow other software to send commands to the mount.

I'd sort of assumed that using software like Stellarium would have bypassed the standard controller software.

Feel free to ignore if I'm talking rubbish :)

Link to comment
Share on other sites

Aha...

sorted. Bought the cable from Astronomiser yesterday afternoon, amazingly it turned up this morning - top service, plugged it in, worked fine.

Seems all cables are indeed not made equal - although it even uses the same drivers..

Thanks for the advice guys...

Paul :-)

Link to comment
Share on other sites

can't see the point in pc control if your not remote imaging/observing too.

just pump in the handset what you want to see. after all you have to be at the scope to observe once slewed

Controlling the scope with stellarium makes it easier to choose what you want as you dont have to mess about with the handbox menus just click on what you want to see (or search) and press ctrl + 1.

It might not be for everyone but I get frustrated scrolling through menus.

Fija

Link to comment
Share on other sites

Agreed,

Granted part of the reason I wanted to set it up was because I knew I could (PC geek in me you se), however, the handset menus aren't briliantly overfriendly for noobs.

With Stellarium I can look and se something I think looks interesting and click on it....rather than not having a clue what it's called.

Link to comment
Share on other sites

yep i get that.

does it then track too?

Yes it does as it controls the scope once it's aligned so with my scope at any rate the sidereal is set on alignment.

Stellarium just passes the RA and DEC info to scope and reads where the scope is pointing so you can use either Handbox or Stellarium.

Fija

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.