Jump to content


ucac4 on cdc


Recommended Posts

Has anyone managed to get UCAC4 working on CdC?

I have unzipped the N & E zip files into a folder: ciel\cat\ucac4 [6990 files 2.25GB]

I have attached two screenprints:

setup.jpg shows the setup screen and the settings I have used

screen.jpg shows the result - a 2 degree fov centred on Polaris. The screen is still only showing TYC stars, even though the magnitude is set to 16.5 and so should be showing a lot more stars from the ucac catalogue.

I am using Cdc v3.8

Any idea what I am doing wrong?




Link to comment
Share on other sites

I think I know. Have you zoomed in enough? The UCAC4 catalog needs a high zoom to appear (you've set it to "min 0 max 5", which corresponds  to less than 20 degrees, no?

sorry, I am being thick, you said it's 2 degrees. ...

Edited by themos
Link to comment
Share on other sites

Nice try, Themos, and I can see your logic.  But when I change the settings to the ones you specify, I lose all the stars from the screen (presumably because a 2 degree field is outside the range of TYC & HIP stars).

There definitely seems to be a problem with the program recognising the data files, but I cannot for the life of me see what I have done wrong.

Link to comment
Share on other sites

Well, this is on a Linux machine, I think I have my Windows CdC configured the same way but can't check now.   I guess you have all these files:

Files content: 
ucac4-catalog-south.zip   : South zone -90 to -30 
ucac4-catalog-equator.zip : Equatorial zone -30 to +22.5 
ucac4-catalog-north.zip   : North zone +22.5 to +90 
ucac4-index.zip           : Search index
Also, I have version 3.9 -svn- 2583 from 2013/09/16
Edited by themos
Link to comment
Share on other sites

I have the N, EQ and idx files - decided not to bother with the S files until I got these working, as anything much below 30S is a bit of a push.

I had UCAC3 working on the previous version, wishing I hadn't removed them, but have now had an inspiration - I'm sure I still have the ucac3 zip files somewhere (as a hoarder, I cannot believe they aren't on a hdd somewhere!).  Will do a search and then will try reloading them instead of ucac4 and see if that works.


Link to comment
Share on other sites

Intriguinger and intriguinger ... or just plain annoying?

Having tried everything I could think of (including completely deleting CdC and reloading with freshly downloaded files) and still not having got it to work, I decided to give it a try (more in desparation than anything else) on my desktop.  The desktop runs XP whereas the laptop runs 7.

Totally different result to the extraction process.

On the laptop I ended up with a single folder containing just under 7000 dat files (for N & E).  On the desktop I ended up with two folders called 'ucac4' and 'ucac4-streak'.  Within each of these folders were a futher 24 folders each (this time using N, E & S), each one covering a different zone of the sky and containing around 500 dat files.  So I am now in the process of copying the result onto a USB drive so I can just load the finished result onto the laptop version of CdC.

So it becomes a question of has anyone managed to get ucac4 working on a Win7 machine?  If so, then it is obviously something weird about me ... I mean 'my machine' :D ... if not, then maybe there is a problem with the original files.

When I have finished copying the files between machines, I will confirm if it is actually working or not.

But I am hopeful (stupid boy!!)

Link to comment
Share on other sites

This is what it looks like on my linux machine, the numbers are megabytes in that folder 

181     cat/ucac4/n0730241     cat/ucac4/s1500108     cat/ucac4/s6730234     cat/ucac4/s373081      cat/ucac4/n6000266     cat/ucac4/s523011      cat/ucac4/s8230166     cat/ucac4/n2230294     cat/ucac4/s2230149     cat/ucac4/n373046      cat/ucac4/n6730238     cat/ucac4/s450036      cat/ucac4/s7500180     cat/ucac4/s0730180     cat/ucac4/n1500268     cat/ucac4/s3000165     cat/ucac4/s0000129     cat/ucac4/n523025      cat/ucac4/n7500157     cat/ucac4/n4500166     cat/ucac4/n30008       cat/ucac4/n8230227     cat/ucac4/s6000163     cat/ucac4/n00006093    cat/ucac4
1       cat/ucac4-streak/n07302       cat/ucac4-streak/s15001       cat/ucac4-streak/s67301       cat/ucac4-streak/s37301       cat/ucac4-streak/n60001       cat/ucac4-streak/s52301       cat/ucac4-streak/s82301       cat/ucac4-streak/n22302       cat/ucac4-streak/s22301       cat/ucac4-streak/n37301       cat/ucac4-streak/n67301       cat/ucac4-streak/s45001       cat/ucac4-streak/s75001       cat/ucac4-streak/s07301       cat/ucac4-streak/n15001       cat/ucac4-streak/s30001       cat/ucac4-streak/s00001       cat/ucac4-streak/n52301       cat/ucac4-streak/n75001       cat/ucac4-streak/n45001       cat/ucac4-streak/n30
Link to comment
Share on other sites

Thanks, Themos.  Yes, that is what I now have and have transferred from desktop to laptop.

I have attached another two screenprints of what is happening now, because otherwise you won't believe me.

PDE shows the folders that are available in Ciel\cat on my file manager program.

cdc shows the folders that are available in Ciel\cat on CdC.

Same folder, but there are two fewer folders available, and yes, you've guessed it, they are ucac4 and ucac4-streak.

How does that result represent any sort of logic???

And I have tried simply typing in the path on CdC, and although it accepts that as a typed entry, it is not possible to change the red button to green.




Link to comment
Share on other sites

Hm, my linux installation does not have the .idx files but it has 4uc.ixr  files much bigger than this

       1251 /usr/share/skychart/cat/ucac4-streak/4uc.hdr    1064184 /usr/share/skychart/cat/ucac4-streak/4uc.ixr       1251 /usr/share/skychart/cat/ucac4/4uc.hdr 2502097862 /usr/share/skychart/cat/ucac4/4uc.ixr
Link to comment
Share on other sites

Sorry, yes they are ixr files.  My frustration is beginning to affect my typing.

As to the difference in size, there was a problem converting the index, but according to the installation instructions the index is optional (if you want to search) anyway.

But I cannot see that that would make any difference as to whether Cdc can see a folder on the C drive or not.  It can certainly see folders that have nothing to do with Cdc and therefore have neither hdr nor ixr files (eg folders in my 'Drivers' folder) - not that I would actually be able to load anything from them, but it can see them.  So why can't it see the ucac4 folder when it is clearly visible to the system, as demonstrated by my file manager program being able to see it?  That's what makes absolutely no sense to me whatsoever. 

Link to comment
Share on other sites

Here is the reply I got from the bug tracker site:

From your description this is a problem with the Windows Virtualstore.

The Virtualstore is a place where Windows write the data if you are not allowed by the UAC to write at the location you request.

The short answer to solve this problem is to install the UCAC4 files in another place you have full write access, for example Documents\ucac4

Here some more information:

On a typical Windows 7 installation the "C:\Program Files" folder is not writable without a privilege elevation. This is why you have to click a confirmation box when you run the setup program that install the software.

The program you use to unzip or copy the UCAC4 files do not request this privilege elevation, so Windows write the UCAC4 catalog at the following location instead:
C:\Users\[username]\AppData\Local\VirtualStore\Program Files\Ciel\cat\

Then by some magic it add the content of this folder to the original when you browse it with the Explorer.
Unfortunately all the Windows file functions do not follow this logic, and sometime the added files appear missing.

I not recommend you disable this folder protection for security reason, so the best solution is the one indicated above.

Please reopen this issue if it is not solved after installing at another location.

Rather surprised by this, because I always log in as administrator, and I didn't think that had any permission restrictions. Anyway, I have placed the unzipped files into a folder c:\cdc-ucac4 and it is now working fine.

Link to comment
Share on other sites

  • 8 months later...

Hi Sorry for digging up an old thread, but I found the solution to this and thought I should share it.

The solution is to install the north south and equatorial sections of the catalog into separate forders.  Then add each header .hdr file as a separate catalog.  If you install as pere the CdC documentation and overwrite each header file from one region with another only the last installed header file region will show.  The Cdc instructions says that its ok to overwite the header files as you unzip.  It's not ok, ypu need all three files and the only way to do that is to put the 3 regions in separate folders.

Hope this saves someone some head scratching.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.