Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

Welcome to Stargazers Lounge

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customise your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    sgl_imaging_challenge_banner_solar.jpg

     

Sign in to follow this  
Followers 0
Steep

iOptron handset firmware upgrade anyone?

13 posts in this topic

I got a new iOptron Smarteq Pro this week and have been trying to upgrade the handset firmware without success. I'm wondering if anyone who has managed a firmware upgrade on any iOptron could tell me what usb/serial adaptor they used (if you did use one).

My issue is that I can't connect to the handset, the upgrade utility tries to connect and fails every time. I've tried different PCs (Win10 and older XP) with different  RJ9-DB9 leads including one I made myself so I'm left with the USB-Serial adaptor, there are different chipsets and I've tried with two kinds, PL2303 and an older FTDI lead that upsets my win10 PC greatly but I have no idea if the chipset matters.

Share this post


Link to post
Share on other sites

Posted (edited)

Do you need to upgrade?

Additionally I was considering one as a small goto to throw in the car with a small scope and did a search a few days back. Altair have none in stock, Tring no longer list them, and when I search on 3 EU sites the mount has disappeared from sale. Which left me puzzling over what had happened.

Just found the iOptron site nad they list the SmartEQ on there but I notice that if you go to the support, then Firmware, that the firmware is specifiecd as that for the ZEQ25, which in itself is a discontinued mount (the CEM25 has taken over).

One thought is that the Utility knows it has ZEQ25 firmware and is talking to a SmartEQ and the 2 are likely to be imcompatible so it is refusing to connect.

Actually slightly surprised the iOptron handset has a serial port on it, thought they would have made it all USB. One option is to reduce the USB speed to the lowest, it sometimes helps.

EDIT: Seems I may need to consider an alternative or get a used one: https://www.skiesunlimited.com/ioptron-smarteq.html

Not sure how this would effect the support and firmware in your case as it shouldn't. There an iOptron users site/forum that might be an option to go to.

Edited by ronin

Share this post


Link to post
Share on other sites

Actually the port speed is a possibility I hadn't though of, thanks for that. There is a specific smarteq firmware listed and one of the improvements is for skyfi connection which I hope to be using. I don't have the skyfi adaptor yet so I may not need to upgrade but as with all new things you like to fiddle (or at least I do...) and of course it's been constant grey skies since it arrived :(

I managed to find mine at Green Witch after much hunting but it was the last one in stock (show model), Lee gave me a good deal on it and I suspect it's being discontinued. It's ideal for my needs though, very light weight and easy to set up, just right for carrying the 80mm ED. I've found a couple of issues with it related to my far North latitude, the latitude adjustment bolt is too long and catches on the polarscope lower cover so I have to leave that off at least until I find a suitable replacement bolt.

TS Express do have it listed though at a very high price.

Share this post


Link to post
Share on other sites

We own an Ieq30 and Ieq45. When we've had an issue I email Ioptron themselves, they are good at responding. The other option is to speak to Ian at Altairastro, they're the importer for Ioptron.

The other option is  not to upgrade the firmware if everything is working, as has already been suggested, my 30 is not on the most recent firmware. I do connect using a laptop to control the mount for imaging and I use a Trendnet make of USB to serial converter which I bought from Widescreen Centre.

Anne

Share this post


Link to post
Share on other sites

I am hoping to pick up a small scope and thought of the SmartEQ for that, as you say it is small and lightweight. I did look at them a few years back, over at Tring, but the scope I wanted to put on it was a 90 ED and the mount just didn't look as if it would handle it. Really the tripod looked to light, and I partially object to the idea of buy a mount and have to get the upgraded tripod simulatneously.

To an extent since it looks like it is ceased production now, I am stuck.

The Skyfi could be useful (or fun) to have so the upgrade may be relevant. I have a little old Meade that simply cannot be upgraded so I never have to concern myself with the option. Which basically is why I asked.

Sometimes I wish I could make a bit of sense concerning what iOptron are doing.

Since mentioned and absolutely nothing to do with the question, but I see that Widescreen have relocated to up my area, they are now at Sutton close to Ely.

 

Share this post


Link to post
Share on other sites

Posted (edited)

Ronin, I'm not sure now that they are discontinuing it, only one supplier seems to have listed that. It's possible that they are just waiting for the next batch from China so unless you find a suitable substitute meantime just keep an eye out.

Anne, thanks I emailed them as well yesterday, don't expect an answer till tomorrow at the earliest though.

 

/Edit - tried everything I can think of with port speeds and settings, no luck.  Also tried iOptron commander and it can't see the handset at all so I'll need to wait for support to get back to me and hope they have some ideas.

Edited by Steep

Share this post


Link to post
Share on other sites

It seems a little odd as that is their sort of small entry item, the next is the CEM25 now and in a way a big jump form nothing to a 25lb mount. And that has undergone a few alterations and possible hiccups before it has ended up at the specification it is.

As you have selected it for is the same as my consideration - light weight scope on a small compact goto. No urgency so I will wait and see what transpires. Ever had the idea they may "update" it and produce something worse then the original. The change from the ZEQ25 to CEM25 was a bit painful and still unsure what the state actually is.

If you have a multimeter have you checked the pin to pin connections - they are in the pdf download - for serial to USB. Just wondering if they are wrong but I think you said you had 2, and even if 1 is wrong I doubt both would be.

Hope you get the solution, it is usually something simple/stupid. In a way it might be better at present as you do not get connection then fail halfway through a download.

Share this post


Link to post
Share on other sites

Yep, tested every lead umpteen times. I'm beginning to think I may have a duff handset, though it works solo nothing will connect to it via the port.  I think I missed the delivery of the skyfi today, if it is that I'll pick it up and try connecting it, that will be a completely different set of cables and equipment, a good test.

Share this post


Link to post
Share on other sites

update - iOptron support (who will only answer one email a day no matter when it's sent) suggested using an FDTI chipset cable so I bought a new one of those but it BSODs the instant it's plugged in on Win10 the same as the old one did. I have one option left, I've ordered a pci card to add serial ports directly to the PC. If that doesn't work I think the handset must be faulty.

The iOptron Starfi wifi adaptor arrived and it doesn't work with my iOptron mount either without an 'optional' USB to RJ cable linked to a separate power supply. Naturally no-one in the UK has stock, iOptron want $22 plus another $22 postage to supply one and that just bugs me (it's a 50p cable). Support "don't know" how the cable is wired even though every other port/cable's wiring for every mount is diagrammed in their manuals.

Share this post


Link to post
Share on other sites

Update to the update.

 

I decided to go ahead and figure out the wiring for the Starfi myself Diagram below for anyone who might need it. The Starfi cannot see the mount either though so it must be a faulty port on the handset. 

 

 

6p4ciOptron.jpg

Share this post


Link to post
Share on other sites

For reference, this is the wiring diagram iOptron sent me today.

 

596c5f9c7b335_starfipowrerwiringdiag..jpg.2e1e060db46555b4ec69d3a4b993c8ae.jpg

Share this post


Link to post
Share on other sites

One further thought, which version of Ascom are you running? I had an issue when I replaced my IEQ30 with the pro version. It needed the newer version of Commander which needed at least Ascom 6.2 to run it, IOptron sent me the previous version for my mount as I was running 6.1 on an old XP laptop. The newer version and Ascom 6.2 work perfectly on my W7 laptop.

Share this post


Link to post
Share on other sites

Thanks Anne, 6.3 but that only applies to direct control of the mount. Firmware update and the Starfi don't use it.

I'm arranging for Altair to check/test the handset so hopefully I'll have some good news soon.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.