Jump to content

Banner.jpg.5ed196c1e70861ebc79109e023c96067.jpg

Kendrick


syd_malicious
 Share

Recommended Posts

After nearly giving up trying to buy Kendrick items from the UK I approached them directly in Canada.

I got quick (quicker than most UK suppliers) emails and they were prepared to help me as much as possible with postage issues etc.

The quoted postage was not hughely more than UK prices either.

In the end I sourced a UK stock just before buying from Canada but in future I would actually approach them directly.

Overall a very positive experience and highly recommended.

Paul

Link to comment
Share on other sites

  • 6 years later...

I felt that I had to write and advise of my poor experience with Kendrick Instruments.

I purchased in January a DigiFire 12 Dew Controller from them, at the first attempt to use it the output socket fell to pieces, in addition I could not get any power output from the ports, I sent it back to them under warranty, they tried to charge me for the return postage, even though it broke under warranty. Upon them agreeing to returning it I asked them three times "Had the checked the power output", they never acknowledged or confirmed it.

Now there had been some other emails initially where they accused me of wilfully breaking the connection and calling me a liar as they did not believe that the connector could break, however...

After successfully arguing my case they returned the dew controller and it arrived at the beginning of this week.

I checked the outputs and there was no power still, I politely contacted Kendrick in Canada and they accused me of tampering with the unit.

My email was: -

.....I did ask but guess you missed it, did you check the output of the DC power outlets as I cannot get a voltage out of it, maybe I am missing something, but I have read your instructions and in either of the sockets from power on there is no voltage.

I have read and followed your instructions “At Power-Up Settings: and still cannot get a voltage on my meter.

Any assistance would be appreciated.

I agreed to send them a video of the unit demonstrating that I was doing everything correctly.

They sent me this reply: -

Does the unit power up?

What are you using as a power source?

Are you using the original power cord? It has a fuse in the cigarette lighter plug. Is the fuse blown?

Have you tested your voltage meter on anything else? Try a 9V battery.

I replied as follows: -

I have now created some videos and an image showing the following: -

1.    An Image of the type of PowerPole connecter that I use to feed my 12v devices.
2.    A quick video of my switching on the unit to show that I have power and that the unit is working.
3.    A quick video showing 0.02v output from the 12v output of the controller
4.    A quick video showing 0.03v output from the 8.4v output of the controller

These can be downloaded in a zip file from this link: - https://drive.google.com/file/d/1HzLEblvQ1uhFSSI4JQTsrO5PjtXudqGB/view?usp=sharing

I am fairly patient XXXX, but when I sent this back I did state that this was the fault and prior to you advising that it was being returned I asked 3 times whether you had checked that and didn’t get a reply (Check my emails to you).

It cost me £15/$30 to send this back the first time and I was without it for nearly 5 weeks mainly because of Canadian Customs, if I have to do this again then I will have similar delays and costs, I really feel that Kendrick should send me a prepaid waybill for UPS/FedEx as this problem has clearly not been fixed and is a second time warranty return.

They wrote back this morning saying: -

Voltage on those ports was tested in our shop.

There is not much to see in your video, but it appears that you have a barrel connector connecting to you multi meter. As stated in the user guide, those ports have a 2.1mm centre pin, not 2.5mm. If you are using a 2.5mm connector, there is no electrical connection.

The video also shows a external nut you have threaded onto the barrel connector. That is not an approved owner modification and it is quite likely how that connector broke in the first place. Those connectors are soldered to a circuit board. They are not chassis mounted, but even if they were, over tighten the nut is going to break it. 

That nut could also explain why you can’t get an electrical connection. The user guide states the official model of barrel connector that will work with those ports. The nut I see in the video will prevent the recommended plug from being fully inserted, and thus, not work.

John, please try not to be offended, but we have both spent considerable time troubleshooting the symptoms. This is a mature product and we just don’t have any issues like the one you are seeking help with. Please be advised that you are not using the product the way it was delivered or intended to function. We believe this is the reason that you are having problems and we consider the case closed.

My reply to them today was: -

XXXX,

I am absolutely dumbfounded with your email, let me just make it very clear to you: -

1.I am using a 2.1mm connector, all of my Astro equipment has 2.1mm connectors as you can see in the photos. Why would I fit a 2.5mm when all of my equipment uses 2.1mm

2. The two external brass nuts are fitted with an insulator so that it won’t fracture any soldering through fitting the jack plugs on and off and are only hand tightened as I was worried that continual plugging and unplugging may fracture solder joints and I’m really surprised that they weren’t fitted on the first place. And any way the box is plastic so I could have hand tightened the nuts direct and it would have no effect whatsoever.

3. How could that nut prevent the plug from being fully inserted when you can clearly see that there is plenty of thread left exposed.

4. I have not made any modification whatsoever to the unit with the exception of modifying the power lead as recommended by your user guide so that it can use the Anderson power pole connection.

5. If I need to then I will take it to an electronics expert for their assessment in support of a legal claim that I will make against Kendrick.

I have never known a company like yours where clearly you have tried to worm out of fixing what was originally faulty, whether it be the original 12v output falling to pieces or whether it is the output sockets not working and have never worked.

I do not believe that the voltage was checked correctly as it was sent away and returned with the same fault. I asked three times and you never bothered to reply.

The nut they are complaining about is the brass one with a plastic washer, which I tightened by hand to stop the socket fracturing the solder on the PCB which really shoudl have been secured rather than floating in space.

The image of my holding the broken part is the exact reason why I screwed the brass washers onto the case so that the connector could not wobble about as you can see in the image of the two output sockets one with the brass washer fitted and the one as they supplied originally without, you can see how fragile such a connection would be.

I decided to call them this afternoon and spoke to the owner who answered the phone very aggressively and then put the phone down on me.

This wasn't a cheap item, altogether it cost me $469.00CAD and I got slammed with a £98 customs charge as well when it arrived.

Sadly I wish all companies were as friendly as FLO to deal with, but they aren't.

In this instance I have filed a claim with PayPal and American Express, but I just thought it helpful to other members on here to be aware what Kendrick are like to deal with.

Mods if this isn't allowed then please advise, thanks.

2.1mm.JPG

Kendrick.jpg

IMG_5155.jpg

IMG_5156.jpg

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.