Jump to content


Asi Air Pro USB power limitations and random disconnects

Recommended Posts

This might be useful to others.

I've been chasing a seemingly random disconnect issue with my AAP.

The guide camera would disconnect, and sometimes the mount, during autorun sequences. The AAP App display would show the guide camera greyed out and inaccessible (not showing on the drop down menu), guiding would freeze, and if I halted autorun, sometimes it wouldn't restart. I would have to shut down, reboot and restart everything. Quite infuriating to put it mildly

I changed the standard cables to decent quality, tied off the cables to prevent random USB disconnects due to movement, with no improvement

Then I realised that I had the guide camera plugged directly into the AAP USB2 socket, along with the EAF, main camera and USB pen drive in USB3

Apparently the max power rating on all 4 sockets is around 6W on 5V. A quick tally indicates that I am likely drawing more than that during pen drive write periods.

The 533 USB2 hub is powered from the separate 12V camera supply, so by connecting the guide scope and EAF to that hub rather than directly to the AAP I will reduce the current draw on the AAP and hopefully problem solved 

So far it seems to be working. A test run on the balcony has no disconnects 

Link to comment
Share on other sites

My pro kept disconnecting randomly during plans which was infuriating, I did suspect it was power draw causing the issue so I removed the WiFi extender usb cable and powered that piece separately, worked fine since. Since dew heaters draw so much power I also power them separately. Strange though that my sct dew heater ring works fine via the 12v out though, all other equipment being the same.


Edited by Elp
  • Thanks 1
Link to comment
Share on other sites

I've bought the Pegasus micro and run it in dumb mode (standalone). I power the ASI from this and the camera via separate feeds. 

I still have the dew heaters connected to the ASI, they draw less than 1A maxed out so no worries there. 

Hopefully problem solved! 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.