Jump to content

740427863_Terminatorchallenge.jpg.2f4cb93182b2ce715fac5aa75b0503c8.jpg

Problem with our LX200 gps


Recommended Posts

hi

we have been having problem with our Society 12" LX200 gps we are having to problems.

1,

Minor point - easy to fix: The display on on our handset no longer works it just stays blank. i think this is just going to be a case of buy a new one.

2,

Major point - less easy to fix: The azimuth motor only turns in only one direction, it will move to the right (clockwise) but will not move to the left. we have tried with another handset thinking that may be the problem but no luck.

i don't know if this is a common problem of not but i would welcome any help you can give

thanks

glen

Link to comment
Share on other sites

My 10" handset packed up and had to be sent to Telescope house for repair. I now keep it indoors with some silica gel, and also have sprayed a little WD40 into the hbx socket on the main scope to keep out damp.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.