Jump to content

290128050_ConstellationBanner.jpg.6eb5d1fe82e0853d4c3b80a745d12d74.jpg

EQ5 and EQ3 pro goto motor firmware upgrade problem solved


lguise
 Share

Recommended Posts

Mods please move if this is in the wrong section.

Thought I would share this in case anyone is searching the web for a solution to the same problem I had.

I bought a second hand EQ5 pro this summer to evaluate the motors and goto system, I’m thinking of upgrading a Vixen GP to this system. ( The EQ3 pro has pretty much the same system I believe)
The firmware on the EQ5 handset needed updating and using an old PC with a serial port this was achieved in minutes using the supplied cable. The old PC avoided problems others have encountered with some USB to serial converters.

Anyway, thought I was on a roll so would update the motor controller at the same time. This was on version 2.04, version 2.07 promises better performance at low speeds. The instructions detail using the handset in PC direct mode to relay the firmware to the motor control box. Mine is an older model, I gather newer ones have a USB port.

Rigged it all up, clicked upgrade on the software and…….. it wiped the 2.04 version but refused to load 2.07! Motors now unresponsive. Instructions say cycle power and retry, lost count of how many times I tried this. Then tried other versions of the loader software and the old 2.04 firmware etc, no joy still unresponsive.

Searched on the web for a solution, found nothing. Reached out to Malcolm (Malc-C on SGL) who had contributed to various posts about EQ5 pro problems, he suggested using an EQDIR cable direct into the motor box instead of using the handset in PC direct mode. Luckily a friend (DAZ on SGL) had the correct lead and the upgrade went through in less time than it took to brew the tea!

So thanks to both SGL members problem now solved. 
 

##### NB It is very important to use the correct EQDIR lead (available from FLO), this reduces the voltage to the motor box and prevents blowing the board. Thanks to Malc-c for making this clear. ####

 

Hopefully anyone searching the web in desperation, as I was, will find this post and will get the same flood of relief when they see the upload percentage ticking away!

Best wishes

Linton

B2494DC4-7E5F-45C3-B25E-64CD74AC641F.jpeg

Edited by lguise
Tidy up
  • Like 2
  • Thanks 1
Link to comment
Share on other sites

  • lguise changed the title to EQ5 and EQ3 pro goto motor firmware upgrade problem solved

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.