Jump to content


Calibration in PHD2 failing with Star Adventurer


Recommended Posts

I see there are a few topics on this so sorry in advance it annoys anyone.

I have a Star Adventurer that I works well for unguided astro shots, but I am keen to now get it actively guiding via PHD2.  The only problem is that it doesn't seem to be working.  I am getting the dreaded "The star doesn't move enough during RA calibration" message when I try to calibrate.  Things seem to move in one direction (which I think is West), but I don't see any evidence that it is moving in the opposite direction.  So my question is, when asking the mount to move against it's standard rotation, does it actually go backwards, or just slow its rotation to allow the starts to 'catch up'? 


Info on what I have done / set up if it informs things:

I am in New Zealand so Southern Hemisphere (as set on the SA).

Set up is ZWO ASI 120MM-S with mini-guide scope, using the on-camera ST-4 port to the SA.  Laptop is running PHD2 (also tried the ASI app).  Polar alignment completed successfully in SharpCap, then PHD2 for guiding.  I've set the 'dec guide mode' to off in PHD2 and entered the declination of my target. 

I have tried manual guiding and the LED's on the SA flash when I tell it to move East or West (which I believe is a good thing) and they do nothing when I try North or South (which makes sense as the SA is a RA only mount),

I have let PHD2 choose the guide star.  Binning is 1, focal length 120mm, 8 bit mode in SharpCap but don't think you set that in PHD2?

I have used the brain calculated 'calibration step' and increased it manually (to 3000ms).

Log attached but it will include a bunch of tried and failed tests in there.  If the clouds clear, I will try again tonight...

I think I had the calibration work once, but not sure what I did differently then (and I may have done something stupid and fooled the calibration)


Edited by Sylvester111
Link to comment
Share on other sites

You cannot guide without a good calibration first. The mount appears to be moving but so slowly that it might just be drift. What declination did you calibrate at? You will need to calibrate on your target but for testing you should calibrate near dec 0 to get the maximum RA movement. Cable issues are very common with ST4 so that is a possible cause. 

You could try the manual guide option on the Tools menu or the Star Cross test (although it wont show anything for Dec of course) for more data on the problem.

EDIT: As to your question n east movement: this just slows down the mount so there is no backlash. But when you move to your target, before calibrating make sure the last movement of the mount is north and west to remove any backlash.

Edited by kens
Link to comment
Share on other sites

Thanks Ken,

Usful to know it slow down rather than reverses. I can try a bit more of a test now. Still cloudy here but hopefully tonight. 
for Dec I had been using the dec of the target, but I will try it at 0° for testing. Cable should be good as it’s brand new and came with camera. Lights flash on SA so it looks like it’s receiving commands. 

thanks again!


Link to comment
Share on other sites

Was able to do a number of tests last night. First lesson was that the guide commands don’t get to the SA unless the ST4 cable is plugged  in after hitting ‘connect all’ in PHD2 for some reason. But still no guiding at all. Movement stays at normal sidereal rate no matter what is sent. I was worried my rig might be too heavy, but even with just the guide camera and miniscope there was no difference. I’ll have to wait till I get home to have a look at the wiring / pin outs to see if there’s an issue there. 

Link to comment
Share on other sites

From the PHD2 Log:

During Calibration PHD2 is moving the mount in RA.

All the Calibrations were carried out a 1800mS Calibration Step Size, I can't see any at 3000mS ?

On your only attempt at guiding, PHD2 calculated the Guide Rate was only1.7arcsecs/sec, you need at least 8arcsecs/sec.

PHD2 calculated the PA error during that guide attempt as 23arcmins, you will need better than 5arcmins if you're not guiding in Dec.

Guidecam focus was HFD =4.46, try getting that lower by watching the HFD reading in the Star Profile window as you adjust.


Link to comment
Share on other sites

Thanks for that, I’ll give all those suggestions a go. Unfortunately I’ve had to come back home from holiday and I get a lot more cloud here. But very luckily I can see the SCP from my apartment balcony just over the block opposite. Nothing to photograph (and I might make the neighbours nervous with a telephoto lens out there!) but it should be good enough for guide testing.

I used SharpCap for PA and can’t remember the final score but it was an ‘excellent’ alignment  

The other good news is that I stuck a tape measure to a wall and the SA is acting upon east and west signals sent to it. Normal rate to cover 5cm at about 7m was 1m45s, with me pressing west all the time (a series of 3 second pulses) it was 1m20s and then east was 2m30s. 

I’ll keep cracking on!

Link to comment
Share on other sites

  • 2 weeks later...


Although I am not 100% sure why...

I completed the Polar Alignment with SharpCap as per usual and made sure I have an 'excellent' polar alignment.  I then swapped to PHD2 and made sure the focus was better than before.  I initially tried a calibration in the same way as I have done it before.  I left the guide camera alone (so still pointing in the rough direction of the SCP from the PA) and tried to calibrate.  The guide star barely moved and I cancelled out of the cal early as it looked like it wasn't going to be any better than before.  Your suggestion that the guide rate was too low, made me try moving the guide scope a bit (I basically twisted it to the left of the SCP) and tried again.  Boom, calibrated in a dozen or so steps and then seemed to guide really well.  PA error was just over 5 arcmins I think and the HFD was bouncing around a bit but seemed to be nearer 3.5 / 4.

The only thing that confuses me is quite what I have done to make it work?  I think I have tried all this before, with the only difference being I point my DSLR at a target before calibration (my guide scope is normally attached to an L bracket on the camera body) rather than just turning the guide scope to slightly off the SCP. 

I didn't get a chance to try pointing the guide scope elsewhere with my camera. 

Do you think my improved focus / possibly improved PA would have made the difference?

Are there any 'rules' about where a guide scope needs to point to get a good cal?  I'm just wondering if I need to get a dual dovetail and have the guide cam separate from the DSLR?


Thanks again, I'm excited to see if I can thread the needle twice and may even take a photo.



Link to comment
Share on other sites

When you are pointing at the pole you will see very little movement in RA. The circles of RA get smaller and smaller as you get near the pole like latitude on earth. But it still takes 24 hours to go around those circles. So near the pole the movement around the circle is very slow. The movement is largest at dec 0 - aka he celestial equator/CE

Your guide log shows you took 26 steps to calibrate. Assuming the guide rate, pixel scale and calibration steps are all accurately calculated that would suggest you were pointing around dec 60 or 70 where the RA movement is about half what it is at dec 0.

With mounts that report their coordinates, PHD2 can calibrate near dec 0, where it is most accurate due to the large RA movement, and use that calibration on any target by applying a correction to the guide pulses.

Using the On Camera mount this is not possible so you must calibrate on target. You can try adding as an Aux Mount the "Ask for coordinates" driver. This asks you where you are pointing every time you guide and allow PHD2 to make the necessary corrections. You don't have to be precise - within a few degrees would be ok.

Why did it work this time? Could be any number of things. The main one I can think of is that previously you had not allowed the RA backlash to clear before calibrating, after moving onto your target. Or you might have been calibrating too close too the pole

Can you clarify something you wrote above. You gave me the impression that you move the guide scope relative to the DSLR so they are pointing in differenet directions. That's a no-no


Link to comment
Share on other sites

Thanks Ken, very informative.

I'll try the 'Ask for Coordinates' driver next time.  What I had been doing was going into the settings (brain) and adding in just the DEC value for my target, but coordinates might be better (and I wont forget if it asks each time).  I suspect I was calibrating too close to the pole when I was doing my initial tests, I'll try calibration on-target next time to see how I go.  I've been trying to get this working in sporadic tests and learning all the time, so I might have fixed a few other things along the way that could account for it!

As to moving the guide scope and DSLR, currently I have them connected together on the same bracket so both point in the same direction.  I was wondering whether having the guide scope fixed to the mount and guiding in one place in the sky, but the DSLR pointing at another, might work (then I wouldn't need to re-calibrate each time I changed targets for the DSLR as the guide scope wouldn't move so would be following the same star)?

Link to comment
Share on other sites

4 hours ago, Sylvester111 said:

I was wondering whether having the guide scope fixed to the mount and guiding in one place in the sky, but the DSLR pointing at another, might work (then I wouldn't need to re-calibrate each time I changed targets for the DSLR as the guide scope wouldn't move so would be following the same star)?

Simplistically that works because the angular corrections would be correct. In reality, a large deviation between the guide camera and imaging camera leads to field rotation from polar alignment error. Plus it is simpler to just tell PHD2 what the declination is and let it adjust than to repoint the guide scope.


Link to comment
Share on other sites

Cool. That makes sense. 

And more success from my end. I think there may be a driver or hardware issue between PHD2, my ASI120MM-S and the Star adventurer as far as ST4 goes. I seem to have to unplug it and reconnect it between each stage in PHD2 (from calibration to guiding) or the mount doesn’t receive commands. Not a great price to pay now that I know it’s an issue. 

One other strange thing was I did a very accurate polar alignment in SharpCap, moved to my target star and failed on the calibration. So I did a drift alight and found the PA was quite far off. I was meticulous in my movements and the mount didn’t shift, as I found my target. Anyway, after a bit of fun getting the drift alignment in, I was able to calibrate and guide on a target as a test for 4 minutes at 500mm with very little streaking. Excellent result!

I’ll keep playing, but thanks for all the advice!

Link to comment
Share on other sites

  • 3 months later...

Hi. I recently searched this issue and landed on your post. I found it strange and I have been having the same issue since the past week. Same SA, same ASI 120 MM-S. I am using a small telescope as guide scope. Sharpcap recommends about 200mm for polar alignment. My scope gives me 220mm or 180mm with a focal reducer. Same sharpcap pro for polar alignment and same PHD2 for guiding. I am failing the calibration each time and have been wasting quite some amount of precious clear skies. Most of the time I am calibration fails and phd2 tells me “RA calibration failed; star did not move enough”. I have been able to proceed with calibration but one (I ignore how I did), that too it offered poor guiding and I received a further message informing that I have lost the guide star, I did not have enough correction east or west..

I felt there’s an issue with the connection of the guide camera-ST4 cable-SA… I lack further equipment to trial out any suspect.

Any advice will be highly appreciated. Thank you for the precious help..

Link to comment
Share on other sites

Hello. I tried setting up guide system again. I tried to follow whatever i learned on this thread. The main thing i tried to improve is the calibration, which i now do close to declination zero to get maximum shift in RA. And bingo, I was able to guide for the first time and it seemed pretty good. I am unsure about other settings i might have mingled with. Thank you Michael. If i am having issue with calibration again, i will post a log with the faulty calibration. 
1. i wish to ask whether i have to do the calibration everytime close to declination zero?

2. do i have to redo a calibration after i repostition my guide system? If i move the guide system, i feel that it does not do proper guiding and if i redo the calibration, it guides good. (Could it be unstable mount?)

Thanks so much everyone here and thank you again Michael. 

Link to comment
Share on other sites

Hi. To be honest i have been trying to learn from forums and videos from astrophotographers. I am sure you are right. I will delve into the proper guides as prescribed. Thanks for the useful links and advice. Good day


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.