Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

  • Announcements

    sgl_imaging_challenge_banner_lunar.thumb.jpg.ef4882eb5fb3610f8a68e5e6913de0e3.jpg

AaronLPK

New Members
  • Content count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About AaronLPK

  • Rank
    Vacuum

Profile Information

  • Location
    Stockton on tees
  1. Ok thanks guys I will do this as soon as I can but unfortunately its raining at the moment lol.
  2. Hi all, about a month or two ago I bought this telescope as I wanted to get into astronomy, and when it arrived I set it all up with no problem. And then a couple days later I went out side to take a look through and all I saw was a big white circle with the front spike cross going through it. After I had found this problem I decided to go on here and ask, someone said to collimate the mirrors as they may be out of focus, and so I bought a laser and I then focused the two mirrors. But that night when I went out I saw the same thing, what do I do??? And I was just looking at some stars.
  3. Help!!!!

    hi again, its been 5 weeks and my laser finally came, i went out that night and i collomated my telescope, but still i see the same exact thing. any other advice???
  4. Help!!!!

    Ok thanks I have just ordered a laser now so hopefully it will come soon thanks a lot
  5. Help!!!!

    Yeh I've done some research and I think the primary mirror is out of focus so I will try to sort that now. Thanks
  6. Help!!!!

    Hi, i just bought a skywatcher explorer 200p and yesterday when i went out side to have a look, i would look through and see a bright circle with the front spikes in. what do i do to fix this???
×