Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_dslr_mirrorlesss.thumb.jpg.5b348d6a5e7f27bdcb79e9356b7fc03b.jpg

Chiz

Problem with Dual-Axis D.C. Motor Drive for EQ3-2

Recommended Posts

Hello,

About 18 months ago I bought my first scope - a Skywatcher 150PL on EQ3-2. At the same time I bought a dual axis motor which has worked just fine - until now.

On Friday night I was having fun trying to image Saturn and all was well. The I noticed it had stopped tracking and the red light was permanently on (it is normally green when no buttons are pressed and the RA is tracking). I tried all four buttons - they all clicked as normal and none of them seemed to be stuck.

The one page set of instructions says that the LED should flash if it thinks the batteries are on the way out. I checked them with a digital voltmeter and that said they were putting out around 5.9V.

Last night I tried again with 4 new batteries (voltmeter said they were just over 6V) and the problem still persists. I tried it without the scope & counterweights to see if that made any difference, unplugging the connectors to the motors etc., but nothing has helped.

If I press any of the buttons then these have no effect - all I have is the solid red light and no tracking :D

As I said, I've had the scope & motors since around Nov 2009, but due to a number of reasons I have not used it anywhere near as much as I would have liked. Each time I have used it things have worked fine. In total it has probably had less than 24 hours usage. It is all stored indoors in a dry environment (not in a cold damp shed) and everything looks as good as it did when it was new.

I'm sure I'm not the first person to have encountered this problem and I hope someone out there knows what is wrong, and more importantly, how to fix it.

Help, suggestions etc. welcomed

Thanks in advance,

[]kywatcher - Dual-Axis D.C. Motor Drive for EQ3-2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.