Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_lunar_landings.thumb.jpg.b50378d0845690d8a03305a49923eb40.jpg

The Sailor

GoTo Telescope control with gamepad

Recommended Posts

Over the weekend I decided to look at the way I use the telescope and what else I could do. I got everything working remotely within an hour, telescope and cameras and looked round to see what else I could use for control. I have a Sidewinder Gamepad and wondered if I could us that so I installed ASCOMPAD, it seen the pad and showed that the pad buttons were active. When it came to using it to control the telescope nothing happened, I would be grateful if anyone could shed some light on how to use this and what I need to do, thanks :)

Jim

Edited by The Sailor

Share this post


Link to post
Share on other sites

I've got a cheapy pad from maplin and have used it successfully with EQMOD on my HEQ5. I don't use the ASCOMPAD application just the Joystick control built into EQMOD. You just click the 'initialize' button under joystick configuration.

Share this post


Link to post
Share on other sites

AstroGnome, thanks for that but still a problem, which EQMOD, have gone through every loc and they show a list of everything except EQMOD, can you give me a clue please lol

Jim

Okay AstroGnome, found the one you were on about, thanks :)

Edited by The Sailor

Share this post


Link to post
Share on other sites
I have a Sidewinder Gamepad and wondered if I could us that so I installed ASCOMPAD, it seen the pad and showed that the pad buttons were active. When it came to using it to control the telescope nothing happened, I would be grateful if anyone could shed some light on how to use this and what I need to do, thanks :)

I presume you have installed the ASCOM platform and have an ASCOM driver for you mount? What mount do you have?

If its a synta HEQ5 or EQ6Pro then you the EQMOD ASCOM driver already has gamepad interface build in so no need for ASCOMPAD unless you're looking for focuser control as well.

If you have some other type of mount and have an ASCOM driver for it then ASCOMPAD should be able to give you some level of control.

Chris.

Share this post


Link to post
Share on other sites

Just a thought mate but did you alter the slew speed in EQmod?

Its default is set to 1 which is very slow-if you up it to 4 it will slew much faster.

Hope this helps

daz

Share this post


Link to post
Share on other sites

Thanks Chris, yes I have a HEQ5 and works okay on the ASCOM, I will remove the ASCOMPAD and start again and see what happens. Daz, yes understand the slew speed and check that, thanks again.

Jim

Share this post


Link to post
Share on other sites

Hi

I've kept this in the same thread on purpose, there is some useful info in here worth keeping together.

I need help from the very basics on this - I am using both Windows 7 and a windows 2003 server to test this.

I have installed ASCOM 5.5, followed by EQMOD including ASCOMPAD and have bought a cheapo ps3 wireless controller - the one from Argos that everyone says works fine.

I have plugged in the dongle, turned on the ps3 controller and the dongle goes from flashing rapidly to solid on. However the four flashing leds on the controller don't stop flashing.

This behaviour is the same on the W7 box as it is on the W2K3 box.

On the W7 box the ps3 device turns up on the 'devices and printers' dialogue as a HID controller device fine.

If I then run ASCOM POTH with EQMOD as the driver driving an EQSimulator telescope, it brings up the EQMOd control panel. I click on the spanner to get to the gamepad and see it is ticked, but no response. If I load up the windows calibrator, I see Windows is not responding to it either.

If I load up ASCOMPAD I get the same lack of response.

This is the second PS3 controller I have had - the first is a wireless I used wired through a USB cable and still didn't get any further.

What is the fundamental thing I am missing here? what did you do to get the gamepad operating against EQMOD that was different to this ?

Hope someone has some answers to this.. ! Hair is thinning rapidly. I could really do with wireless control from the top of the ladder.

Thanks in advance

Mike

Share this post


Link to post
Share on other sites

Hi

I am using Stellerium and you also have to load StelleriumScope.

Stellarium

Astronomy - StellariumScope

These may be useful too;

EQMOD [EQMOD]

http://www.iceinspace.com.au/63-581-0-0-1-0.html

http://eq-mod.sourceforge.net/eqaindex.html

http://ascom-standards.org/index.htm

Good luck

Edited by keithatrochdale

Share this post


Link to post
Share on other sites

Mike, those flashing lights drove me up the wall as well; make sure that the pad is fully charged, if it says 3 hours, go for 24!

I then downloaded the latest driver from SPEEDLINK / Products / Gaming Accessories / Sony® / PlayStation® 3 / Gamepads / STRIKE FX Wireless Gamepad for PC & PS3®, black (but i am assuming that you are using a Speedlink). Also, follow the faqs, it probably took a few goes for me to get it to connect to my laptop, but once it did EQMOD found it and it has never fallen over since.

HTH,

Alistair

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.