Jump to content

sgl_imaging_challenge_2021_annual.thumb.jpg.3fc34f695a81b16210333189a3162ac7.jpg

Skywatcher az goto mount ........... Caput.


Brett
 Share

Recommended Posts

Good morning all I need some help :( My az goto mount popped last night after plugging my power lead in. I've done it many many times before without a problem but for some reason something went wrong and it blew the motherboard. I use a 12v tip positive 2000mah adapter for the mount and also a 7ah powerpack for when I'm not at home or cant find the extension lead. Is the motherboard something I can purchase from somewhere or do I have a mount that will no longer function. I have written to OVL in the hope they can help, what makes things worse is that I was about to strike a deal with someone to sell my mount :)

Thanks

Brett

Link to comment
Share on other sites

Thanks Peter, I'm just waiting to hear from OVL I think they're going to sort it for me FOC as its already been in once and only been used 10-15 times at the most in the two years I've had it from new. It's amazing what a strong but kind worded email can do to get you out of strife.

:)

Brett

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.