Jump to content

Banner.jpg.32030495336bee81a52546621b6f39a2.jpg

Astroberry Connectivity to ZWO main and guiding cameras


Recommended Posts

Hi

Apologies if this has been covered elsewhere, but I was about to throw in the towel yesterday, having spent 2 hours trying to connect everything and searching for answers online, but thought I'd give RPi another chance. Alas, no change to the situation, even after I've given it over 24 hours to change its mind.

Scenario:

WO Redcat + ZWO ASI 183 MM Pro connected to USB3 port of RPi
ASI290 Mini connected to USB2 port
ZWO EAF & ASI EFW connected to USB 2 ports of  ASI 183.
Simulated Telescope mount

Astroberry Server release 2.0.4, updated via apt-get to version 2.05

I've set up a profile in Device Manager [see image 1]

Open Kstars
Create a profile and save [see image 2]
 

Click on start
EAF & EFW have both been detected, along with the simulator, but no detection of either ZWO camera, despite the EAF and EFW being connected to the USB port of the ASI 183 camera.... [see image 3]

I've tried with just the ASI 183 - no detection (multiple attempts, different ports)

Obviously I'm doing something wrong

Anybody any idea what that is?

After this I connected everything to the ASIAir Plus and all connections made, no tinkering required. I know some would say just use the ASIAir, but I would like the option to choose between the two. The Astroberry should work, shouldn't it?

RPi is model 4 B with 4GB of RAM, powered with an official RPi power supply (5V, 3A) connected to the mains indoors. I had previously attempted this with the Pegasus Power Box Advanced, but switched to mains supply just in case power was an issue.

This is my first foray into INDI/Kstar/Ekos etc in the past having used an RPD session to connect to a laptop/ITX PC local to the mount.

 

Any help would be appreciated.

 

Cheers,

Paul

 

1.device manager.png

2.kstars profile.png

3.star kstars profile.png

Edited by appyaardvark
added Astroberry server version
Link to comment
Share on other sites

It looks like what you're doing is correct and I've certainly got a ZWO camera and guide camera to work fine with astroberry.   If you type "lsusb" at a command prompt do you get an extra listing appear when you connect the camera to when it isn't connected?  (Mine don't identify themselves as ZWO, it's just a hexadecimal number)

Are you using the extra 12V power supply with the ASI 183?  If not it's possible the pi just doesn't have enough power from the USB port to make it work but the Asiair does. Does the ZWO mini connect ok on its own?

 

  • Like 1
Link to comment
Share on other sites

1 hour ago, Stefan73 said:

It looks like what you're doing is correct and I've certainly got a ZWO camera and guide camera to work fine with astroberry.   If you type "lsusb" at a command prompt do you get an extra listing appear when you connect the camera to when it isn't connected?  (Mine don't identify themselves as ZWO, it's just a hexadecimal number)

Are you using the extra 12V power supply with the ASI 183?  If not it's possible the pi just doesn't have enough power from the USB port to make it work but the Asiair does. Does the ZWO mini connect ok on its own?

 

If I unplug the 183, so that just the 290 mini is plugged in, nothing connects (except the simulator).

As I understand it, the power is for cooling only, but it's powered nevertheless.

I've tried using ZWO camera driver for both devices, different combinations of ZWO camera and ZWO camera 1,2 & 3., all with the same outcome.

 

image.thumb.png.d64b6119ccf7d6c5295261f42eac88b4.png

When I use lsusb in the terminal console, I get the following

With nothing connected:

image.png.92a29e306b1b279c90a224616382993f.png

 

290 mini connected to bottom USB2 port:

image.png.4696abbc9c2234247b703055aea9b532.png

When I reconnect the 183 on its own to the top USB3 port:

image.png.669bbe4eb2114b8d1593cbafd2781d3c.png

183 still connected, plus EAF connected to top USB2 port of the 183:

image.png.c77bf099e5e447bbf65faf3537f7aed8.png

 

183 still connected, plus EAF connected to top USB2 port of the 183 and EFW connected to bottom USB2 port of 183:

image.png.6ad2bf74cb27704f8e61ab77a30d29c1.png

 

Finally (sorry about all this), with the 290 mini reconnected to the bottom USB2 port of the Astroberry:

image.png.a79663cc2691f49c48216cf1caeee46c.png

 

So....

183e = 183
1f10 = EAF
1f01 = EFW
290f = 290 min

I presume Cypress is the in built USB2 hub on the 183

How to make Ekos understand what these devices are and use them?

 

Edited by appyaardvark
too many screenshots
Link to comment
Share on other sites

So the Pi is seeing all the USB devices. Points to a driver issue.

I believe you are using the Pi as a server. Where is Kstars/Ekos running? On the Pi or a connected PC? The first screen you posted of a device manager is confusing me. Is that device manager taking ownership of the two cameras before Kstars can connect?

Have you trued running the whole thing in local mode. ie Kstars/Ekos running on the Pi in local mode, and using VNC or remote desktop on the PC to see what is happening.

Link to comment
Share on other sites

1 minute ago, AstroKeith said:

So the Pi is seeing all the USB devices. Points to a driver issue.

I believe you are using the Pi as a server. Where is Kstars/Ekos running? On the Pi or a connected PC? The first screen you posted of a device manager is confusing me. Is that device manager taking ownership of the two cameras before Kstars can connect?

Have you trued running the whole thing in local mode. ie Kstars/Ekos running on the Pi in local mode, and using VNC or remote desktop on the PC to see what is happening.

This is all running on the Pi.

 

I am connecting to it via VNC, with my PC

Link to comment
Share on other sites

1 minute ago, Stefan73 said:

Shouldn't you be in local mode then?

ekos.png

I honestly have no idea 😆
I followed a YT tutorial by AstroExploring


image.thumb.png.812587b9d91107b1b8d6cb4d2272cdce.png

He suggests it needs to be remote because it's connecting to a remote INDI server that is already running....

Selecting local causes driver crashes:

 

image.png.22b9bb0757307075fe04460128b0459b.png

Link to comment
Share on other sites

Well INDI should be running on the pi if your hardware's connected to the pi so there shouldn't be any need to connect to a remote server.

It was a while ago I set this up but I don't remember it being at all complicated.  I think I just started a new profile, selecting ZWO CCD for the two cameras, EQMOD for the mount, PHD2 for the guiding, chose suitable telescopes and then started it with everything else default. And it just worked[tm].  Maybe restart kstars, start a fresh profile and try that? 

  • Like 1
Link to comment
Share on other sites

13 minutes ago, appyaardvark said:

He suggests it needs to be remote because it's connecting to a remote INDI server that is already running....

The INDI server is running on the RPi and you are running Kstars on RPi so connection is local. If you were running Kstars on a laptop and connecting to RPi then it would be remote connection.

Try removing the tick on Auto Connect and see if it recognises the cameras. The INDI popup should show a tab for each camera

Edited by AstroMuni
Link to comment
Share on other sites

20 minutes ago, AstroMuni said:

The INDI server is running on the RPi and you are running Kstars on RPi so connection is local. If you were running Kstars on a laptop and connecting to RPi then it would be remote connection.

Try removing the tick on Auto Connect and see if it recognises the cameras.

image.png.31b3f8538dac9354a0027734c49c9a1c.png

image.png.9eef025a4957929549c7d8de92aede72.png

image.png.0a23703fe533760ce3028b5fd30f4221.png

Edited by appyaardvark
Link to comment
Share on other sites

1 hour ago, appyaardvark said:

image.png.31b3f8538dac9354a0027734c49c9a1c.png

image.png.9eef025a4957929549c7d8de92aede72.png

 

Try changing the driver to ZWO camera 1 & ZWO Camera 2. I am assuming that you have tried to connect just a single camera (say the 290) and no other devices?

EDIT: I just noticed that lsusb doesnt detect the cameras! So something is wrong. Are you using the blue ports for the cameras? Assuming they are having the faster USB3 connection.

Reboot the RPi, connect just one camera to USB port and run lsusb. See if it shows up. If it does you can add the 2nd one and check again. So do it in stages

Edited by AstroMuni
  • Like 1
Link to comment
Share on other sites

5 minutes ago, AstroMuni said:

Try the changing the driver to ZWO camera 1 & ZWO Camera 2. I am assuming that you have tried to connect just a single camera (say the 120) and no other devices?

EDIT: I just noticed that lsusb doesnt detect the cameras! So something is wrong.

I have used all sorts of combinations of drivers ZWO camera, ZWO camera 1,2 and 3. None are recognised as cameras by Ekos.

lsusb shows that devices are detected, but the codes for the cameras are not recognised by Ekos, but they are for the EAF and EFW

 

Link to comment
Share on other sites

21 minutes ago, appyaardvark said:

lsusb shows that devices are detected, but the codes for the cameras are not recognised by Ekos, but they are for the EAF and EFW

Can you post a lsusb -v for the camera part only? Does the listing look something like this? Also try using Firecapture or OACapture to see if they recognise the camera

 

image.png.df193c774cf1a8c83a02438ded084d64.png

 

OACapture should show something like this

image.thumb.png.110e0fdb4db36637ec8d3197accb9e0d.png

 

Edited by AstroMuni
  • Like 1
Link to comment
Share on other sites

Hi.

Start again perhaps?

1. Connect to the pi via VNC.

2. Delete the profile you currently have

3. Lose indi web manager.

4. Make a new profile and leave the 'Mode'as 'Local'.

5. Do not select Auto Connect. Instead, connect each device from the indi control panel. This step will help decide which if any of the devices or driver's are faulty.

Use VNC until you have it working. All should then be fine.

You can experiment with Auto Connect and client-server remote stuff later.

Cheers and HTH

 

Edited by alacant
  • Like 1
Link to comment
Share on other sites

Having connected to the Pi with a keyboard and mouse, with a monitor, I configure the Pi to use my Wifi.

Restart the Pi, open my browser and type astroberry.local in the address bar, which takes me to Astroberrry Server Version 2.0.5

This is where Device Manager (a.k.a Indi Web Manager). It has not been started and auto Start and Auto Connect have been disabled:

image.thumb.png.8f2a555a96bd716ac60e5081662b874d.png

Click Connect, which allows me to remote onto the Pi with the VNC service

Open Kstars

Click on the dome icon

Create a new profile called Test, local, disable autoconnect and only CCD is configured

image.thumb.png.36dab2356a8c9fbc74e5588f5b9da565.png

Hit save.

Connect ASI 183 to the top USB3 port on the Pi. The camera has 12V power, just in case it's an issue

Once connected, Start Ekos

image.thumb.png.b97e4961ca9db8ab30eb0b8e3c59e794.png

 

Output from lsusb -v shows ASI 183MM Pro is connected

image.thumb.png.461f55ea864d0c0b43f2d50ab1eb5f4b.png

OACapture agrees:

image.thumb.png.8de94304586b67f9b38b9201180eb93e.png

Edited by appyaardvark
Link to comment
Share on other sites

1 hour ago, AstroKeith said:

I really think you need to clear the Indi device manager. Clear all fields.

It's not running, stopped, auto start off, auto connect off. Clearing the fields won't change anything 🙂

I'm onto something though, just testing something else to see if it's the reason why......

Link to comment
Share on other sites

I tried with another SD card and both local and remote work as expected.

Local:

image.thumb.png.70ff9fd3eb49f77a3c24ae42f8c588ae.png

Remote:

image.thumb.png.49689f4acb2a4ee2aeebbb75e1ba7907.png

I reflashed the original card, set it all up again....both local and remote work as expected.

Bit of a mystery this one. Tried on 2 different RPis,  same issue, same success. The only difference was the SD card that had not previously been updated worked first time. Both cards were flashed on the same day, but one had an update applied to it a week or so ago (broke), the other didn't.

The only visual difference was the Ekos GUI, so perhaps when I applied the update, Ekos was updated to a version that wasn't quite right? I don't know.

Link to comment
Share on other sites

15 hours ago, appyaardvark said:

The only visual difference was the Ekos GUI, so perhaps when I applied the update, Ekos was updated to a version that wasn't quite right? I don't know.

So now all working I take it? 🙂 Alls well that ends well

Edited by AstroMuni
Link to comment
Share on other sites

1 hour ago, appyaardvark said:

wary about keeping the OS up to date

Hi

Duplicate the card which you know works and update the duplicate. Use the latter to test and report success/failure/logs back to the developers. 

Remember that it's a community project. The more we help and contribute, the... etc etc...

Cheers

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.