Jump to content


Something is going wrong with my flats

Recommended Posts

Something is going wrong with my flats and I cant work it out.  Attached are two stacks done using Deep Sky Stacker.  One using flats and the other without.  The flats version shows significant lightness on the left corresponding with the darkness at the edge of the flats.  It looks like its a gradient but it not there if I dont use flats.   I’ve tried using different exposures for the flats and using a light panel (cheap one) and pointing at the sky.  It doesn’t seem to make any difference, better results without using flats.

Also attached is the master flat created by DSS.  The stacks are done with 60s subs, 60s darks and 1.3s flats and 1.3s dark flats.  1.3s came from the NINA flat wizard but .5 sec gives the same effect.

So I’ve tried different flat exposures and methods of taking them and different software for stacking (Pi and DSS but DSS is faster for a quick test).  Any pointers for what to try next?

Zenithstar 61 with flattener plus l-enhance and ASI 2600MC pro at -10c





Stack with flats, original tiff and stretched jpg (basic auto stretch in Pixinsight, no other processing)

Stack without flats, original tiff and stretched jpg

Master flat

AutosaveFlats1.3s.tif AutosaveNoFlats.tif MasterFlat_Gain100.tif

Link to comment
Share on other sites

It looks to me that the Master Flat is overcompensating. I had a similar problem with my 2600 MC Pro which arose when creating the master flat in Pixinsight. When calibrating your flats try unchecking "Enable CFA". To create the master flat under ImageIntegration try Average Combination + No Normalisation (*) & Weights set to "Don't Care (all weights = 1)". Under Pixel Rejection pick the appropriate Rejection Algorithm ("Winsorized Sigma Clippng" works well for 30 flats) & set Normalisation to "Equalize Fluxes".

I'd also suggest trying shorter exposure times for the flats/flat darks, or a dimmer light source. With my cheap LED panel I have to make it pretty dim & shoot 0.155s flats.

I've attached the unstretched histograms of your master flat & one of my own.

(*) my problem occured because I was used to selecting "Multiplicative" normalisation here, which worked fine when I had a DSLR...



  • Like 1
Link to comment
Share on other sites

I've had another go at stacking using the suggestions.  I did find I had to check CFA for the flats (so Pixinsight would debayer them), if I didnt do that the flats didnt show in the calibration diagram.

The other thing I found was, I suspect, the main cause and that was user error!  I've started to use NINA and that's really great for framing the images.  I was using APT before and I still find it easier for flats and darks.  I'd managed to get a mixture of camera offset settings.  Lights at the default of 50 and flats and darks at 0.  I've now redone all the calibration at offset 50.  I haven't disturbed the optical train so the flats should be there or there abouts.


  • Like 1
Link to comment
Share on other sites

@Jerry Barnes I realised that I gave your some duff info! Recently I've been having problems with my own calibration & so the advice I gave was wrong. When integrating the Normalisation should be set to Multiplicative, not "No Normalisation" as I'd previously said.

My problem turned out to be a mistake using darks taken at a longer exposure length than the flats...

Glad you got your pedastal issue resolved.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.