Jump to content

NLC-Banner.thumb.jpg.acb5ba835b9e8bf0718b90539633017d.jpg

Connecting Astroberry Pi To Laptop Via LAN Cable...


Recommended Posts

I've been using the Raspberry Pi with Astroberry for a number of months now, but I'm having some communication difficulties with Wi-Fi.  I've read that using a USB 3 thumb drive in one of the USB 3 ports can cause problems with the on-board Wi-Fi, the workaround is to connect the RPi directly to the PC using a LAN cable.

Previously, I was using Wi-Fi from my smartphone hotspot to get the laptop and RPi to talk to each other, without too many issues - using VNC.  I've tried a similar thing, but using a cat6 LAN cable between the laptop and RPi, but just can't get them to talk.  It's a Win 8.1 laptop.

Any ideas?🤔

Link to comment
Share on other sites

I use a gigabit ethernet cable connection, from my household network, to my external computers (Windows & Linux), and control them using remote desktop / xrdp with no issues....  I tried WiFi, but like you, I found it unreliable, so reverted back to wired connections.    

Link to comment
Share on other sites

Ditto - all kinds of weird intermittent problems using WiFi and rock solid since I went to a wired connection. My PC is running Linux and has a dhcp server configured to provide the Rasp Pi with an IP address, so the ethernet interface on the Rasp Pi should be set up for dhcp client in this configuration. Can't speak for how to configure this on Windoze 8 though - stopped using Microsoft products many years ago...

Link to comment
Share on other sites

4 hours ago, Dr_Ju_ju said:

I use a gigabit ethernet cable connection, from my household network, to my external computers (Windows & Linux), and control them using remote desktop / xrdp with no issues....  I tried WiFi, but like you, I found it unreliable, so reverted back to wired connections.    

I don't have a household connection (router), as I use my smartphone for the internet and broadband hotspot.  I tried the NOOB version of RPi OS on a spare micro SD and can get the laptop and RPi talking, through the LAN cable - therefore it must be something configured differently in the RPi.  I do have SSH and VNC enable in Astroberry, so goodness knows..🙄

Link to comment
Share on other sites

On 02/05/2022 at 14:18, Ian McCallum said:

I don't have a household connection (router), as I use my smartphone for the internet and broadband hotspot.  I tried the NOOB version of RPi OS on a spare micro SD and can get the laptop and RPi talking, through the LAN cable - therefore it must be something configured differently in the RPi.  I do have SSH and VNC enable in Astroberry, so goodness knows..🙄

When you update your RPi, do you use the hotspot for that too?

Link to comment
Share on other sites

19 hours ago, AstroMuni said:

When you update your RPi, do you use the hotspot for that too?

Yes, I do.  I've managed to get the LAN cable to work between the laptop and RPi. 

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
Posted (edited)

OK, sounds like you have the basic networking setup between the Pi and laptop.  You can verify this by pinging the Pi from the laptop:

Open a command window  on the windows laptop (CMD window)

type:  ping nnn.nnn.nnn.nnn   <--(insert Pi lan IP address here)

If that works (because you get ping replies), then you probably have KStars/EKOS still setup with the old IP address from the hotspot and need to update the indiserver IP to the new lan address in EKOS.

If you can't ping the Pi from the laptop, then the problem is network configuration.  You need to be certain of the problem (network config or EKOS config) first to know what to fix.

Edited by JonCarleton
  • Thanks 1
Link to comment
Share on other sites

Thanks for everyone's input.  I've managed to get the laptop and RPi to talk to each other via the ethernet cable.  I found that I had to disable WiFi on the RPi, then it would connect to the laptop through the ethernet cable - the RPi being controlled through VNC Viewer.

Link to comment
Share on other sites

Posted (edited)
42 minutes ago, Ian McCallum said:

I found that I had to disable WiFi on the RPi, then it would connect to the laptop through the ethernet cable

Good point that was missed out. I do the same but forgot to mention :( Useful info for anyone new trying to establish similar connection.

Edited by AstroMuni
  • Like 1
Link to comment
Share on other sites

5 hours ago, AstroMuni said:

Good point that was missed out. I do the same but forgot to mention :( Useful info for anyone new trying to establish similar connection.

It took me a while to work than one out too.🙄

Link to comment
Share on other sites

Posted (edited)

I don't like to "fix" things after they aren't broken any more, but you should be able to use both WiFi and Ethernet on a Pi.  I do all the time.  However, it can be a bit challenging, so the point of this post is just to mention that it is possible and practical, but not necessarily a good plan if you no longer need it.  If you are up and running sans WiFi, you have my applause and congratulations.  Ethernet on a Pi is generally rock-solid and significantly faster than any WiFi.

Edited by JonCarleton
  • Like 2
Link to comment
Share on other sites

10 hours ago, JonCarleton said:

I don't like to "fix" things after they aren't broken any more, but you should be able to use both WiFi and Ethernet on a Pi.  I do all the time.  However, it can be a bit challenging, so the point of this post is just to mention that it is possible and practical, but not necessarily a good plan if you no longer need it.  If you are up and running sans WiFi, you have my applause and congratulations.  Ethernet on a Pi is generally rock-solid and significantly faster than any WiFi.

As I don't have broadband internet or a router in the house, it sort of complicates things.  I use my smartphone as a hotspot and it's mobile data for any internet stuff.

  • Like 1
Link to comment
Share on other sites

On 02/05/2022 at 15:18, Ian McCallum said:

I tried the NOOB version of RPi OS on a spare micro SD and can get the laptop and RPi talking, through the LAN cable - therefore it must be something configured differently in the RPi.

If you are using the LAN on your laptop to ONLY connect to your Pi, then it should work if you give both a static (fixed) IP on the same subnet on the LAN interfaces. I.E. 192.168..1.23 and 192.168.1.24. Or something like that. Astroberry is based on Raspberry OS, which is based on Debian, so this should be easy. Use the Ping command on your laptop to check the connection.

  • Like 1
Link to comment
Share on other sites

On 02/05/2022 at 09:49, Ian McCallum said:

I've been using the Raspberry Pi with Astroberry for a number of months now, but I'm having some communication difficulties with Wi-Fi.  I've read that using a USB 3 thumb drive in one of the USB 3 ports can cause problems with the on-board Wi-Fi………..

I think there is a slight confusion here - the known ‘problem’ is potential interference between the USB3 circuitry, ports and 2.4GHz WiFi. You may avoid this with Astroberry by forcing the WiFi hotspot to use only the 5GHz band. I run two Astroberrys in Flirc metal cases with the underside plastic panel outwards away from mount metalwork to give minimum restriction to the printed circuit WiFi antennas. The systems work simultaneously close by each other, both exclusively using the 5GHz band, controlled by a laptop outside during polar alignment and from inside the house at a distance of about 8m afterwards. I use Samsung 256GB Fit Plus USB3.1 drives in place of micro SD cards. I pick up lots of other WiFi networks when setting up and selecting the Astroberry hotspot networks (with different SSIDs) on the laptop.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.