Jump to content

NLC-Banner.thumb.jpg.acb5ba835b9e8bf0718b90539633017d.jpg

COM port too high!


Recommended Posts

When I connect my telescope, I have to check Windows Device Manager to see what Prolific COM port has been assigned and then make sure that is selected in ASCOM.

But ASCOM only has COM ports up to 16, so what happens when Windows has given it a number higher than that?

 

Untitled-1.jpg

Capture.JPG

  • Confused 1
Link to comment
Share on other sites

Under devices if you right click on the computer name & select "Show Hidden Devices", then under Ports you will see the ports that the system has previously used....  right clicking & deleting each of the hidden ports, then when re-connecting the USB to serial device, a lower port number will be applied....

  • Thanks 1
Link to comment
Share on other sites

This is probably be caused by shutting down the computer without disconnecting the USB, or pulling out the USB lead. Windows keeps that 'assigned' port reserved. 

Solution, is ...

open control panel, then device manager, then 'view - hidden', then ports. You should a long list of identical assignments. Just right click on one. Choose uninstall, but DONT CHECK THE DELETE DRIVER SOFTWARE box. Repeat!

  • Thanks 1
Link to comment
Share on other sites

16 minutes ago, StuartT said:

When I connect my telescope, I have to check Windows Device Manager to see what Prolific COM port has been assigned and then make sure that is selected in ASCOM.

But ASCOM only has COM ports up to 16, so what happens when Windows has given it a number higher than that?

 

Untitled-1.jpg

Capture.JPG

Try this https://www.startech.com/en-eu/faq/change-com-port-number-windows

I pull and push my usb cables in/out of the computer and shutdown with all connected without problems. The point to remember is that COM ports are assigned to devices at each usb port, so if you have a hub as well at the telescope the cables need to be connected to their same ports at the hub and the cable from the hub connected to the same usb port on the computer each time. That way the COM port for each device remains static. Hope that makes sense!

  • Thanks 1
Link to comment
Share on other sites

Also, just for future reference, if you don't want to go through the windows device manager dance, just click the "Binocular" icon near Ports in EQMOD then it'll connect to the port, no need to go searching manually.

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.