Jump to content

Banner.jpg.b6007b69ccdf5c69bf18273ddfe023df.jpg

EQMOD timeout error (my solution)


Recommended Posts

 

Hello everyone.

 

TL;DR If you are certain the mount and cable are good, and you are certain the com port selected is correct and so is the baud rate, but you still have connection issues to eqAscom you may want to try a different power cable to your mount. This was the cause of my connection error in eqmod.

 

I spent the last few days almost ripping out my hair trying to get my telescope to connect to eqmod ascom. I later found the problem which I didn't see on any forum, granted my search may not have been thorough enough. Anyway I thought I'd try to help out this community by explaining my problem and how I fixed it. If you are having a similar issue to me I hope this can help you.

 

Issue- Connect Error: Timeout.

I am using a HEQ5 pro mount, the mount is slightly over a year old and has been working fine with the current set up and hand controller. I later decide to upgrade the system by connecting it to the laptop. I purchased an appropriate cable from FLO and get the Lynx Astro mount to USB cable. I have downloaded and installed ASCOM platform v6.6 and EQMOD v200w.  I power up the mount, connect the cable to laptop and I get a timeout error in eqmod toolbox. 

Fix 1. FTDI driver; I check the cable in device manager and see I need to set up the correct driver for the FTDI chip. Link to driver for my Lynx Astro cable - https://ftdichip.com/drivers/vcp-drivers/.  While the driver must be installed and now was I still had a connection error.

Fix 2. Baud rate; I make sure that the correct baud rate is selected in eqmod i.e 115200/9600 (I say 115200 as this is what the internet told me I should use, I later found out that only 9600 would work). However this did not fix my problem! Additional note you may want to check the baud rate thing of the com port. 

 

Fix 2, Sort of worked. Although, sometimes it would connect to eqmod for several minutes and even allow me to control the mount it would always later drop the connection and give me another timeout error. Even when connected eqmod and stellarium would be extremely slow.  I figured this was because the mount was only updating eqmod  every 7+seconds when connected.  Clearly this worked but only kind of and this set up was not going to be reliable on a night under the sky. 

I later go nuts and take apart the entire mount, trying visually inspect wires and probe various parts with a multimeter. I later probe the power supply to the mount and find that I am getting a steady 12volts, I again was at a loss with what the issue could be.                                                                                                                                                                                                                                                              I check the connection of the Rj45 to mount to see if it is loose or anything, same with the power cable and it all looks good. Through sheer luck I ended up using a different power cable later that day to take another look at this problem and to my surprise it was working perfectly! The mount worked and was updating eqmod every second and could control the mounts position quickly and with ease. I load up stellarium and it was responding fast, and would allow me to point the mount wherever. Not once has the eqmod dropped out of connection. 

Knowing that the only thing I changed in the set up this time was a power supply I switch to the old one to see what would happen. Eqmod couldn't connect and if it did it would run slow and judder ultimately ending in it dropping the connection completely. 

So if like me you have checked the cable's driver, driver setup in eqmod (baud and com number), and you still can't connect or can just about connect but it runs slow or keeps disconnecting and reconnecting you might want to try another power supply. While the cable produced a steady 12 volts (I didn't check amps) I think maybe what was happening is the power supply wasn't seated well in the mount socket and the change in power supply gave the scope a better fit and therefore constant supply of power.

 

You will eventually find the solution to your problem so don't give up. You may also want to consider taking your telescope to a shop for them to have a look at if you have run out of all other options. I really hope this helps.

 

 

Edited by Joshua1243
Link to comment
Share on other sites

22 hours ago, Joshua1243 said:

Issue- Connect Error: Timeout.

I am using a HEQ5 pro mount, the mount is slightly over a year old and has been working fine with the current set up and hand controller. I later decide to upgrade the system by connecting it to the laptop. I purchased an appropriate cable from FLO and get the Lynx Astro mount to USB cable. I have downloaded and installed ASCOM platform v6.6 and EQMOD v200w.  I power up the mount, connect the cable to laptop and I get a timeout error in eqmod toolbox. 

Fix 1. FTDI driver; I check the cable in device manager and see I need to set up the correct driver for the FTDI chip. Link to driver for my Lynx Astro cable - https://ftdichip.com/drivers/vcp-drivers/.  While the driver must be installed and now was I still had a connection error.

Fix 2. Baud rate; I make sure that the correct baud rate is selected in eqmod i.e 115200/9600 (I say 115200 as this is what the internet told me I should use, I later found out that only 9600 would work). However this did not fix my problem! Additional note you may want to check the baud rate thing of the com port. 

 

All well documented on this forum and on the EQMOD website.  As TomatoBro states, we've all been there at some point

Only the newer synscan units based on the ARM processors and  have a USB port (with a prolific chilpset built in) operate at 115200 baud.   If you are using an EQDIR cable that uses the FTDI chipset (such as the Lynx Astro) the driver should be natively installed by Windows  if you are using that platform.

But thanks for sharing 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.