Jump to content

Banner.jpg.b6007b69ccdf5c69bf18273ddfe023df.jpg

Celestron 6SE mount fault


bf79
 Share

Recommended Posts

Ive been having some issues with my 6SE mount recently. I bought it a second hand a few years ago, so it is the older style handset with the “info” button lower left as opposed to the newer style with the “celestron” button.

long story short, it powers up with the original handset but doesn't seem to align properly now, and it no longer recognises my starsense or wifi accessories. When the starsense is connected I just get a fault saying it cant find the telescope model, and the wifi module says it can find the telescope but cant connect. 
 

Ive tried swapping about the aux connections incase it was one of the ports that was faulty, but that hasn't worked, and when I try to do a firmware update on my laptop it doesn't find the mount. 
 

Im pretty much at the point where I know I need a new mount, but I was wondering if its worth trying to replace the motor control board as a last resort. Had anybody had similar issues or done a similar repair and could give me an idea if its worth a try?

Im planning on trying to source a replacement 6/8 SE mount, and also pick up an AVX / HEQ5 or similar as well to dip my toe into EQ mounts, but if this was easily fixable id like to give it a go and either keep as a spare or stick one of my spare scopes on to let family / friends use. Just hate seeing things go to waste 😆

 

thanks in advance

Brian

Edited by bf79
Link to comment
Share on other sites

Any error codes?

Have you checked that the power cable is making proper contact, and/or the battery is charged?

Has any water got into it?

59 minutes ago, bf79 said:

and when I try to do a firmware update on my laptop it doesn't find the mount. 

Did it find the mount previously? Various things have to work for the firmware update to succeed.

I imagine Celestron can supply a replacement board as a last resort, as this is a current model.

  • Like 1
Link to comment
Share on other sites

It worked fine up until a few months ago,  and its never been out in the rain and kept in a dry weatherproof shed with lots of computer equipment, Ive never had any issues with water ingress.
I use a power supply so no issues with batteries. Power cable always seems fine and i always make sure the connection isn't taking any weight


If I connect the starsense to the scope, then the firmware manager detects it no problem, but when i connect the nexstar handset it doesn't find anything. 

Link to comment
Share on other sites

I had never tried to do a firmware update prior to it going faulty… this was just something I tried to see if it would fix the problem

Link to comment
Share on other sites

In my experience with the same mount, a bad power cable connection will definitely cause malfunctions.  You can splay the split centre pin slightly with a craft knife, and attach a cable tie to stop the cable shifting around at the inlet.

You can also get a bad connection where the handset plugs into the mount arm.

If the handset cannot get a response from the mount, an Error 16 or Error 17 will result.  The cause can be scrambled firmware (had that), or a failed internal connection ( not had that) or a general failure caused by something like water in the connectors (had that).

It is not a simple matter to refresh the firmware even if you have a working mount and handset and power. See nexstarsite.com for guidance. How far do you get before encountering an issue?

Edited by Cosmic Geoff
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.