Jump to content

1564402927_Comet2021Banner.jpg.a8d9e102cd65f969b635e8061096d211.jpg

Ekos Manual focusing and scheduler - need help


Recommended Posts

I do my focussing manually. I achieve a manual focus with the aid of the Focus simulator before I start imaging. But once the scheduler has taken charge, if I need the scheduler to do a refocus, there doesnt seem to be a way for the scheduler to pause automatically and alert me to do a manual focus. It treats as if I have an automated focuser and goes into a loop.
Is there a way around this?

  • Confused 1
Link to comment
Share on other sites

AfaIk, there’s no way around this. The scheduler is intended for automated operation, and since you’re focusing manually, there is no real automation. In your case it’s probably easier to start an imaging sequence in the capture module and set an alarm to signal when it is finished. (Or get a focus motor, of course.)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By AstroMuni
      Hi,
      I updated my RPi 4 to latest version of astroberry v2.0.4 today and been trying to connect my main ASI224mc and ASI120mm mini guide cameras in Ekos. When I connect both the cameras on the USB2 ports only one of them i.e. ASI120mm connects. If I connect the ASI224mc on the USB3 and ASI120mm to USB2 again its only the ASI120 that connects.
      But if I connect both on the USB3 ports on the RPi it connects successfully. I have tried with the ZWO CCD driver and using a combination of ZWO Camera 1, ZWO Camera 2 drivers. In both cases the behaviour is the same.
      It works fine on my Linux Mint laptop using direct connection to the cameras even though the USB ports are USB2 only. Both RPi and Linux are running Kstars 3.5.5 stable.
      Any ideas what is the cause of this?
       
    • By AstroMuni
      I wish to use INDI weather watcher driver with Ekos. I have Ekos running on Linux Mint. I would like it to connect to a service such as weathermap.org. My programming skills are near zero but having coded over 20years ago (in now ancient languages), can read some code 🙂
      Has anyone else done this? If so need tips on achieving this please.
      @wimvb I recall seeing your post in the INDI forum about something similar. Did you get it working?
    • By Elp
      Hi, first post so please bear with me, having issues with autoguiding, looked at numerous forum threads and cannot find the issue specific to my setup and the issue I am having.
      Equipment in question:
      ZWO 224 using as guide camera plugged into raspberry pi running Astroberry via USB3,
      Lynx Astro EQDIR cable plugged from USB on raspberry pi into hand controller port on AZ GTI.
       
      Configuration:
      Synscan android app successfully connected to AZ GTI via wifi and can control via mobile phone,
      AZ GTI setup to connect to raspberry pi (so it's on the raspberry pi network) AZ GTI connected successfully as it is recognised in PHD2 and EKOS,
      In PHD2 the mount is setup as INDI mount (AZ-GTI) and connects.
       
      Issue:
      PHD2 is unable to guide in either RA or declination (see screenshot error showing up), it is always one or the other. I have tried setting up multiple times, tried using the network cable which came with the camera directly from the camera into the hand controller port and setup in PHD2 as "on camera" (I suspect this setup is wrong anyway and was one of the first I tried). Polar alignment has been checked multiple times, the end result is always the same, the star field within PHD2 window will always drift in one direction so any star chosen will eventually disappear out the field of view as the mount isn't moving to follow it.
      Looking at the PHD2 graph I know it is trying to send pulses to the mount but either the movement is too much for the mount to move or something isn't happening as it should, in the example screenshot provided I tried this indoors on a fairly fast (compared to in the field) rotating star field looking at a screen so it will fail, though the mount didn't adjust at all, no matter how I've setup prior the AZ GTI refuses to adjust to follow a guide star. I have tried manually moving the mount in PHD2 and it doesn't seem to move in any direction, manually moving however does work in EKOS so the hardware seems to be plugged in correctly. EKOS even knows where the mount is pointing and can issue go-tos (although it is slightly off target at the moment).
      I am kind of at my wits end to why autoguiding isn't working, if anyone can help please assist.
      On another note if someone can advise how to configure PHD2 so the off yellow warning box colour can be changed so the error message can be read clearly - I know theres a line of code I can use in the terminal window which refers to a resource file to change to the default PHD2 colours and launches the software but the changes are never saved.
       

    • By Gina
      I have a triple imaging rig with 3 RPi boards and using wired LAN to the house.  Indoors the rig is controlled by KStars/Ekos running in Linux Mint on my tower system.
      All was working fine a few nights ago but then on a later night I kept getting "Broken pipe" errors and network disconnection. This wasn't all at once but one system at a time with a few minutes in between.
      LAN consists of router plus one network switch indoors and a second network switch on the rig.  Both Netgear 5 port units.  I also have a WiFi LAN if that's relevant.
      On the rig are 2 RPi 3B boards running Raspian and indiserver with drivers plus an RPi 4B running Astroberry Server.  The first RPi 3B controls the EQ8 mount and has 2 CMOS cameras, ASI 1600MM-Cool for imaging and ASI 178MM for guiding.  The other RPi boards run imaging only.  Except that I also have remote focus for the imaging cameras using the Astroberry Focuser driver.  The remote systems run servers and the Mint machine runs 3 instances of KStars/Ekos as clients, controlling everything via 3 individual SSH channels.
      Cable to obsy is CAT6 outdoors rated cable allowing gigabit data rate.
      Nothing has changed between the night the kit worked and later when it lost networking.  The only thing I can think of is that it got warmer.  I have fan cooling through the box with the 3 RPi boards and HATs.  The main obsy power of 13.8v feeds the rig with a 12/24v to 5v 10A voltage dropper/regulator feeding the RPi boards.   1000µF electrolytic and 0.1µF ceramic capacitors are connected across the incoming power connector.
      Any thoughts on what could have gone wrong and/or what I can do to fix it would be much appreciated.  Lots of clear night skies and kit problems!!!  Frustration unlimited!!
    • By teoria_del_big_bang
      Last night started off so clear (an unexpected according to CO) so managed to drag the rig out onto the patio. 
      Nebula targets that are above houses and trees are few and far between at moment for me but ad a go at Horsehead initially then Heart.
      But I was not happy with the images I was getting and a close look showed the focus was not precise, in fact far from it.
      So using the auto focuser in EKOS I tried tuning it in.
      But each time I tried it failed.
      I did look on line for suggested parameters and that was not too useful as  there were suggestions to use just about every combination possible.
      Now, maybe there is a wide range of parameters being used and which you find best may depend on camera and FL of the scope setup, I think I do not understand the mechanism of auto focusing enough, I sort of assumed it just moved the focusser in and out to get  the star it had chosen as small as it would go.
      One thing I did find is that even after trying many different parameters already suggested as the best on-line if the stars had halos due to being a fair way out of focus it never achieved focus at all and basically I ended up manually focusing inwards for a while to see if the image got better, then if not move it outwards, until the stars were pretty much in focus and then an auto focus did pretty well and got the stars pin point.
      So is that what other people find ?
      Is that pretty normal for most auto focus algorithms ?
      Also I thought this might be a good place for people to maybe say what  parameters they use in EKOS and mention the scope and camera if that is relevant ?
      If there is somewhere with this info I apologize profusely 🙂 
      Steve
       
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.