Jump to content

Banner.jpg.39bf5bb2e6bf87794d3e2a4b88f26f1b.jpg

EQ8 with Kstars / Ekos & INdI


Stuart1971
 Share

Recommended Posts

1 minute ago, Stuart1971 said:

Don’t think so

Well, the method is described in this thread.

The next stage is to use a cable from a member of your local astro club which you will have seen working with indi eqmod previously at one of its gatherings. 

Cheers

Link to comment
Share on other sites

4 minutes ago, alacant said:

Well, the method is described in this thread.

The next stage is to use a cable from a member of your local astro club which you will have seen working with indi eqmod previously at one of its gatherings. 

Cheers

The ones I have worked six months ago with my set up and INdI EQMOD…then stopped….probably after an update…

Link to comment
Share on other sites

5 minutes ago, alacant said:

Well, the method is described in this thread.

The next stage is to use a cable from a member of your local astro club which you will have seen working with indi eqmod previously at one of its gatherings. 

Cheers

In what thread…??

Link to comment
Share on other sites

 

1 hour ago, alacant said:

Mmm. So you haven't tried removing the kernel module...

 

 

 

43 minutes ago, Stuart1971 said:

Don’t think so….all I know is I have the very latest kernel as Jasem updated it today while he was having another go to try and fix….but got nowhere…

He has  given up now..☹️

 

I'm no expert, but I think he may be referring to this post (below) which if I follow it (and to be honest my linux experience can be written on the back of a postage stamp so could be way off) is removing an automated update to one that uses an older profile / driver / setting ??

 

5 hours ago, alacant said:

OK.

Try the traditional route:

Disconnect everything on usb. Pull the plugs.

before

ls /dev/ttyUSB0
ls: cannot access '/dev/ttyUSB0': No such file or directory

Unload the ftdi module and tail the log as you plug in the cable.

Use the old method of communicating.

e.g.:
Sep 17 19:58:22 g50 kernel: [  588.552277] usb 2-2: FTDI USB Serial Device converter now at
tached to ttyUSB0

and after:

ls /dev/ttyUSB0
/dev/ttyUSB0

Enter the port in the INDI panel:

Screenshot_20210917_200426.png.c7b92a0b0363f9fe5d477e9fae872828.png

Disable autoconnect in your EKOS profile and connect only the mount.

Anything?

 

  • Thanks 1
Link to comment
Share on other sites

I'm not sure if I've missed something here so forgive me.

You are connecting to RPI with Lynx cable with EKOS/INDI running on the Pi? If yes, this is how I connect so unless the Lynx cable is broken it should work (as other have said some cheapo cables may not) - is the cable OK, clean connections etc? You could test this by connecting it directly to your PC/Laptop usb running INDI/Ekos from there (rather than on the Pi).

I use it with Windows, Mac and Ubuntu where I VNC into the pi - so operating system will have no bearing on the mount connection if you are using the Pi as the server as everything is handled on the Pi.

So, assuming the above all works the issue may be with the USB port on the Pi? Have you tried other ports? I use the USB3 connection for my setup (although this shouldn't matter) and also, is there enough power for the Pi? If you are running other things off the Pi USB it may be not coping with the load. I would start by only trying to connect the mount only to start with.

As others have said, if you have it working with BT then at least you have a working solution. This will have no bearing on the functionality re time lags etc so long as the Pi is close to the mount. I used to use a wifi connection the same way before I switched to EQMOD and had no issues at all.

Hope this helps.

Daz

Link to comment
Share on other sites

24 minutes ago, Dazzyt66 said:

I'm not sure if I've missed something here so forgive me.

You are connecting to RPI with Lynx cable with EKOS/INDI running on the Pi? If yes, this is how I connect so unless the Lynx cable is broken it should work (as other have said some cheapo cables may not) - is the cable OK, clean connections etc? You could test this by connecting it directly to your PC/Laptop usb running INDI/Ekos from there (rather than on the Pi).

I use it with Windows, Mac and Ubuntu where I VNC into the pi - so operating system will have no bearing on the mount connection if you are using the Pi as the server as everything is handled on the Pi.

So, assuming the above all works the issue may be with the USB port on the Pi? Have you tried other ports? I use the USB3 connection for my setup (although this shouldn't matter) and also, is there enough power for the Pi? If you are running other things off the Pi USB it may be not coping with the load. I would start by only trying to connect the mount only to start with.

As others have said, if you have it working with BT then at least you have a working solution. This will have no bearing on the functionality re time lags etc so long as the Pi is close to the mount. I used to use a wifi connection the same way before I switched to EQMOD and had no issues at all.

Hope this helps.

Daz

Hi,

All thee cables I have are fine, as they all work fine on windows with EQMOD and NINA, also the ports on the PI are fine as I have tried it all with a Mini PC with Ubuntu and still the same issues….also when connected to PI it’s the same issue I’d connected direct to it, and to a powered USB hub….but thanks for the input….👍🏼

  • Like 1
Link to comment
Share on other sites

16 hours ago, alacant said:

OK.

Try the traditional route:

Disconnect everything on usb. Pull the plugs.

before

ls /dev/ttyUSB0
ls: cannot access '/dev/ttyUSB0': No such file or directory

Unload the ftdi module and tail the log as you plug in the cable.

Use the old method of communicating.

e.g.:
Sep 17 19:58:22 g50 kernel: [  588.552277] usb 2-2: FTDI USB Serial Device converter now at
tached to ttyUSB0

and after:

ls /dev/ttyUSB0
/dev/ttyUSB0

Enter the port in the INDI panel:

Screenshot_20210917_200426.png.c7b92a0b0363f9fe5d477e9fae872828.png

Disable autoconnect in your EKOS profile and connect only the mount.

Anything?

 

Ok, so how do I unload the FTDI kernel..??

Link to comment
Share on other sites

3 hours ago, Stuart1971 said:

Yes tries all that many time

And what messages did you get? Anything different to the ones I posted?

 

3 hours ago, Stuart1971 said:

how do I unload the FTDI kernel.

You said you'd already tried it. Many times. What did you use?

Link to comment
Share on other sites

2 hours ago, alacant said:

And what messages did you get? Anything different to the ones I posted?

 

You said you'd already tried it. Many times. What did you use?

I didn’t, but Jasem did, and he said he could not get it to work….I was going to try again myself….

Link to comment
Share on other sites

At this point I would resort to just reformat the sd card and set up linux from scratch. Sometimes this is faster than trying to fix the problem. After all, you said that it used to work.

Link to comment
Share on other sites

OK I'm a total newb when it comes to Linux, but I know that there are lots of flavours around.  Would trying something different have any bearing on this or is it really a core issue and all these flavours of Linux are really just "skins" over the top, or is there more than one core kernel that could be tried.

The strange thing is that the OP reported that the set up was fully working, but then mentions an update.  Was that an update to the OS or was it an update to the INDI platform ?  If it was the INDI platform, then can you roll back or install a previous version and not have any auto update in place.  For example when I updated ASCOM to 6.5 as GSServer wanted that version to run, it screwed up my old QHY5 camera as 6.5 was too new for it.  I therefore had no choice but to roll back the PC to how it was prior to installing 6.5 and GSServer.

Link to comment
Share on other sites

6 minutes ago, alacant said:

INDI code is hosted on GitHub.

You can choose any version you like.

So that begs the question, does removing / overwriting the current version resolve the issue (presume it's no harder on Linux to uninstall than on the windows platform ??)

Link to comment
Share on other sites

29 minutes ago, malc-c said:

OK I'm a total newb when it comes to Linux, but I know that there are lots of flavours around.  Would trying something different have any bearing on this or is it really a core issue and all these flavours of Linux are really just "skins" over the top, or is there more than one core kernel that could be tried.

The strange thing is that the OP reported that the set up was fully working, but then mentions an update.  Was that an update to the OS or was it an update to the INDI platform ?  If it was the INDI platform, then can you roll back or install a previous version and not have any auto update in place.  For example when I updated ASCOM to 6.5 as GSServer wanted that version to run, it screwed up my old QHY5 camera as 6.5 was too new for it.  I therefore had no choice but to roll back the PC to how it was prior to installing 6.5 and GSServer.

It did work perfectly well, but I have been very reliably informed that this is NOT an INdI issue but a Linux one, as it’s the same on both RPI and an Ubuntu mini PC, and will not work outside of INdI by using a serial port tool that sends a command to the mount but gets no response back…

So as this all happened on an RPI which had been updated kernel and software, and then was the same on a new download of Ubuntu 20.04 on an Intel mini PC. I tend to agree that this is an issue at the Linux code level, and nothing to do with INdI or updates with that….

My next idea is to source a prolific chipset EQMOD cable and try that, but these do t seem to be very popular, but saw this, can anyone co firm that this is what I need….

https://thepihut.com/products/usb-to-ttl-serial-cable

 

Link to comment
Share on other sites

10 minutes ago, alacant said:

???

So rolling back to the version which worked, doesn't work?!

I have installed the software that was on when it worked, and no it did not work, BUT have also upgraded the firmware on the RPI too, in that time, and have no idea what version was in there, so makes me wonder if it’s the RPI firmware that’s the issue….??

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.