Jump to content

sgl_imaging_challenge_2021_annual.thumb.jpg.3fc34f695a81b16210333189a3162ac7.jpg

RA calibration problems with PHD2


Recommended Posts

Hi Guys,

For the last few weeks I’ve been trying to sort out a PDH2 failure to calibrate issue I’m getting. I’ve guided in the past, but I’m far from knowledgeable regarding the PHD2 settings. My problem is this: Last month, I tried a re-calibration, and all I was getting was ‘calibration failure, RA star did not move enough.’

I was aware that my HEQ5 mount had some bad backlash, so I spent a few hours removing that. Still got the same error. I had been using a usb to serial to RJ lead combination. I was never particularly happy with this (I had to bind the two leads together with electrical tape to stop them detaching). So, I now have an EQDir cable; much better…but I still can’t calibrate in PHD2. I can control the mount fine through Stellarium and the mount tracks ok.

I think the issue must be within the PHD2 setting or possibly the EQMod tracking rate – I’ve tried 0.1 to 0.9 (and used the calibration step calculator each time).

I’m guiding through an Evoguide scope (FL 242mm) and an ASI 120MM mini guide camera (3.75u).

I think the error probably sits with me rather than the hardware. Is anyone able to offer any advice please? I’ve added last night’s PHD2 log – I tried a number of settings, but no joy!

Any help would be fantastic!

Andrew   

PHD2_GuideLog_2021-06-10_225310.txt

Link to post
Share on other sites

Hi Andrew

A puzzler, some unusual conflicting results.  From the GuideLog:

You started with two brief guiding sessions.

Guide Rates were RA = 1.3 arcsec/sec, Dec = 1.6 arcsec/sec

Usual rates are 7.5 or more.

Then I assume you increased the EQMOD rate to 7.5arcsec/sec and made four more Cals which took about 60 RA steps instead of the usual 12.

Similar result with five more Cals at 13.5, still took 60 steps.

Then at 1.5arcsec/sec, still took 60 steps.

I can't explain that I'm afraid.

Another puzzle.

In half the Cals the West move was towards 11 O'clock, the other half towards 5 O'clock - all at the same RA and Dec and side of pier !!

I'm unfamiliar with EQMOD, apart from the common Pulseguide Rate too-low setting, so hopefully someone will comment on your screenshot.

Try this in PHD2:

Tools / Manual Guide, Pulse Duration 5000.

Try all four directions for correct movement and direction.

Are W and E opposite, S and N opposite ?

Each press will move 5000, holding down doesn't issue more pulses.

You have 

Have a good read of the PHD2 Manual:

https://openphdguiding.org/manual/

Michael

Link to post
Share on other sites

Thanks Michael, I'll try pulsing at 5000 tonight. In the past I've guided on-camera without any real problems, although calibration did still take 61 steps.

Do you think I could have removed too much backlash? That said, the mount still tracks and slews without any binding sound - and I rotated a full 360 degrees in RA and Dec. Hmm.

Link to post
Share on other sites

Have you created a master dark frame in PHD2 for your ASI120MM Mini? If not then it may be trying to calibrate on a hot pixel. You can also try increasing the minimum reference star size to 2 or 3 pixels to avoid this.

Link to post
Share on other sites

Hi Budgie1,

Yes, I have a dark library. Also tried guiding on different stars (auto and manually selected).

I'll check the star reference size though, I can't remember what that had been set to - thanks.

Link to post
Share on other sites

A big thankyou to Michael and Martin! 

I amended the minimum star reference size from 1.3 pixels to 2.7 and also increased the pulsing duration to 5000. I was then able to calibrate at the first attempt! Its not the smoothest of guides, but my mount is working beyond it's imaging payload anyway.  I'm sure I can work at smoothing it out a bit more over the next few clear nights :)

Thanks once again folks!

Andrew

Guiding Graph 13 06 21.bmp

  • Like 1
Link to post
Share on other sites
4 hours ago, Andrew INT said:

I amended the minimum star reference size from 1.3 pixels to 2.7 and also increased the pulsing duration to 5000.

Not sure what you mean by minimum star reference size  - do you mean Minimum Star HFD ?

If a Hot Pixel = 1, so a setting of 2 or 3 would work, not sure why you have fractions of pixels in the setting.

The Pulse Duration of 5000 I suggested was for Manual Guiding, so that won't have made any change to normal guiding ?

Although your guiding is looking good it would be worthwhile posting the PHD2 GuideLog.

Michael

 

Link to post
Share on other sites
1 hour ago, michael8554 said:

Not sure what you mean by minimum star reference size  - do you mean Minimum Star HFD ?

If a Hot Pixel = 1, so a setting of 2 or 3 would work, not sure why you have fractions of pixels in the setting.

The Pulse Duration of 5000 I suggested was for Manual Guiding, so that won't have made any change to normal guiding ?

Although your guiding is looking good it would be worthwhile posting the PHD2 GuideLog.

Michael

 

Hi Michael,

Yes, I meant the minimum star HFD. This value was set at 1.2 (I think that was a default setting).   I increased the value using the arrows - which incremented in 0.5. I've since re-set this to 3.0

Using the calibration calculator, PHD2 was setting the calibration set at 1100ms. This still resulted in the RA error. However, setting this to 5000ms resulted in calibration. As requested. I've attached the log. Thanks once again for looking!

Andrew

PHD2_GuideLog_2021-06-12_112421.txt

Link to post
Share on other sites

Hi Andrew

I reread the PHD2 instructions and you're correct, 1.2 is the preset Min Star HFD - my bad.

From the GuideLog:

The Calibration Step Size on your guiding run was 900mS, not 5000ms  - is 5000ms something you set in EQMOD ?

Your HFD from the guidecam is 4.17pixels, you might be able to improve that.

 A Min Star HFD setting of 3 is too close to 4.17, so may be rejecting good stars, back that setting off to 2.

Your guidestar SNR is only about 7 which seems low to me, but depending on the camera can be as low as 20, and up to 800 or more.

You have Star Max Detection ticked, this might be rejecting good stars too.

RA Error is 1.28arcsecs, and is quite choppy, so try Aggression = 80% or lower to smooth that out, changes of only 1 or 2 % are too small.

Give each change time to settle.

Or try the PHD2 PPEC Algorithm for RA guiding.

PA is good, but Dec is still swinging around the axis due to Backlash, and taking 20 seconds to correct.

If you do a Guide Assistant run on Target, that will give you Min Move settings, and a Dec Backlash Compensation setting, which you have switched off.

And you should slightly unbalance Dec to stop it wobbling.

Michael

 

Link to post
Share on other sites
2 hours ago, michael8554 said:

Hi Andrew

I reread the PHD2 instructions and you're correct, 1.2 is the preset Min Star HFD - my bad.

From the GuideLog:

The Calibration Step Size on your guiding run was 900mS, not 5000ms  - is 5000ms something you set in EQMOD ?

Your HFD from the guidecam is 4.17pixels, you might be able to improve that.

 A Min Star HFD setting of 3 is too close to 4.17, so may be rejecting good stars, back that setting off to 2.

Your guidestar SNR is only about 7 which seems low to me, but depending on the camera can be as low as 20, and up to 800 or more.

You have Star Max Detection ticked, this might be rejecting good stars too.

RA Error is 1.28arcsecs, and is quite choppy, so try Aggression = 80% or lower to smooth that out, changes of only 1 or 2 % are too small.

Give each change time to settle.

Or try the PHD2 PPEC Algorithm for RA guiding.

PA is good, but Dec is still swinging around the axis due to Backlash, and taking 20 seconds to correct.

If you do a Guide Assistant run on Target, that will give you Min Move settings, and a Dec Backlash Compensation setting, which you have switched off.

And you should slightly unbalance Dec to stop it wobbling.

Michael

 

Hi Michael,

I had changed the calibration steps to 5000ms in PHD2 - I guess I must not have hit ok! The calibration step calculator suggests 1100ms, so I will try that too.

I shall make all your recommended tweaks on the next clear night, as well as offsetting the balance a little in Dec, and running the guide assistant. Not sure where to turn the dec backlash compensation on - I'll have a look for it!

Thanks once again for your invaluable assistance :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.