Jump to content


Trying (and currently failing) to get to a single cable from Mount/Cameras/Focuser to Laptop

Recommended Posts

Posted (edited)


Hoping someone can help me complete my mission.

So far I have successfully connected the Mount and two Cameras to the Laptop via a StarTech USB Extender and Cat 6 cable.  My problem is with also using the laptop to control a JMI MotoFocus unit which, after much experimentation, seems to only play to very specific rules.  It will only reliably connect if it is plugged in to the same physical USB port.  When plugged in to that same physical port it will not tolerate being connected to it via either the StarTech extender or a USB hub, both of which I think are sufficiently powered.  When I say ‘will not tolerate’ I mean it either doesn’t connect at all or if it does, it loses connection soon after and then the motor runs until I disconnect power which is somewhat alarming.  As a result I currently have to have one cable for the JMI Focuser and another for the Mount and Cameras.  I’m using the JMI MotoFocus Plus 1.0 software to control the Focuser and have tried uninstalling and reinstalling it.  The Mount and Cameras are connected via SharpCap.

I have experimented with various different configurations of different devices being connected via the USB Hub and StarTech extender, such as just having one other device and the JMI unit being connected via these methods and all failed so it looks like the Hub/Extender is part of the problem rather than the other devices. Weirdly, I can get the JMI Unit and one other device connected to the same physical port via a simple two way USB splitter.

If anyone has any experience of this or any suggestions they would be gratefully received.  I am no computer whizz, however, so if it involves messing about with Com ports etc please assume minimal knowledge 😳.

There’s also no more budget for buying ASI Air or similar btw so I have to stick with a cable solution.



Edited by Priesters
Link to comment
Share on other sites

Think your question may have led to a solution.  I just tested using the MotoFocus on its own via the StarTech Extender and it initially failed but then it occurred to me that if it was fussy about which physical USB port it was connected to on the laptop maybe it was also fussy about which physical port it was attached to on the Extender.  Last port I tried worked! Same experiment with the USB Hub - same result.  Don’t have time to test out with all devices attached until after next week as setting off to Lake District this aft. but happy bunny for now.  Extender and Laptop now have stickers on the relevant ports 😂.  Thanks v much for your help.👍

Link to comment
Share on other sites

  • 2 weeks later...

Update just in case anyone else comes across a similar problem and reads this thread.  Using the correct physical USB ports on both the extender and the laptop meant the JMI unit was consistently discovered and connected to the JMI control software.  Unfortunately, it then consistently crashed after several operations (continuous in/out, pulse in/out etc).  It didn’t matter which other devices were connected (or not) to the extender.  It consistently worked fine when connected directly to the laptop.  On reflection I think the cause is actually quite obvious.  The remote extender requires 5v 3amp DC power input which In my set up is supplied exactly by a 20 mah power bank. The JMI focuser is a 9v motor unit so I am assuming that is where the problem lies and have resigned myself to having two cables after all.  

Link to comment
Share on other sites

  • 3 months later...

Long USB active cables and hubs are terribly fickle. One can be successful over Cat6 cable and a USB extender as described, but adequate power is crucial. However, I found that the most successful route is.......

1.   Put a mini-computer at scope running all software.

2.  Control 1 from a computer indoors using Remote Desktop.

3.  Connect 1 and 2 over either Cat6 cable or a 5Ghz WiFi network.

I use the 5Ghz WiFi option via BT Whole home MESH WiFi extenders.  Over longer distances Station and Access Point devices from Ubiquiti also work great.

Remote Desktop replicates the screen of 1 on computer 2. So this route works for camera and focusser control too. 

I favour Windows 10 Pro/Windows Remote Desktop (an upgrade from Win 10 Home costs about £110) but there are free versions of remote desktop if you don't object to their issues and intrusions. I favour the Microsoft route albeit it has a cost (upgrade to Win 10 Pro on one computer) , then I know I have better security, having discovered that many of the free versions of RDT have an origin in Russia or China. 

Edited by noah4x4
Link to comment
Share on other sites

I too had the exact problem you described with the star tech so changed it for another cheaper make which works perfect came from amazon, it was that good I bought a spare will see what make it is when I get in if you still have problems 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.