Jump to content

Banner.jpg.39bf5bb2e6bf87794d3e2a4b88f26f1b.jpg

Weird Ekos/EQ6R problem


Recommended Posts

Hello,
I recently have reinstalled all my gear and wanted to align the guider scope with the main scope using the attached cameras.
Here's my problem, and how I reproduced it (twice only, as I don't want to wreck my equipment)

  • Running kstars (Version 3.5.0 Stable)/ekos (INDI Library: 1.8.7) on astroberry (Linux astroberry 5.10.11-v7l+ #1399)
  • Mount connected to astroberry via USB port
  • Start ekos from within kstars
  • Connect EQ6-R mount, main camera and guide camera
  • Start ekos mount control
  • Slew declination so that scope is +- horizontal roughly pointed at an object near the horizon
  • Start slewing right ascension to find object on the horizon

Result:
Slewing in right ascension cannot be stopped; mount continues to slew till pointed at the ground and motors making a horrible noise (I'm sure it didn't do much good to the worm gears and/or motors)

I did the same thing using the synscan hand control, and there I had no problems; I'm not sure if this is an ekos problem or if's a problem on the EQ6R-controller ???

FYI:

  • I have used this setup (EQ6R, astroberry, kstars/ekos) for imaging without any problem so far.
  • Every time I start the astroberry, I do a system update (sudo apt-get update && apt-get upgrade)
  • I have posted this on indilib.org/ Ekos forum, but have not received any reaction so far.


Any help/comment appreciated!

AstroRookie

Link to comment
Share on other sites

Did you by chance remember to set your geographic location in astroberry (sudo raspi-config i believe) before hand? I had the same problem. I figured the GPS would provide the correct location, which it did, but the UTC offset was wrong and wouldn't correct itself. When I would try to go to a target that was visible, the mount would think its below the horizon and start slewing almost upside down before I stopped it. Once I changed the geographic settings all was good.

Edited by acommonsoul
Link to comment
Share on other sites

1 hour ago, acommonsoul said:

Did you by chance remember to set your geographic location in astroberry (sudo raspi-config i believe) before hand? I had the same problem. I figured the GPS would provide the correct location, which it did, but the UTC offset was wrong and wouldn't correct itself. When I would try to go to a target that was visible, the mount would think its below the horizon and start slewing almost upside down before I stopped it. Once I changed the geographic settings all was good.

That's a good idea - I'll check it over the weekend, thanks!

  • Like 1
Link to comment
Share on other sites

On 24/02/2021 at 20:13, AstroRookie said:

That's a good idea - I'll check it over the weekend, thanks!

I checked it and no nothing changed; I was doing some test shots and while polar aligning with the PoleMaster, it did it again. I shutdown the mount, put it manual in home position and then I noticed that the RA setting circle was no longer well positioned. Re-positioned that and every went ok from there. Fixed, but I can't explain why :(

Link to comment
Share on other sites

Were you slewing in RA with a Goto or were you pressing down the East (or West) button on the Ekos mount control?

Link to comment
Share on other sites

On 03/03/2021 at 04:21, kens said:

Were you slewing in RA with a Goto or were you pressing down the East (or West) button on the Ekos mount control?

Hello Kens, I was using the ekos mount control arrow buttons

Link to comment
Share on other sites

Ok. That means it is nothing to do with having time or location set. When you use the arrows Ekos issues a command through the driver to "Start slewing East" (or West). When you release the button it issues a "Stop slewing" command. If you hit the Stop button it also issues a "Stop slewing" command. Did you try that at the time?

So it looks like the "Stop slewing" command has gone astray. I'd start by looking at the USB connection. Could be that as the mount slewed the cable came loose? Another possibility is a driver issue. I'm assuming you are using the EQMOD driver and connecting directly to the mount and not via the Synscan. Its a heavily used driver so I would have thought any issue like this would have been picked up by now. A third possibility is that Ekos did not respond to your mouse clicks. Even more people would use that function but it could point to an unresponsive system.

If you have a Kstars or INDI log that could provide more information. If not, I suggest you enable logging for the Ekos Mount module and the INDI mount driver to capture the details in future.

To avoid the problem while you sort things out, you could instead use goto instead of a manual slew. That should be safer. 

Link to comment
Share on other sites

On 04/03/2021 at 21:45, kens said:

Ok. That means it is nothing to do with having time or location set. When you use the arrows Ekos issues a command through the driver to "Start slewing East" (or West). When you release the button it issues a "Stop slewing" command. If you hit the Stop button it also issues a "Stop slewing" command. Did you try that at the time?

So it looks like the "Stop slewing" command has gone astray. I'd start by looking at the USB connection. Could be that as the mount slewed the cable came loose? Another possibility is a driver issue. I'm assuming you are using the EQMOD driver and connecting directly to the mount and not via the Synscan. Its a heavily used driver so I would have thought any issue like this would have been picked up by now. A third possibility is that Ekos did not respond to your mouse clicks. Even more people would use that function but it could point to an unresponsive system.

If you have a Kstars or INDI log that could provide more information. If not, I suggest you enable logging for the Ekos Mount module and the INDI mount driver to capture the details in future.

To avoid the problem while you sort things out, you could instead use goto instead of a manual slew. That should be safer. 

Hello Kens,

thanks for the advice; I was just slewing manually to get some object in the field of view in order to align the guide scope. I haven't had the problem since then. I have since then, 3 times used my setup and each time I slew with the ekos mount control during polar alignment with the PoleMaster, and no problem.

I think a lose usb cable could have been the problem, as the usb-b cable is not very fixed in that "socket", I switched already cables but I think it's the "hole" where that usb-b connector plugs in, that is a bit to big.

Thanks for your help!

AstroRookie

Link to comment
Share on other sites

  • 5 months later...
On 23/02/2021 at 20:43, AstroRookie said:

Every time I start the astroberry, I do a system update (sudo apt-get update && apt-get upgrade)

Hi there!

Sorry to bump this post; just saw it by chance. If I may, I only wanted to give my opinion about this. I've learnt the hard way than an update is not always free of problems. I've broken my installation (if not broken, it shows an unexpected and very very weird behaviour) a couple of times due to bugs introduced in some update. So I'm now very careful with updating the system. Before updating (even from time to time, without updating) I perform a complete backup (image disk) of the whole microsd card. I messed up the installation one time just a couple of hours before of my imaging session, due to a system update. It will not happen anymore; at least if I can avoid it.

 

CS!

Edited by mgutierrez
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.