Jump to content

sgl_imaging_challenge_2021_annual.thumb.jpg.3fc34f695a81b16210333189a3162ac7.jpg

Help please! Problems post modification of 450D


Recommended Posts

Hi all

This is my first post on this forum and I just wanted to start off by saying thanks to all members. I am just about to start out on the AP journey and it is thanks to a lot of the content on here that I have been able to develop the interest, confidence and plan to move forward with it! 

I was hoping my first post would be a little more exciting but I have a problem that I was hoping to test with others that may have seen something similar. 

I just tried to modify my Canon 450D following Gary Honis’s instructions (which were great). I am no electrical engineer but have been handy with such things in the past. I did not replace the IR filter - rather removed it entirely as I am planning on using a clip in LPS filter. 

I thought it went well but when I went to turn the camera on I got nothing on the LCD. The backlight was coming on but nothing else. The camera was autofocusing, shuttering and flashing. Just nothing on the screen. I opened it up, checked all the ribbons again, and this time when I closed it up the screen backlight wouldn’t come on either. The rest was the same. 

Any idea what I might have done/missed? Is it possible that the LCD back cover has just died?

The only other thing worth mentioning is the little black plastic part that has the hole for the white pin on the circuit board to go into -when I removed the circuit board, the black bit came away with it. There was a thin black flexible tube of sorts (1mm or so thick) that seemed to sit within the black part. I slotted that back in when putting it back together but not sure if that is usual or not?

Any help you could provide would be greatly appreciated. I plan to walk back through the process end to end next weekend to see if that does anything as I know some have had success just trying again.

Link to post
Share on other sites

We were lucky our 450d worked on reassembly, this was years ago.  I can remember the seating of the ribbon cables caused most problems. Not helpful I know but you have our sympathy.  Take it to bits and try again and better luck next time.

Link to post
Share on other sites

Yep I had to dismantle and do mine twice as I hadn't got everything seated together correctly (about 10 years ago now!). All you can do is dismantle it and do it again, if it still doesn't work, unfortunately it's not valuable enough to be worth sending off for professional repair. Sounds like it's still taking photos though, so could be used via USB to the purpose of astrophotography.

Link to post
Share on other sites

Not the same camera but I modded a used Canon XS. I removed both filters (confession-I broke both !)

I also lost the screen view. I had to reseat all the ribbons TWICE before normal service was resumed even though they all appeared to be seated fully and correctly.

I also had the black "tube" come away and it would not sit back in it's housing correctly. Not sure but I suspect the tube is a fiber carrying light to a sensor related to auto exposure setting.

If so it serves no function for astro purposes as only bulb exp. is used in MAN.

Link to post
Share on other sites

Thanks dobblob. That is helpful to know. I confirmed that the camera is taking pics this evening. Popped out the SD card and all looks good (and slightly red which is great ha). 
 

The other pain point is that the USB connection doesn’t seem to be working. It does nothing when I connect to a PC (tried a few). This is annoying because I could live without the screen if I could utilise remote live view via USB. The remote shutter port which is immediately above it works though which is making me scratch my head! 
 

Still hoping the full re-try on all ribbons this weekend does the trick

Link to post
Share on other sites
  • 3 weeks later...

Just in case anyone was wondering, I opened up the camera and reseated everything. The screen is well and truly dead but the USB port has come to life which is excellent. Back in business! Thanks for the responses all

  • Like 1
Link to post
Share on other sites

Glad to hear the USB connectivity has been restored.  If you are controlling the camera from a PC then it doesn't matter if the screen is dead as long as the camera still functions and you can take images.  I was lucky when I modded my 400D, but I have been around electronics since leaving school in '78 so it wasn't so much of a daunting job at the time.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.