Jump to content

stargazine_ep46_banner.thumb.jpg.34e6cdd5a0856b006a0b47c6373eb9b1.jpg

ASCOM and Skywatcher AZEQ6-GT


Recommended Posts

I'm trying to get set up to control my mount using my laptop and am hitting a brick wall with ASCOM so am wondering if I am doing things completely wrong.

I have an AZEQ6-GT, I have plugged one end of the 'Hitecastro USB EQ Direct Interface' cable into the Hand Control port and the USB into the USB port on my laptop.

I have downloaded the ASCOM driver from the Skywatcher website and it's picked up by the ASCOM telescope chooser.

I have installed all manner of the latest EQMOD and ASCOM drivers and software and I've tried connecting to the Mount using Cartes Du Ciel, Stellarium Scope but I can't seem to get anywhere.

It appears as though the Software needs me to select a COM port but it's 2020 and my Laptop (Surface Book 2) doesn't have any COM ports, the laptop is tethered to the Mount using the USB cable so I have no idea where to go next.

Any tips?

Link to post
Share on other sites

As the Surface Book, is a Windows 10 device, it still has COM ports, but you have to dig to find them.  

Have you installed the driver for the Hitecastro USB adapter device ??  if so, in Computer Management \ Device Manager \  under Ports, you should then see the adapter show as one of the COM(x) ports, and its this com port that you enter into the software. 

  • Like 1
Link to post
Share on other sites

I’m wondering about the bit about connecting the Hitecastro to the hand controller. I connect mine directly to the mount. It’s probably not a or even the problem, but I thought I’d mention it. I seem to recall they used to say that connecting via the hand controller was possible but not supported. 

I used to find the YouTube videos by Chris Shillito of the EQMOD project very instructive, including on COM port matters.  They are still on YouTube. https://www.youtube.com/channel/UCVrU4T3b2d25cMaqbGNBxQA

Things might have moved in since then so I apologise if the info is out of date. I now use KStars, EKOS and Indi for mount control so I’m somewhat out of touch with developments. 

Goid luck! :) 

  • Like 1
Link to post
Share on other sites

Connecting to the hand controller port is correct.  As has been said, it will probably be the COM port issue.  Double check the correct one is selected in the EQMOD setup.

Link to post
Share on other sites

Thanks everyone. I think we're getting somewhere.

I had installed the driver for the HitecAstro USB - and consequently it showed up in Device Manager under Ports COM & LPT. It's listed under COM4 which I read was a-OK. Previously, before I had installed that driver, it was showing as an unknown USB device, so when I sorted that I thought I had it licked. 

spacer.png

But the issue is, in all of the ASCOM utilities when I try to add and configure the mount, despite the fact that it showed up in the list after I'd installed the drivers:

spacer.png

The COM dropdown is blank:

spacer.png

 

Even trying to manually add '4' or 'COM4' into it doesn't work as it throws an error. When it's left empty it also throws an error.

spacer.png

I am befuddled. Any further things I should try? 

Edited by WicklowSkies76
Link to post
Share on other sites

Don't use Ascom.Skywatcher.Telescope, if you've installed EQMod correctly, one of the options in the drop down selector window, should be EQMOD.Telescope, i.e.

image.thumb.png.5b0a86dfdfcd880c437f890a208e55ec.png

  • Like 1
Link to post
Share on other sites

For the life of me I cannot find that screen. That and the fact that I don't see the EQMOD.Telescope in the options dropdown would suggest I do not have EQMOD installed either fully or correctly. I will investigate and revert.

Thank you all for the support thus far. You are legends... all of you!

Link to post
Share on other sites
2 hours ago, Dr_Ju_ju said:

In the Ascom setup window, under EQMod Port Details, when you select the drop down arrow by "Port" is COM4 one of the options ??

OMG... after a disconnect and reconnect and choosing 'COM4' followed by Connect, I am in!

 

HUGE THANKS!!! Would never have figured this out on my own. Never. Legend.

  • Like 2
Link to post
Share on other sites
  • 3 weeks later...

If you go via the hand controller, don't you need to set the hand controller to 'PC direct' mode? Just a thought for the future.

Link to post
Share on other sites

With the AZEQ6-GT you don't need a Hi-Tec or any other adaptor. You just connect with a standard USB cable from the USB port on the mount to a USB port on the computer. EQMOD will pick up the connection. I use this mount in my Obsy and that's how mine is connected.

Link to post
Share on other sites
8 hours ago, mallorcasaint said:

With the AZEQ6-GT you don't need a Hi-Tec or any other adaptor. You just connect with a standard USB cable from the USB port on the mount to a USB port on the computer. EQMOD will pick up the connection. I use this mount in my Obsy and that's how mine is connected.

Yes, I don't know when SW introduced a USB port in these mounts. My older AZ-EQ6 doesn’t have one. I don’t think Wicklowskies  mentions whether his mount has one or not. I must say I don’t understand why you would connect to the hand controller when the   Hitecastro USB EQ Direct Interface' cable connects  directly to the mount. The hand controller doesn’t do anything, as far as I can recall, when connected to the computer.  
 

PS When you connect your mount to the computer via USB can you still control the mount locally with the handset still connected - or is the handset USB too? 

Edited by Ouroboros
Link to post
Share on other sites
On 06/02/2021 at 07:53, Ouroboros said:

Yes, I don't know when SW introduced a USB port in these mounts. My older AZ-EQ6 doesn’t have one. I don’t think Wicklowskies  mentions whether his mount has one or not. I must say I don’t understand why you would connect to the hand controller when the   Hitecastro USB EQ Direct Interface' cable connects  directly to the mount. The hand controller doesn’t do anything, as far as I can recall, when connected to the computer.  
 

PS When you connect your mount to the computer via USB can you still control the mount locally with the handset still connected - or is the handset USB too? 

The handset has a dedicated port and the USB port is separate. I'm not sure if the direct usb connection overrides the HC as I've never used the handset.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.