Jump to content

548140465_Animationchallenge.jpg.32379dfa6f3bf4bba537689690df680e.jpg

Making a mosaic using CDC and apt


Quatermass
 Share

Recommended Posts

Has anyone used apt and CDC to make a mosaic successfully if so can you help me out as I'm having a lot of issues getting the frames CDC creates for its mosaic to match my alignment in apt. I can import the mosaic from CDC to apt after I've plate solved and aligned but it ends up shifting the position to the left just off were it should be, it's driving me nuts. The only way I can accurately align them is by nudging the telescope back to the frame marker but sending the frame position coordinates to apt just keeps missing the frame again beginning to wish I had not gone down this dark and troubled road.

Edited by Quatermass
Selling error
Link to comment
Share on other sites

Guess not then.. but I have been investigating this and have come up with the following issues so hopefully this might help someone who is daft enough to try it 

In this picture you can see the mosaic panels in CDC lining up nicely with the telescope position which looks good so you send the mosaic coordinates to APT using the send via server button into APT and use them to position your telescope but…

image.png.f0f6127ae7160c907e3a5ad1c9f47f8b.png

The problem is the slew moves past the area when I use the coordinates that CDC is giving me when there supposedly lined up as in the above image. You can get around this by nudging the telescope position along so it lines up with the mosaic panels but that’s not what we want.

image.png.b176d0bde61057e51a9709a019cd606d.png

Conducting some tests I found out that if you use the go to coordinates in APT to find M45 and hit go to it will slew to M45 and show that position in CDC but if you find M45 in CDC and hit sync in CDC it will move the fov reticule away from the position that APT had set. Telling me that that CDC and APT coordinates for this target are not the same. Let’s just check the RA and Dec to make sure

image.png.bb6f6dda8ae8e0f9c722166fb1d7a87d.png

Yep not the same. Maybe this is why CDC is kacking up because the mosaic frames and apt are not lining up in which case it’s not much use and to be honest I have had enough of this frustration. On one of the APT forums another guy doing this said he just copied the dec ra positions from the center of the frame and put them in APT which kind of defeats the whole point really.

Oh well maybe it is my dyslexic brain maybe its CDC and APT maybe I am just cursed who knows sigh.

 

Link to comment
Share on other sites

OK.

Just make sure both programs use the same setting.

J Now or J2000

(Due to the wobble in the Earth’s orbit the RA and Dec positions of the Stars appears to change. The older star atlases used Epoch 1950 for their positions, newer atlases use Epoch 2000.)

Edited by Merlin66
  • Like 1
Link to comment
Share on other sites

I think I may have found the problem thanks to your information about the epoch setting and a bit of diggin g on the apt forums I found this..

 Mon Jan 21, 2019 6:11 pm

UPDATE 13/04/2019

As of APT V3.65.5 (beta), the problem described below has been resolved within APT itself. :-BD

Now, when the APT > Gear > JNOW" setting is selected it automatically converts the PlateSolve2 (PS2) and AllSkyPlateSolver (ASPS) communications to JNOW.

So:
  • PS2/ASPS to APT is always J2000 (note: ASPS must be set to J2000)
  • If APT JNOW is selected, then
    • APT to planetarium s/w is transmitted as JNOW
    • planetarium s/w to APT is transmitted as JNOW (note: planetarium must be set to JNOW)
    • APT to PS2 is transmitted as J2000
  • If APT JNOW is NOT selected, then
    • APT to planetarium s/w is transmitted as J2000
    • planetarium s/w to APT is transmitted as J2000 (note: planetarium must be set to J2000)
    • APT to PS2 is transmitted as J2000
So, for example., I have the following settings:
  • "APT > Gear > JNOW" selected.
  • "ASPS > settings > Platesolve settings > advanced > platesolver coordinates epoch" set to "J2000"
  • "CdC > Setup > General > Server > Coordinate system to use with clients" set to "Current chart coordinate system"
  • EQMOD set to JNOW (though apparently this doesn't matter)

The Problem

The problem starts with Platesolve2 (PS2). It provides it's solve data in J2000 epoch. Although there appears to be a PS2 setting (PS2 > View > Parameters > Default Catalog epoch) to change the coordinate system, it seems to make no difference to the result.

APT, acting as the middleware, can pass these coordinates on to Cartes du Ciel (CdC) for it to show (APT > Gear Tab > Point Craft > Show) as a rectangle of the appropriate Field of View and Orientation (CdC > Right Click > Finder Circle > Rectangle).

Image as shown in APT's Preview window
Capture a.JPG

If CdC happens to be displaying in "Equatorial coordinates", with "type" set to "Mean J2000" then the rectangle is exactly the same as APT shows in it's preview window. The Chart coordinate system can be set here: CdC > Setup > Chart Coordinates > Chart coordinates system > Equatorial coordinates and Type of coordinates > Mean J2000

Solved FOV and Orientation Rectangle as shown correctly in CdC
Capture 2a.JPG

However, as soon as CdC is set to display in "Alt-Az coordinates", it automatically changes the "Chart Coordinates" to "Azimuthal coordinates" with "type" set to "Apparent" (i.e. JNow). This means that the the displayed rectangle is offset, by at about 1arcmin as of 2019.

Solved FOV and Orientation Rectangle as shown incorrectly in CdC
Capture 1a.JPG

Although APT can be set to use "JNow" (APT > Gear > JNow) it makes no difference to the CdC display because in this case it's just acting as middleware.

The Solution

Patrick Chevalley (CdC developer) and Ivo have collaborated to resolve this issue.

Patrick has kindly provided a setting in CdC that means that all communications with external applications (in this case APT) can be forced to use the J2000 epoch, irrespective of the coordinate system used for it's display. The CdC setting is under "CdC > Setup > General > Server tab > Coordinate system to use with clients > Force J2000"
 
Capture 3a.JPG

For consistency, with PS2's epoch, the other requirements are that:
  • All Sky Plate Solver (ASPS) is also set to use J2000: select "ASPS > Settings > Plate Solver Settings > Advanced > Plate Solver Coordinates epoch > J2000"
     
    Capture 4a.JPG
  • EQMOD/EQASCOM (if you use it) is set to J2000
     
    Capture 5a.JPG
To be honest, I'm not sure what other mount drivers require.

Notes

Note: It makes no difference to this setup whether APT is set to use "J2000" or "JNow" (APT > Gear tab > JNow). However, it's probably worth keeping all the coordinates the same, so deselect this option.

As of 21/01/2019 this option in CdC is only available in beta. For those that want to test it it can be found here: http://sourceforge.net/projects/skychar ... 019-01-21/.
Please note, this is a Beta version, so there is no guarantee it won't have issues. So it's use should be treated as such.

A final thanks to Patrick and Ivo for implementing this solution in only a couple of days! ^:)^ ^:)^ ^:)^
Link to comment
Share on other sites

Goodness me that was driving me insane. So it seems that in CDC you need to do all of the above but now in APT there is a setting that changes the all sky plate solver setting for you as in this section.. I was going to just forget it and use eqmosaic as I have done in the past but will test it out again with the new setting in CDC and APT and report back on my findings fingers crossed.

.image.png.88772ac559cef60db6336dad66d2222b.png

Link to comment
Share on other sites

Just another up date for those that may run into this issue trying to do a mosaic with APT and CDC. 

It now seems to be working and syncing the Mosaic panels in CDC  with my telescope position when I use APT.

First I changed the settings in CDC so that force J2000 is selected.

image.png.91b1151ebcbc6c925974fbd97493b88a.png

Next I changed the setting in EQMOD driver set up to J2000 under Ascom options

image.png.78c4a63160a3426de33160445a726efe.png

In APT I made sure that the JNow button is not activated as we have told CDC to use J2000 and this would change that.

image.png.793f3244ac39cf6c3f269a8575d781e5.png

And lastly I have kept my coordinates in CDC to Alt/Az not Equatorial coordinates as it does not work if its in EQ settings and APT is using AZ/ALT

image.png.0f0eaaad83eccae51f8a8daa25cdef24.png

With that all done find your target of choice in apt and go to it. Then in CDC under view bring up Mosaic and set the panels how you want them to be. Then press send via server in the Mosaic panel and it will send them to APT. In APT go to the objects-to do section under the gear tab and from here  you choose import list and then mosaic frames from CDC. Once that is done chose which frame you want to image from your mosaic and hit go to. All being well it should show the telescope position lined up nicely with the mosaic panel in CDC now. I had no idea what J2000 was or what an epoch was before I posted this so I am very grateful to this forum and the wonderful people on here who help each other out. Phew that was a steep learning curve I think I need a beer now.

image.png.7e92cb2c99c607193d7b6d9d323340e0.png

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.