Jump to content

sgl_imaging_challenge_banner_31.thumb.jpg.b7a41d6a0fa4e315f57ea3e240acf140.jpg

Ctrl + 1 not working in Sterallium


Recommended Posts

Hi there,

 

So I've finally gotten round to setting up APT and Sterallium (via ASCOM) on my laptop for controlling my mount EQM 35 pro. (I got PHD2 working on it a while back).  I followed a tutorial on youtbe about doing this using simulators in Sterallium, when doing this pressing control + 1 on the keyboard moves the simulated telescope and everything seems to update in ATP and work fine.

 

The (small) problem I'm having is when i successful connect my own mount in Sterallium (after doing the same in APT) I click on an area and then press the short cut Ctrl + 1, nothing happens, my yellow telescope icon doesn't move to the location, but when I do it in APT, sterallium obviously updates to show the new position.

 

Any idea why the short cut in Sterallium isn't working when connected to my mount?

 

Cheers,

Mark

Edited by Sidecontrol
Link to post
Share on other sites

Assuming you have Stellarium Scope (a third party program) installed and properly configured I think from memory you have to click on the object you are interested in within Stellarium and then press Ctl 1

It's ages since I used a PC with ASCOM/Stellarium/Stellarium Scope but it worked very well.

 

  • Like 1
Link to post
Share on other sites

You do not need Stellariumscope in the latest versions of Stellarium , it has been integrated into the core program.

 

I sometimes find Ctrl +1 unresponsive , but after a few tries it seems to reset and work , no idea why , maybe don't hit the 1 too soon after ctrl

I have found allowing a second or so with ctrl down before hitting 1 usually makes the scope slew OK

  • Like 1
Link to post
Share on other sites

I knew that ASCOM had been incorporated into Stellarium, but I thought you still needed Stellarium Scope for the CTRL buttons to work to align your scope?

Edited by BrendanC
Link to post
Share on other sites
3 minutes ago, TerryMcK said:

Assuming you have Stellarium Scope (a third party program) installed and properly configured I think from memory you have to click on the object you are interested in within Stellarium and then press Ctl 1

It's ages since I used a PC with ASCOM/Stellarium/Stellarium Scope but it worked very well.

 

No not using that, but I'll go give it a look at thanks.

Link to post
Share on other sites
1 minute ago, fifeskies said:

You do not need Stellariumscope in the latest versions of Stellarium , it has been integrated into the core program.

 

I sometimes find Ctrl +1 unresponsive , but after a few tries it seems to reset and work , no idea why , maybe don't hit the 1 too soon after ctrl

I have found allowing a second or so with ctrl down before hitting 1 usually makes the scope slew OK

Thanks, it's a crappy old laptop, so i'll give it a try!

Link to post
Share on other sites

You do not need Stellariumscope in the latest versions of Stellarium , it has been integrated into the core program.

You do need to activate the telescope control plug in however , and configure it for your system (click configure button)

 

 

Image11.jpg

Link to post
Share on other sites
18 hours ago, fifeskies said:

You do not need Stellariumscope in the latest versions of Stellarium , it has been integrated into the core program.

You do need to activate the telescope control plug in however , and configure it for your system (click configure button)

 

 

Image11.jpg

Yeah I've done all that, when i connect my telescope icon appears near polaris.  Problem is can't get it to move in sterallium, but when i tell the mount to go to a target in APT while the mount is moving I can see the telescope icon moving in Sterallium.  I mean I could survive the way it is, but i like to know why things are not working (i.e have i missed a step somewhere). 

Link to post
Share on other sites

I always open and connect APT and PHD2 guiding first. Also do a Platesolve with a test target using APT. (And Sync mount to platesolve co-ordinates)

Then start Stellarium.

 

If I dont do that order I find Stellarium will not work properly , or places the scope target wrong.

 

Default opening has Scope Icon at Polaris , I use a custom park (horizontal) to fit my scope under my Roll of Roof.

APT seems to handle this recovering the Custom Park co-ordinates wheras Stellarium gets confused if opened first.

Edited by fifeskies
Link to post
Share on other sites
Just now, fifeskies said:

I always open and connect APT and PHD2 guiding first. Also do a Platesolve with a test target using APT.

Then start Stellarium.

 

If i dont do that order I find Stellarium wil not work properly

ah cool, im doing a dry run before it gets dark tonight, but I pretty much have done the same in my dry run, although i did notice a couple of new errors in APT.  See image attached.

Connecting to Sterallium Porblem (5)

WinHTTPSendRequest: 12029: A connection with the server could not be established

IMG_8514.jpg

Link to post
Share on other sites

I have a fixed system in my ROR observatory.

If you are taking down and resetting each session , take care to use the same USB ports as before or you may get comms errors when gear is not on the comms port it is expected to be found on.

  • Like 1
Link to post
Share on other sites
1 minute ago, fifeskies said:

are you using the latest versions of APT and Stellarium

I upgraded both to latest stable versions and seems to run OK.

I downloaded and installed them both a couple of days ago.  Thanks anyway, hopefully someone is familiar with those error messages.  I'll go try google. 

Link to post
Share on other sites
1 minute ago, fifeskies said:

I have a fixed system in my ROR observatory.

If you are taking down and resetting each session , take care to use the same USB ports as before or you may get comms errors when gear is not on the comms port it is expected to be found on.

Yeah I learned that the hard way haha. 

Link to post
Share on other sites
16 hours ago, BrendanC said:

I'm pretty certain that error message in APT is because you don't have the telescope remote plugin activated on Stellarium. 

Go through this page and you should get set up properly: https://www.lightvortexastronomy.com/tutorial-setting-up-an-equatorial-mount-on-ascom-with-eqmod-stellarium-and-cartes-du-ciel.html

I'll give my set up another look through after work today. 

Link to post
Share on other sites
On 06/01/2021 at 17:14, BrendanC said:

I'm pretty certain that error message in APT is because you don't have the telescope remote plugin activated on Stellarium. 

Go through this page and you should get set up properly: https://www.lightvortexastronomy.com/tutorial-setting-up-an-equatorial-mount-on-ascom-with-eqmod-stellarium-and-cartes-du-ciel.html

Turns out my Sterallium wasn't up to date.  Ended up installing EQMOD, so i'll be using that now with Sterallium. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By GeekTeacher
      Hi all,
      Can anyone please point me to a clear and complete set of instructions for both setting up and using the MGEN-II autoguider with Astro Photography Tool.  I need to start right from the beginning.
      Many thanks
      Martyn
    • By SStanford
      Hi All,
      For what has seemed like forever, the clouds finally parted late last night and the Orion constellation was very clear from my balcony.
      I had a brief window of opportunity earlier this week and had difficulty focusing on stars at all using my DSLR (Canon 450D) and APT. 
      Last night was a breakthrough; I was able to capture starlight in APT liveview and even bring the stars into (significantly better) focus!
      I now face my next challenge; I am unable to focus sharply on any of the stars.  Using my telescopes focusing wheel I seem to get only blurry spots of light coming through, despite very carefully adjusting the wheel for quite some time.
      At the risk of embarrassing myself, I've attached the images of Rigel and Betelgeuse I captured last night (on both long and short exposures, details of ISO and exposure are detailed in the image titles). This is as sharp as I can them.
      Is there anyway I can fine tune the focus? I've seen AP videos on Youtube where jam jar lids have been glued to the focus wheel or motorized focusers attached. Are these gimmicky or do they make a significant difference?
      I should mention that I don't yet have a tracking mount:  I've eyed the Skywatcher AZ-GTI wi-fi as good candidate for my first meaningful mount (with the EQ wedge coming shortly after).  Having emailed a number of retailers it seems these are in very short supply, here's hoping stock replenishes post-Christmas! I think this will let me get to grips with the equipment I have right now, definitely would like to get a sharper image, even if I'm only capturing star trails.  
      to capture the images shown below I used:
       - Celestron 100AZ (100mm Aperture, 660mm focal length)
       - Canon 450d 
       - Barlow lens x2 (Celestron)
       - APT (connected DSLR directly to laptop via USB)
       - Stock Celestron Alt-Az Mount
      All the best.
      Single__0049_ISO400_0s4s__20C.CR2 Single__0034_ISO1600_30s__20C.CR2 Single__0027_ISO1600_30s__20C.CR2 Single__0012_ISO1600_1s__20C.CR2 Single__0011_ISO1600_30s__20C.CR2
    • By Bob_the_Science_Guy
      Hey Guys, 
      I run a Youtube Channel and as part of that I like to live stream the telescope.  But the problem is lack of consistency.
      Equipment:
      Orion EON 110, Meade 10" SCT
      Orion Mount - Exos2-PMC. Meade Mount 'push to' alt az with clockwork drive
      APT, SharpCap, PHD2, Stellarium, ASCOM Hub
      Focal Lengths Orion 660mm, Guide Scopes 188mm, SCT 2500mm
      Powered USB for ZWO cameras (120 and 294)
       
      Here is what happens:
      Cameras, sometimes work, sometimes don't.  I am not making the mistake of trying to get APT and SharpCap to view the same camera.  I used APT for the guide scope and SharpCap for the main tube and the 294.  Sometimes APT will take an image, sometimes it will do live view, sometimes both, sometimes neither.  It is very distracting to the stream to spend an HOUR turning the computer off and on, plugging, unplugging and replugging the cameras just to get them to image.
      When I do get an image it plate solves at the NCP, but if you move away, setting the coordinates to the scope position or the object I am looking at, it doesn't consistently plate solve.  Sometimes it does, sometimes not.  It is completely irregular and can change within a session.
      Not all three plate solving means even work, for blind solve, 
      ASTAP never seems to work, either in point craft or locally stand alone
      PS2 and ASPS work intermittently, as above
      I did download all the catalogs and they are in the default directories.
      This is very frustrating and I was wondering if anyone else is having this issue or has suggestions.
      Bob
    • By Padraic M
      I spent the full night out last night and got 6 hours of Ha lights on the Bubble and the Horsehead. Reasonably pleased with the results, but even though I followed my usual process and got good focus statistics in APT, I am slightly out of focus with roundy stars and some are even slightly donutty. Samples are attached below.
      Problem:
      - After getting close to spot-on focus, the APT Bahtinov Aid showed a focus distance oscillating from -0.02 to +0.02. Seeing seemed good to the inexpert eye. Not so sure about transparency as there was some thin, wispy cloud throughout the night. So, I started the night's imaging with focus 'Close' rather than 'On' focus.
      - Different subs show different quality stars, ranging from small donuts to circles.
      Background information:
      - HEQ5 Pro Rowan; SW Esprit 80 with field flattener, SW stock manual Crayford focuser; ZWO EFW Mini; Baader 1.25" 3.5nm Ha filter; ZWO ASI1600MM Pro binned 1x1 @ -20c.
      - AA Starwave 50mm guidescope with ZWO ASI290mm Mini guidecam binned 2x2.
      - All subs are 300s, gain 139, offset 10.
      - Polar alignment with Sharpcap to 17 arcsec ("Excellent"); capture with APT; guiding with Phd2. Focus with Bahtinov mask and APT Bahtinov Aid. Stacked in DSS with Darks, Flats and Dark Flats.
      - Mount is well balanced in RA, but is very camera-heavy in Dec.
      - PHD2 guiding was around 2"/px. Imaging pixel scale is 1.9"/px.
      Questions:
      - Do I put the round stars down to seeing, given that the Bahtinov Aid focus distance was bouncing equally above and below zero?
      - Can poor seeing cause the donut stars?
      - Would an electronic auto-focuser do any better in this situation?
      - Would the Seeing Monitor in Sharpcap give useful information? I didn't think to use it last night.
      - Could my guiding performance, and possibly the Dec balance, have affected the image quality in this way?
      - What are my options in future - abandon imaging for the night? Bin all images in software 2x2 or 4x4 to sharpen the stars at the expense of lower resolution?
      - Other suggestions?
      Sample 1: Detail from a single 5-min sub of Bubble nebula at 100% showing round stars, and a blurred bubble.

      Sample 2: Detail from a different sub of the Bubble nebula at 400% showing donuts

       
      Sample 3: Detail from a 5-min sub of the Horsehead nebula at 100%, showing both round and donut stars

       
      Finally, both images stacked, calibrated and stretched, scaled to 4x4 in Gimp. 28x300s Ha on bubble, 22*300s Ha on horsehead.


    • By Padraic M
      How can I set up APT so that it always connects by default to my imaging camera? I have an irritating problem that APT will regularly connect to my guide camera, even though that camera is already connected in Phd2.
      I have created two APT shortcuts on the desktop, one specifying camera 2 (which usually is the guidecam) and the other specifying camera 1 (which is usually the imaging camera), but it looks like cameras 1 and 2 are not absolutely assigned to the ASI1600mm (imaging) and ASI290MC (guiding).
      At APT startup, in the log it will say 'Connected to ASI1600mm' and then imediately say 'sensor size 5.6mmx3.2mm'. Then I know I have a problem as it's obviously not the 1600! I can usually sort it out by disconnecting, Shift-Connecting (to get the camera selection dialog), and selecting cameras 1 and 2 until I get the correct sensor size.
      There must be a better way?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.