Jump to content

Recommended Posts

FLO sent me this beast of a mount for review, and after a few months use I've finished said review. If you don't want to read, then scroll to the bottom to see the video. If not, let's go.

From the top, the dual type Vixen/Losemandy type puck, and at the back of mine it had 3 5521 type power ports for powering equipment, and 3 USB ports (2 powered) for connecting to the internal USB hub network. Whilst I didn't exactly use this network, it's still very handy to use, especially being on the puck - it means you don't have to worry about any slack on your cables and they won't pull. A handy feature. The power ports seem to be of a different type to 99% other astronomy hardware though, which means you'd need to get different connectors, a major inconvenience which still will make itself known later.

The mount includes an iPolar system, which is absolutely awesome. Sure the UI looks like it's straight out of Microsoft Paint but it's certainly function over form as it's quick and uses plate solving to align. This means you can polar align even with a semi-obstructed view to the pole. It's powered by a USB2-B port at the back of the mount with no need for external power. There is no manual polar scope on the mount so a computer is a must for polar alignment.

The carry capacity of 31.8kg is a hefty amount, though it's advised to not exceed 21kg for astrophotography. I never loaded it up with this much equipment however the sheer build quality and performance of this mount leads me to have no concerns whatsoever about using that much weight, or even all the weight. It's always advised to use underneath the stated maximum capacity anyway.

The altitude adjustment knob is a hefty coarse worm gear style affair. Embossed with the iOptron logo. It's a nice way of adjusting, especially when coming from GEM mounts where you have to undo/do up two individual bolts. However on my mount it was let down by an abhorrent squeak it made when raising it whilst the mount was loaded up. When going down in altitude sometimes the gear would jump a bit and let the mount down even further than I wanted. Azimuth adjustment was fluid and great.

The control panel includes its power port, power switch, hand controller port, ST-4 port and the USB port. The USB port can be used to control the mount via computers, and is also the other end of the internal USB network. It is USB2-B. 

A major issue I found was the power port. It wasn't the standard type DC centre-positive tip style that all my other astro equipment used. IT's also a standard female type port, whereas I would've liked to have seen a screw type connector for this price point. But yes, the biggest gripe was the different style port, which meant I couldn't power it using my power box (without getting more cables), and had to use the supplied plug.

The carry case is a substantial and very sturdy box. It's foam cutout and very tight in holding the equipment. All but the counterweight goes into this box and I believe it could really survive quite a harsh fall. It's very well built.

Slewing with the CEM70 was quick and fluid, it was also quieter than I was anticipating for such a large bit of machinery. Using its own dedicated software through the laptop was intuitive and there was little to no learning curve. The axis clutches, whilst using a small switch, feel solid and substantial with a nice meaty clunk when engaged. One lock position is the EQ Home position which makes life a lot easier.

When guiding, I was regularly getting values of 0.4-0.6" total error. This enabled me to take extremely long exposures if I so desired, though I mainly did  5 minutes, I was able to do 10 under testing. Unguided (just sidereal tracking) I was only able to achieve 2 minutes before trailing was found with my Evostar 80ED (reduced to 510mm) and ASI 071mc Pro. Now in full admittance the mount was unbalanced as the Evostar package was too light for the mount. 

The counterweight, if moved too high up the bar, will strike the body. So you would need to buy a lighter weight if you wanted to balance a lighter load on the CEM70.

Also when attaching it to a tripod or a tri-pier, you do need to bolt down 2 spring loaded bolts down with the supplied allen key. Now this is a bit fiddly and adds several minutes to the setup and tear down times. Though I suspect iOptron made this mount with a permanent setup in mind so if you're putting this into an observatory then this won't be a problem. For me, who setup and torn down the rig each night when using it, became a bit of a chore.

Overall I found the CEM70 to be an extremely capable mount with a lot of features. Whilst there are niggles that detracted from the user experience; the altitude gear squeak and the non standard power ports. Other features improved the quality of life and user experience enough to vastly outweigh the drawbacks. The iPolar system is particularly capable and excellent, the carry capacity, build quality also and guided performance, as well as the internal USB hub. 

I think this would be a nice investment if you were looking to mount larger scopes on, or decking out an observatory. I can't afford one but if I was making my own permanent setup I would severely consider buying one. 

If you're interested you can find more information at the links below (if you did buy through these links, I'd earn a few pennies to help support these reviews).

iOptron CEM70 w/o iGuider: https://bit.ly/CEM70

iOptron CEM70 w/ iGuider: https://bit.ly/CEM70iGuide

iOptron Tri-Pier: https://bit.ly/CEM-Tripier

 

Thanks for reading everyone. What are your thoughts about this mount? I hope my review has been helpful for you :D clear skies all, keep looking up and keep them cameras clicking.

  • Like 8
Link to post
Share on other sites

If I understand correctly, this is a new design?

Only time will show if it's reliable enough for such a large amount of money.

I guess that the tri-pier is a necessity for this heavy mount.

N.F..

 

Link to post
Share on other sites
5 hours ago, nfotis said:

I guess that the tri-pier is a necessity for this heavy mount.

That's a good point. Since the CEM70 is only the mount head, without a tripod or pier, any review about the performance won't be about the mount itself. It has to be for the combination of mount + extra-cost tripod.

Link to post
Share on other sites
  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By deanchapman2705
      Hi guys, hoping you can help with the tracking problems I'm coming across with my astrophotography setup. I've been using it since August 2020 and have kind of put up with the problem until last night where I think it's getting worse...
      Specs below (let me know if you need anything else):
      William Optics Zenithstar 61 II (360mm F6.1) - Zenithstar 61Adjustable Field Flattener iOptron SkyGuider Pro Camera Mount Full Package K&F Concept Aluminium Tripod with 2kg weight Canon EOS 250d (cropped sensor 1.6x) The problem:
      I take roughly 40 pics with each being 1 minute long at 1600 ISO and stack them on DeepSkyStacker. From a few people I know on the internet, it seems as though, with a very similar setup and same focal length, they can get around 3 mins of exposure with no problem. And that's without a guide camera.
      With my 1 minute exposure, roughly 10 of 40 images are reasonable but the rest have star trailing or double stars (see attached downscaled, unedited pics of Orion nebula)
      What I think it could be:
      My first idea was the tripod, it's not the best but it's not cheap plastic, and it should be fine for a 1 min exposure. Then I thought it could be the iOptron tracker that could be faulty?
      Every screw has been tightened, there's no play in any of the adapters/mounts.
       
      I thought I'd post this here to see if anyone else has the same problem or has more experience/knowledge that could help. Also to see if there's an obvious problem before I spend hundreds on a new tripod or send the tracker back for a replacement.
      Any help would be much appreciated!
      Thanks,
      Dean
       









    • By ABPhotosUK
      Hi all,
      I've had my new CEM70 for about a month now and getting good results unguided so far. The only issue I have is the Latitude adjustment clamps are very stiff and hard to turn, so much so that the Western side one no longer tightens enough. Before I start fiddling and spraying WD40 has anyone else had the same problem and solved it?
       
      Many thanks and clear skies.
      Andy
    • By SStanford
      Hi all, 
      I have what might be a silly question regarding alignment of the start adventurer:
      Are you able to align the mount without being in sight of Polaris? 
      I'm weighing up my mount options and was curious if this is possible. Most of my AP will be done from my balcony and unfortunately the North star isn't visible at all from this point. 
      S. 
    • By Brownthunder93
      Anyone have any idea where I can get a replacement counterweight bar/shaft for my EQ5 mount? 
    • By xvariablestarx
      I recently moved back to Ireland, having been in the USA a long time, and I had to leave my 8 inch Dob behind. What i did bring was two OTA, a 80 mm Orion Goscope refractor, and an Explore Scientific  100mm Mak. Now i do has a basic alt az mount for these but i have a longing for a very basic GoTo system like the iOptron cube-e. Would that work ok?
       
      P.S. sorry if this shouldnt be a beginner question
       
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.