Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

stargazine_ep24_banner.thumb.jpg.56e65b9c9549c15ed3f06e146fc5f5f1.jpg

Recommended Posts

Hi All, 

I've recently acquired a pair of Celestron 20x80 Pro bins; however even with the lock nut tightened there is some slight movement with the reflex sight rail. I'm using a Baader SkySurfer III RDF.

Thanks 

Edited by R3Z4

Share this post


Link to post
Share on other sites

Have you tried adding a washer?

Share this post


Link to post
Share on other sites

Thanks, but the movement occurs whilst the reflex sight rail is attached to the support rod. 

Share this post


Link to post
Share on other sites

Oh. Maybe  try a strip of rubber around the rod.

Share this post


Link to post
Share on other sites

Good thinking Ruud 👍 I’ll try that and see if it helps? Thank you.

Share this post


Link to post
Share on other sites
34 minutes ago, Sky-searcher said:

I used insulation tape to build up the bar for my clamp. 👍

That’s a great idea! I’ll have to test it out, as there’s not much space between the clamp and the support rod, but enough to make it slip. Thanks 

Edited by R3Z4
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.