Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

Recommended Posts

Hi guys,
With new mount and upgraded scope features, now looking to venture into imaging.
Before I start, I'm not looking to get feedback on polar alignment, mono guidecam, better imaging cameras, etc; this is more a 'dummies guide' setup discussion! I'm not expecting to get great images at this stage, just more the options available, getting over some issues, so that I can jump outside on a clear night with an ideal, foolproof(!), setup for either imaging or visual as time would permit and what may work best for me. As you may guess from the topic name, I'm a mac user (Macbook Pro) and would rather keep to this if possible (whilst I do have Windows (and Ubuntu) via parallels, I'd rather not use these).

I've got a setup which has worked well for visual, and obviously want to have a couple of 'staple' setups that I can use depending on expectations of night observing or imaging. So far, the best one for me has been the Skywatcher Wifi Synscan controller, which has worked a treat with my Android phone - I use the Synscan app to complete alignment and GOTO stars/planets/DSO etc, or Stellarium_plus after completing alignment. This removes the need for the Synscan Handset and any USB cables to the mount altogether. But I don't know if this will work for guiding.

That then brings me to my issue on mac - connecting USB(A) between Macbook and Handset, I've attempted to control the mount through Stellarium. Trying each of the available connections (/dev/tty.usbsetial-1420, /dev/cu.usbsetial-1420, and just for sake of it, the /dev/tty.Bluetooth-Incoming-Port and /dev/cu.Bluetooth-Incoming-Port) in the dropdown menu under DeviceSettings/SerialPort, I cannot get the mount to connect (well, more like selecting the telescope and clicking the "Start" on the TelescopeControl just results in the spinning icon and I have to Force-Quit Stellarium and start again with the same result each time. Annoyingly (for fellow mac users!), Parallels/Windows/Stellarium connects and controls the mount fine! As the mount is the newer "pro" type, I also have a USB connection directly under the hand-controller RJ45 and AutoGuider ST4 sockets, but using this still results in the same issue. Another issue I have seen is that when I unplug the USB from the computer when connected to the handset, the date on the controller jumps significantly - for example, last night at ~23:30, I was transported through the local wormhole galaxy to Jan 2048 according to Synscan! Obviously unplugging isn't going to happen during a genuine session, but just wondering if this is a possible issue somewhere?!

Any other mac users connecting USB directly to the SW 'Pro' mounts?

Software wise, would folks generally suggest steering away from Stellarium towards KStars or SkySafari(Plus) for controlling the mount?
Can the Wifi dongle be used for controlling mount from computer (any OS) or do I need to go USB either to handset or directly to mount?
Is there an issue in using Mac USB to the telescope compared to 'straight' Windows (i.e. PC/laptop with Windows instead of virtual)?

Anyway, back to topic... I've a Nikon DSLR to use for primary camera at this stage, which would be triggered independently from guiding software. PHD2 is my hopeful choice of guiding software (is EKOS with KStars similar?), with T7C guide-camera on 240mm f/4 guidescope, and at this stage, I can confirm PHD2 at least connects to the camera on OS-X. There is an ST4 port on the camera, but having read several topics, I think I want to pulse-guide directly - is this correct or is ST4 best for this setup? This sorta comes back to software and connections - my understanding is one of the following cable setups for guiding (as a minimum) :

Guiding-camera => USB(A) => Macbook => PHD2 => USB(A) => SynscanHandset => AZEQ6
Guiding-camera => USB(A) => Macbook => PHD2 => USB(A) => AZEQ6
Guiding-camera => USB(A) => Macbook => PHD2 => Wifi => SynscaWifi Adapter on AZEQ6
[using ST4: ST4_on_AZEQ6 => Guiding-camera => USB(A) => Macbook => PHD2] (no additional connections needed if ST4 is used)
Additionally, I'd like to use an observatory package, say Stellarium/KStars/SkySafari, to select objects and drive the mount, then use guiding software to keep good 'tracking'.

Where in this train does EQMac fit in, or when is it used?
What about the 2019 addition to EQMod (ASCOM Alpaca)? Can this be used or is it already in other packages?!
For Windows users, how does EQMod fit in (if I go down route of getting Windows laptop for controlling things, is the setup similar to above?
There may be bits in the above that repeat, and for that, I'm sorry, just want to get across the message that I'm new to the guiding but haven't quite settled down into the software/hardware I'm expecting to use for 'goto' and 'guiding'

For a mac user, what setup and software are folks using for guiding and observatory softwares for the newer USB-on-mount 'AZEQ6/EQ6-R Pro' mounts from SW?

Share this post

Link to post
Share on other sites

Keep it as simple as possible, Use EKOS. The new multistar guiding looks like it has surpassed PHD2. You can also use PHD2 in EKOS.

Connect mount to MAC direct with standard USB cable, baud rate needs to me set to 115200.

I believe you might be able to control the Nikon in EKOS, Canons definitely.

Don't bother with ST4 at all.

KStars/EKOS will do everything, no real need for anything else. Works a treat for me and my MAC + AZEQ6

  • Like 1

Share this post

Link to post
Share on other sites

Thanks for that Mark, looks like what I'd expected - we mac users can do all at once!
Regarding alignment, how do you solve this then? Using the hand controller?
Where did you set USB baud rate?
I'm assuming setting wise (to get started) is to use:

MODE set to REMOTE - how to select the Port, or is this set once stuff is connected (don't have scope access just now)?
Internal guiding (rather than PHD2)
Skywatcher=>Synscan Mount
IndiHub Off

Anything else or should that at least get things started?

Is there a good place to start with KStars? Where does INDI come in or is that the under-the-hood stuff?
What mount do you select

Share this post

Link to post
Share on other sites

EKOS has a polar alignment routine, once you get close using the visual polar scope you would run the PA in EKOS and if careful can get within 5 arc seconds.

Initially EKOS will try to detect ports and connect automatically. Sometimes it doesn't and you can set the baud rate in the INDI control panel in the mount section.

In you equipment profile set mode to LOCAL, Mount to EQMOD, INDI HUB off.

Good place to start is YOUTUBE, plenty of set up vids there. Firstly though is getting your time and location setup right in the KSARS part.

Share this post

Link to post
Share on other sites

Thanks @MarkAR,

I had struggled with this before as there appears to be a directory reset which meant that I had no drop-down for camera/guiders available, even when connecting everything up. Eventually discovered "https://indilib.org/forum/general/4527-kstars-not-finding-indi-folder-in-osx.html" which solved the issue. I'll need to do some more on connecting the Nikon unless anyone wants to share here!

Not tried direct mount/USB as yet due to cloudy nights but will attempt this soon! Hoping my old printer cable is the reason I'd not had success with this thus far...

Regarding alignment of the mount (rather than polar) - I'd half hoped to stop using the controller and use wifi - is this possible (USB direct to mount from macbook, and wifi-dongle to do any alignment/slewing/simple-go-to, independent of kstars)?
I think I'd like to have control of the mount without needing the macbook (phone control via wifi), but also if the macbook is connected that I can move using phone (or controller if this won't work, although I can't see why it wouldn't). How have you yours setup?
I assume that KStars will continue to track position movement of the scope with the mount-on-board encoders?

Can KStars work with the AZEQ6 in altaz mode to slew mount around also?
Thanks in advance!

Share this post

Link to post
Share on other sites

Standard USB cable will connect direct to mount. It might take a while initially to figure out that the Baud rate needs to me 115200. You can always set it manually to 115200 in the INDI Control Panel for the mount.

48 minutes ago, pete_81 said:

How have you yours setup?

Everything connected to a Pegasus Ultimate Power Box V2, the Pegasus then connects to a Raspberry Pi4, the Pi4 connected to Macbook via ethernet cable. This makes it neat and tidy and a lot faster than wifi. 

50 minutes ago, pete_81 said:

I assume that KStars will continue to track position movement of the scope with the mount-on-board encoders?

Yes it has auto guiding.

51 minutes ago, pete_81 said:

Can KStars work with the AZEQ6 in altaz mode to slew mount around also?

I would have thought so but not tried it.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gstallichet
      I just bought a Celestron 8se.  Which planetarium/scope control software do you recommend, Stellarium or Celestron's Starry Nights,  and why?
    • By astrosathya
      Recently I had belt modded my HEQ5-PRO and last night i gave it a full run and i was absolutely stunned to say the least about the guiding results I achieved. I was left wondering if its even too good to be true! 
      Below are Before and After images of guiding.

    • By Marsto
      I am looking for help and advice on my SynScan EQ5 pro problem which i am struggling with. Everything was working fine and as expected. I have never updated the firmware and thought while i had everything connected i would update the Hand Controller and the skywatcher WiFi dongle. 
      Everything updated first time without issue and i was pleased to be up to date. However i loaded SynScan app on the pc which connected fine through the handset and USB/Serial adaptor cable. I clicked on the movement arrows and nothing happened, i then went in to a random 1 star alignment and again no response from the motors. 
      I powered off again and instead of the PC i tried the hand controller, i tried a 1 star alignment and the hand controller was displaying the slewing but again no response from the motors. in panic i then did the same with the WiFi dongle and phone app, same thing the software is showing movement but the scope remains still. 
      Knowing all was well prior to firmware updates i reverted back to the previous firmware version and no difference, i tried it again in Lo mode and still nothing. I then noticed a firmware update for the Motor Control so thought i had nothing to loose i updated the Motor Control firmware and again no sign of life from the Motors. I have swapped the cables around, checked that they are all inserted correctly, the power is from mains not battery and the power source is plugged in to a a Power Filter and Surge protector. 
      I have little experience of circuit board electronics, i was struggling to find similar experiences online other than voltage issues due to batteries which is not the case. I have opened it up and no obvious loose cables of solder loose, but this was straight after the firmware update which seemed to have installed and updated very smoothly no crashes etc. 
      Any help would be really appreciated. 
    • By MattsGazingAgain
      Hello all,
      First post since my initial hello message due to a lot of cloudy nights and a small wait until I could afford my very entry level camera. I would like to apologise straight away for my lack of knowledge and the poor quality of my images. The framing is terrible and they're out of focus, but I'm also completely over the moon with them. I'm very eager for you guys to rip them apart and tell me all the ways I went wrong but I will always love these 4 images as they are the very first successful AP images I've taken
      My equipment is as follows
      skywatcher 150pds on a eq3-2 pro synscan mount
      Polar scope
      Canon 2000d
      Super coma corrector
      I have tuned the motor drives for the mount but haven't stripped down and cleaned and greased the mount itself yet but plan to. Also plan to upgrade to a heq5 Pro asap. I have no guiding other then synscan. Again something else I hope to change as soon as I can but for now its an oppurtunity to learn.
      None of the images are stacked, they're single 30 sec exposures. I very slightly adjusted the raw files by placing a slight s curve on the linear channel but will leave any further processing if I bother until after a good nights sleep. I've included both the before and after image.
      The first image is just of vega, I took it while star aligning. A awful pic for many reasons, especially the flare coming from the star, but my first so will keep it for sentimental reasons. The second I was very happy to catch some light from the ring nebula, and was equally happy to catch the dumbell nebula a little. The fourth is the globular cluster. All really bad framing but was suprised to catch the nebula on just a 30 sec exp with my light pollution. 
      Can't wait for your ideas,suggestions and criticisms. My apologies for a very long post but feel very hyped up even after such awful results.
      Many thanks and clear skies

    • By deflatedfruit
      I'm trying to set up Stellarium with my cameras (Canon EOS 1300D and a Canon EOS 2000D) and my telescope (Celestron NexStar 127SLT). I think I've found the correct values for everything like focal length and sensor size etc... but the FoV in Stellarium it is different to what I actually see. I've attached screenshots of the settings, as well as the predicted image and an image I captured using the EOS 1300D and the Celestron NexStar 127SLT (it's not very good, I know).
      Any help would be much appreciated. (And I apologise if I've posted this in the wrong place - I'm new)

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.