Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

Recommended Posts

Just having a look at ASTAP as a possible alternative to DSS, but unfortunately can't get it to debayer or apply Flats correctly.

To deal with the flat problem, can anyone tell me what the message:

"Warning, could not find a suitable flat for ""! De-classify flat filter or add correct flat."

means?  I've failed to find it in the documentation, and am not really sure what 'De-classify' might refer to in this context.

I am using flats that DSS was quite happy with and it has created a master flat but then steadfastly refuses to apply it.

Share this post


Link to post
Share on other sites

Maybe more fussy than DSS check the fits file against your light frames to see if there's any differences.

Dave

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for that thought, Dave.

Just checked and the flats report their size as 3476 x 5208 while the lights are  5208 x 3476.  Why one has been rotated and not the other seems a bit of a mystery - the master flat created by DSS is correctly oriented (long side 1st) - and while the individual raw files open correctly (landscape fashion) in Windows Photo Viewer, they open portrait style in PhotoPaint.   Auto rotate is switched off in the camera which, if I understand the manual aright, should mean the image is always displayed landscape.  

Not sure what to so about that, but maybe ASTAP is not an option, it is incredibly slow: 20 minutes to convert all the .raw files to .fits and then another 10 or more to stack them.  I'd expect DSS to have done the whole job in less than 5 usually. And then there's its inability to debayer the image...

Share this post


Link to post
Share on other sites
On 28/09/2020 at 18:12, almcl said:

To deal with the flat problem, can anyone tell me what the message:

"Warning, could not find a suitable flat for ""! De-classify flat filter or add correct flat."

means?  I've failed to find it in the documentation, and am not really sure what 'De-classify' might refer to in this context.

I am using flats that DSS was quite happy with and it has created a master flat but then steadfastly refuses to apply it.

Just uncheck the options inside the red marked area as shown in the screenshot.

These options are intended to allow automatic selection of a dark or flat based on light exposure time and/or temperature.  If you have only one (master)dark and master flat  or they don't have the info in the header (DSLR) you don't need this option .

Han

astap_classify.thumb.png.c2f85923a4a7ba803e3426406531f698.png

 

  • Like 1

Share this post


Link to post
Share on other sites

Thank you for responding, Han.

Unfortunately, nothing was checked in the boxes you have indicated, could the Canon camera's random autorotation (see post above yours) of the flats be the cause of the problem?

Share this post


Link to post
Share on other sites

The flat and dark should have the same pixels dimensions as the light. So the same height and width in pixels . This is the only reason why the programt would not accept them. The image dimensions width and height are indicated at each tab after pressing the button analyse.

In some case conversion from RAW to FITS could cause the problem, especially with Libraw which in some cases converts to portrait mode instead of landscape. In tab Stack Method you can select DCRaw or Libraw. DCRaw works the best but doesn´t support the latest formats.

Assuming rotation is the cause you could rotate the images 90 degrees batch wise in the tools menu of the viewer but I have no idea if they should turn clockwise or counter clockwise. If rotation is the problem you probably best start over again with the RAWs and select DCRaw for conversion.

Han

 

Share this post


Link to post
Share on other sites

It turned out that the calibration files were being interpreted as portrait while the the lights were seen as landscape.  I rotated the three masters in AvisFV (which was a lot quicker than rotating 50+ lights)  and they then stacked.

Thanks for the responses.

  • Like 1

Share this post


Link to post
Share on other sites

Unless you knew which way to rotate them you could end up with a dust bunny for example in the wrong place from the flats.

You can turn off autorotate in the canon menus (i can on a 1100d)

Share this post


Link to post
Share on other sites

Fortunately a very prominent dust bunny as well as horrific amp glow showed the rotation required (anti-clockwise).

Autorotation is turned off in the camera, suspicion now falls on APT which has been randomly flipping images for a little while in its on-screen display.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi. Yes APT does flip images.  Disabling image rotation does not fix the issue(maybe different on some models but not on my 550d)
I was on their forum and the thread is here.  https://aptforum.com/phpbb/viewtopic.php?f=5&t=1053 - go to the end to see the last few posts.

They have mostly fixed the issue in version 3.86.7. In order to update your version just google- Astro Photography Tool beta 3.86.7 and install it.

The orientation of the camera was not being properly read off the RAW images but interestingly was OK on JPEGs (the initial workaround was to capture images in RAW+JPEG)

One remaining issue that still hasnt been sorted is when you use Image preview, while live view focusing, to flip the image intentionally -say to frame an image that was previously upside down- then the orientation works well, but then when you click 5x or 10x zoom, that orientation is not applied to the liveview zoomed image.
But that's a special case perhaps not come across often.

Edited by johneta
  • Like 1

Share this post


Link to post
Share on other sites

I just noted the ASTAP convertor option Libraw ignores the rotation for .ORF files. Default it is set at Dcraw. You can  the setting "Raw conversion" to Libraw in ASTAP, tab Stack method. It is bottom left of this tab.

  • Like 1

Share this post


Link to post
Share on other sites

Rotation of RAW files is also prevented for DCRAW  by adding -t 0 in the DCRAW command-line. ASTAP version 0.9.427

Han

 

Share this post


Link to post
Share on other sites

Thank you for both of those, Han.  I'll have another look.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.