Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

stargazine_ep28_banner.thumb.jpg.b94278254f44dd38f3f7ee896fe45525.jpg

Max Todas

NEED HELP! Can't identify my telescope brand

Recommended Posts

I have a telescope that I received from a teacher. I know it's a celestron but I can't find any info on the model/type, and I can't find the name of the telescope anywhere on it. Can you tell me what type of it and if I need the electrical parts to make if work?
Here's a link to a photo of it. 

 

https://photos.app.goo.gl/ZtBm1pe1fTszG9FQ8

 

I don't have a manual for it as I don't know the model so I can't figure out how and what I need to fix it, or make it work(if it's missing a specific piece or something) I need to know what model it is so I can find the pieces for it and learn what it needs to work. 

IMG_20200724_131543.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Synq
      Hi I am fairly new with telescopes and I noticed my telescope needed collimation. I preview the collimation at the beginning (tell me please if its alright) however after I finished the secondary mirror kept tilting and not staying in place as seen in the video. This is a Heritage 130P telescope. Please help.
      VID_20201123_161617.mp4
    • By STOCKPORTRICO
      Hi everyone, I am almost new to Astronomy - I currently have a Powerseeker set up but my mate has given me a konus digimax 90 he has lost the tripod can anyone advise me of a replacement tripod - I have a Go-To altaz mount  I dont have a compatable Tripod I just want a cheap one. any links or any advice to get a tripod would be amazing - thanks in advance (im in the uk)
      Rick 
    • By NightSky_Wanderer
      Hi,
      I am hoping someone here may be able to offer some help or advice. I have submitted a support ticket with Celestron but I am still waiting for a reply and would really like to get this working ready for the next clear sky!
      I recently brought a starsense but have not been able to use it because it comes up with the following errors,
      Err: Model Num
      The telescope model could not be read and initialization cannot proceed.
      Critical error!
      File: ..\source\mo
      Line: 1468
      An unexpected error occurred that may cause the HC to not opperate normally.
      When updating the controller and camera it finishes succesfully but when I check for new updates it proceeds to install the same one again and again.
      I can still control the mount and I think the camera tried to do an alignment in my room.
      I have a Celestron Nexstar 6SE.
      Thanks
      Adz
    • By Witcherking10
      Hello all,
      I always been fascinated by astronomy and finally purchased a celestron nexstar 8se. Setup went smoothly but I'm a little stuck on the lens. I attached the star diagonal to the telescope and focused in on an object. I was able to see a part of the leaf on the plant in my house and I attached a picture of that. Moving the telescope left and right allowed me to see other things. I then took out the 25mm lens and can see through that when not attached to the telescope. I can see my sandals and feet through the lens and attached a picture of that. I then inserted the 25mm lens into the star diagonal and that's where all hope gets lost. I see white (assuming that's my wall) and yes the cover on the telescope is also off. No matter where I move the telescope. All I see is white. I tried last night in clear skies and pointed towards some clear stars using the skyportal app to align but I didnt see anything except pitch black through the lens. I also played with the focus but nothing. Am I doing something wrong, I would think the 25mm wouldnt be so zoomed in that I cant see anything? Thanks for any help you can provide me. Looking forward to exploring!!




    • By Astrofriend
      I continue my reports from observatories I have visited. This one is very special for me, I did my education in astrophysics at this place in the 1990s. My girlfriend and I took the car this weekend and visited Saltsjöbaden for a walk, only 30 km from where we live. We ended the walk up at the Stockholm's Observatory.
      Some photos from this beautiful place:
      http://www.astrofriend.eu/astronomy/observatory-sites/saltsjobaden-observatory/01-stockholms-observatory.html
      One of the observatories at this photos is the astrograph which I already earlier had written about.
      http://www.astrofriend.eu/astronomy/observatory-sites/saltsjobaden-astrograph/saltsjobaden-astrograph.html
      Lars
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.