Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

Recommended Posts

Posted (edited)

Okay, looks like I have to admit defeat regarding connection with ethernet cable direct.

I've tried this and similar

https://medium.com/@tzhenghao/how-to-ssh-into-your-raspberry-pi-with-a-mac-and-ethernet-cable-636a197d055

Problem is Thunderbolt Bridge won't work, LAN 10/100/1000 shows a connection but there doesn't seem to be any traffic, lastly the nmap command this guy uses isn't recognised by Mac Terminal.

Is it possible to connect through an old router ? i.e Pi to router to Mac. Just straight Lan connection not over internet.

Other than that it all seems to work over wi-fi. Trouble is when I get in position in the garden I'll probably have signal difficulties and the Devolo devices I have are not reliable. Hence the need for cable connection.

Edited by MarkAR

Share this post


Link to post
Share on other sites
14 hours ago, TerryMcK said:

PHD2 works ok but calibrates after every slew or meridian flip. I don't believe that is an EKOS issue it's just the way that PHD2 works on Linux. You learn to live with the extra 3 minutes or so it adds to an imaging session.

That's not correct, there is a setting but it's not where you would expect it to be! :)

If you go to the guide tab in Ekos and select options, turn off "Reset Guide Calibration after each mount slew" that shout preserve your calibration 👍

image.png.e476b56a9641d7c08aca734598c6392b.png

Share this post


Link to post
Share on other sites
34 minutes ago, MarkAR said:

Okay, looks like I have to admit defeat regarding connection with ethernet cable direct.

I've tried this and similar

https://medium.com/@tzhenghao/how-to-ssh-into-your-raspberry-pi-with-a-mac-and-ethernet-cable-636a197d055

Problem is Thunderbolt Bridge won't work, LAN 10/100/1000 shows a connection but there doesn't seem to be any traffic, lastly the nmap command this guy uses isn't recognised by Mac Terminal.

Is it possible to connect through an old router ? i.e Pi to router to Mac. Just straight Lan connection not over internet.

Other than that it all seems to work over wi-fi. Trouble is when I get in position in the garden I'll probably have signal difficulties and the Devolo devices I have are not reliable. Hence the need for cable connection.

Mark - my recommendation would be to bring the scope indoors, connect the Pi up to your router by ethernet (you dont need the mount etc attached but make sure your camera you will plate solve and scope settings (FL etc) is  configured correctly. 

Start EKOS (could be in simulator mode) and go to the alignment tab, select options and EKOS will recommend which index files you need based on your scope and camera settings. (hover over the little shield symbols shown in the following pic) 

 

image.thumb.png.5c207f64da3d07e00c859151ab80f84a.png

 

Download those files and you should then be almost there to being able to plate solve offline - set the "Solver:" settings to offline and astro.net. Make sure you had your scope and CCD settings set correctly!

After this, you should be able to mostly use the PI without an internet connection, just power up, connect to it's hotspot and run VNC to then remote on to control it.

You can configure the PI to wireless connect to your home network and give that a higher priority than the hotspot so it will try to connect to the home network initially then fall back to hotspot but that might cause problems if you have patchy wifi. I personally run a ethernet cable out to mine as I store my images over the network rather than grabbing them off the PI later. (get there through right click on the network in the task bar, select edit connections)

image.png.f9de44433a05487ca2139abb7b4927ae.png

image.png.30b6f342de4a618131cf14ff14c94750.png

Share this post


Link to post
Share on other sites
6 hours ago, MarkAR said:

Okay, looks like I have to admit defeat regarding connection with ethernet cable direct.

I've tried this and similar

https://medium.com/@tzhenghao/how-to-ssh-into-your-raspberry-pi-with-a-mac-and-ethernet-cable-636a197d055

Problem is Thunderbolt Bridge won't work, LAN 10/100/1000 shows a connection but there doesn't seem to be any traffic, lastly the nmap command this guy uses isn't recognised by Mac Terminal.

Is it possible to connect through an old router ? i.e Pi to router to Mac. Just straight Lan connection not over internet.

Other than that it all seems to work over wi-fi. Trouble is when I get in position in the garden I'll probably have signal difficulties and the Devolo devices I have are not reliable. Hence the need for cable connection.

I'm not a mac guy but I do know a thing or two about networking. 

How have you set up the IP addressing on both the mac and the pi? 

 

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, jiberjaber said:

That's not correct, there is a setting but it's not where you would expect it to be! :)

If you go to the guide tab in Ekos and select options, turn off "Reset Guide Calibration after each mount slew" that shout preserve your calibration 👍

image.png.e476b56a9641d7c08aca734598c6392b.png

I think I tried that but will give it another go. 

  • Like 1

Share this post


Link to post
Share on other sites

If you’re using DHCP then, depending on the router, you can go in and tell it to assign the same IP address each time. This is better than setting a fixed IP address on the device as it prevents potential conflicts between DHCP assigned addresses by the router and manually set ones per device. 
 

Also you could try running as ‘local’ instead of ‘remote’. Works fine for me each and every time. I just use Chrome as my browser, go to http://astroberry.local and I’m in. Works fine via WiFi or Ethernet. 

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, MarkAR said:

 

Problem is Thunderbolt Bridge won't work, LAN 10/100/1000 shows a connection but there doesn't seem to be any traffic, lastly the nmap command this guy uses isn't recognised by Mac Terminal.

Is it possible to connect through an old router ? i.e Pi to router to Mac. Just straight Lan connection not over internet.

Other than that it all seems to work over wi-fi. Trouble is when I get in position in the garden I'll probably have signal difficulties and the Devolo devices I have are not reliable. Hence the need for cable connection.

Hi Mark

if you have an old router then yes that should work, just plug the Pi and Mac into it and the router should assign them an IP each and they'd be able to chat. The problem with back to back connection is you do need to set an IP at each end, manually or neither will be able to use that link, but both ends will report link-up physically since the signal cables are in place. You may need a crossover cable or may not depending on the LAN interfaces, experimentation would be the only way to know if setting the IP's doesn't work then that'd be the next thing to try.

If you are running cabled-direct then you have to set an IP manually with each end in the same IP range as the other and each on a unique address. It needs to be a different range than your main home network is using else the computer won't be able to route properly. Doesn't much matter what IP range you use being it is a private connection, but avoid using a known public one else your computer won't be able to reach it later. Should you have a spare router (not a switch tho) then the router would take care of address assignment so long as both Pi and Mac are still set to DHCP and you should be fine with a regular cable. Worth checking tho that the router is operating in a different IP range than your main home network else confusion will follow for the Pi, Mac and yourself 🙂 

edit:

Looking at the first steps in that linked article I do have to wonder if he's any idea about networking or just got lucky. Cable between 2 computers and leave network to DHCP... hmmm where's the DHCP server? It's on another physical LAN so it's not going to assign an address for a MAC address/LAN connection it cannot see. So it ends up with an APIPA address (169...) which is no use to anyone. Looks to me like in his case both are connected to a network with 192 addresses and the messing about with a direct cable and Bridge100 etc appears to work because of that and not the "knowledge" he's trying to impart and failing to.

 

Edited by DaveL59
  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Wyvernp said:

How have you set up the IP addressing on both the mac and the pi? 

 

1 hour ago, DaveL59 said:

If you are running cabled-direct then you have to set an IP manually with each end in the same IP range as the other and each on a unique address.

This could be the key, I didn't put in a IP address on the Pi wired connection.

Just looked at my two laptops wifi settings, IPv4 is 192.168.1.xxx (last is different on both) Router is 192.168.1.254

What should I set the LAN wired connection IP's to ? 192.168.2.XX same on the Mac and Pi or 192.168.2.YY on the Pi ? 

Share this post


Link to post
Share on other sites
6 minutes ago, MarkAR said:

 

This could be the key, I didn't put in a IP address on the Pi wired connection.

Just looked at my two laptops wifi settings, IPv4 is 192.168.1.xxx (last is different on both) Router is 192.168.1.254

What should I set the LAN wired connection IP's to ? 192.168.2.XX same on the Mac and Pi or 192.168.2.YY on the Pi ? 

That's exactly it, just make sure the subnet mask is the same, default is 255.255.255.0

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
8 minutes ago, MarkAR said:

 

This could be the key, I didn't put in a IP address on the Pi wired connection.

Just looked at my two laptops wifi settings, IPv4 is 192.168.1.xxx (last is different on both) Router is 192.168.1.254

What should I set the LAN wired connection IP's to ? 192.168.2.XX same on the Mac and Pi or 192.168.2.YY on the Pi ? 

yep that'd work Mark so long as you set the mask to be 255.255.255.0 on that interface

edit - gotta love dual posts saying the same thing. great minds and all that 😉 

Edited by DaveL59
  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
Posted (edited)

The Astroberry has a DHCP server running on it (it's how you can connect to it as a local hot spot). However I can't recall if it is just set up so it serves the wireless interface or not! If you can connect to the hotspot and get a DHCP address but when you connect wired you do not get an IP then (assuming the mac is new enough to not need a crossover cable for direct connection) it would suggest the PI isn't serving DHCP (or running the DHCP) on the wired interface. That would make sense as it can cause problems with existing DHCP servers if not configured correctly :)

My scope and PI are in the house at the moment so I might wire and power it up to check :)

You can set up the equivalent of a wifi hotspot but using wired connection - I've just tested this and it works. If you ensure the priority is lower than the main wired connection in the General Tab (it should be by default as the wired priority is set to 999!) then the wired 'hotspot' will only work if there is no DHCP server on the network.

Once you've set that up, you should be able to VNC into astroberry.local from a directly wired laptop.

The only issue is if your OS tries to workout if the ethernet connection actually has an internet connection and if not tries to do something else, my Win10 laptop does this which results in the connection dropping and coming back up as it tries again for internet. This is the laptop not the PI causing the problem and I am sure there will be a setting somewhere to stop it :)

 

image.png.7f74c0296f3259f81149f5104d56aff8.png

 

Priority setting: 

image.png.3b7dc5359d660ba6f8869f3fb23a2b34.png

Edited by jiberjaber
Added words to picture :)
  • Like 1

Share this post


Link to post
Share on other sites

Cheers Jason, will try it out.

I did actually manage to get a connection wired with wifi on my Mac turned off. Everything connected and running via the Lan. Then I thought best to shutdown and see if it all connects again, Mac to Pi was working but I could not for the life of me figure out why Ekos now wouldn't connect.

Here a few shots of my settings that worked. Mac Lan set up.

2122221456_Screenshot2020-08-21at12_01_24.png.8791563e628d2f73acfcc2361834e742.png

 

Pi wired set up.

1152129583_Screenshot2020-08-21at12_02_04.png.dc358125216f79bde80c061d4af377b1.png

 

Terminal with IP highlighted that I used in Ekos to connect.

1163002632_Screenshot2020-08-21at12_01_04.png.b9b31cf1fc6022062ab7ce9135876843.png

 

 

With all the same settings now I can't connect Ekos !

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

hi Mark

you really need the mask set to 255.255.255.0 as the 4x255 setting you have on the Mac there would limit to a single address and could prevent things communicating. The Pi at least has decided on /24 which equates to 255.255.255.0 so it would be able to see the Mac just fine. You at least seem to have it working tho which is good.

Edited by DaveL59

Share this post


Link to post
Share on other sites

Cheers Jason, will change it and try again with the other settings as above.

Share this post


Link to post
Share on other sites

It's alive, the beast is awake.

Huge thanks everyone it looks like I've got a working set up.

Changed the last 255 to 0 in both Mac and Pi, opened a screen in Safari went to astroberry.local and started drivers (set to start and connect at launch), then in Ekos Profile changed to Astroberry.local

Everything worked with no wifi connection that I could see, switched everything off then restarted again and it connected straight away.

Looking at the fits file download speed it was something like 8 to 10 seconds over wifi but under 0.2 seconds  with Lan connection. 😋

  • Like 6

Share this post


Link to post
Share on other sites

Rabbit Hole excavated ready to dive down then Mark 😋

Enjoy it

  • Like 1

Share this post


Link to post
Share on other sites

Cheers Terry, Jason, Dave and everyone else that has chipped in.

This set up is ideal for fast connection and especially good if wifi is an issue.

Really strange that I couldn't find an online tutorial to do it my way, or at least one that works. I'll write it up whilst still fresh tonight.

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)
2 minutes ago, MarkAR said:

Cheers Terry, Jason, Dave and everyone else that has chipped in.

This set up is ideal for fast connection and especially good if wifi is an issue.

Really strange that I couldn't find an online tutorial to do it my way, or at least one that works. I'll write it up whilst still fresh tonight.

There is some simple code that you input at the terminal that sorts out static ip addresses, it’s very simple on SM there is an actual tool for it that takes a few seconds to sort, I thought AB had the same feature....👍😀

Edited by Stuart1971
  • Like 1

Share this post


Link to post
Share on other sites

It might have but now my understanding of IP addresses has been raised by 1% to 2%, I managed to get it sorted.

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)
On 20/08/2020 at 12:21, TerryMcK said:

PHD2 works ok but calibrates after every slew or meridian flip. I don't believe that is an EKOS issue it's just the way that PHD2 works on Linux

Hi

As @jiberjaber's recommendation regarding resetting the calibration (it's your choice) but remember that you must also connect to PHD2 with an indi (os ascom) mount which supplies ra and dec positions.  It reuses the calibration. Irrespective of operating system. Get a good calibration once and forget.

However I agree with @MarkAR With EKOS' new multistar guiding, GPG PPEC for RA and reusable calibration, we're at the stage where PHD2 is -and I never thought i'd come to say this-  perhaps second best.

Cheers

Edited by alacant
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

I might try the inbuilt guider in that case. I have never even considered using it as I have used PHD2 since Windoze days.

I use EQMOD and had unchecked the reset calibration setting but it definitely still recalibrates after every slew. I’m now wondering if EQMOD supplies RA and DEC as you say. When I set PHD2 to use on camera/ST4 it only calibrates once. 
 

Thanks for all the responses and I don’t want to hijack Marks thread ;)

  • Like 2

Share this post


Link to post
Share on other sites

Glad you got it working. Should be pretty stable now you’ve got to this point. I certainly won’t be going back to a laptop based solution. 
 

My next step is to try it via its own internal WiFi hotspot as I want to go portable so we’ll have to see how well that works. Want to make sure everything does what it should before venturing out. 

  • Like 1

Share this post


Link to post
Share on other sites

As for hijacking this thread it's not a problem with me as it's all relevant (so far).

The multistage alignment works well, I suppose it'll help if there's some thin patchy haze around so you won't lose all the targeted stars. 

If you're using Ekos on the Pi then you'd have to update it on the pi to the latest version, I think that'll be a "sudo update/get and upgrade" the specific file in terminal.

1 hour ago, dannybgoode said:

My next step is to try it via its own internal WiFi hotspot as I want to go portable so we’ll have to see how well that works. Want to make sure everything does what it should before venturing out.

Don't know what the range is but it might not be that large, just thinking that you can still be pretty portable with a direct cable. You can sit in your car up to 100m away and have a really good connection.

Share this post


Link to post
Share on other sites
5 minutes ago, MarkAR said:

Don't know what the range is but it might not be that large, just thinking that you can still be pretty portable with a direct cable. You can sit in your car up to 100m away and have a really good connection.

I am hoping not to have to take a laptop with me and control it from my iPad Mini. Plus the site I have in mind is quite a lot more than 100m from where I can park. And of course I’d have to fiddle around with settings I’d rather leave alone as I run it all as local and I might break something!

Don’t forget I only need to get the sequence started and then I can disconnect and get back into the warmth of my car.  The other option is to set the sequence up at home and then just schedule it. Go to site and set up and leave it to run at the given time. This of course means having absolute faith in it all working.

I also have the 7” RPi display. This and a keyboard would be enough to get things running as well.

Will have to have a play though at home. I ain’t risking venturing out until I know it all works one way or the other. 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.