Jump to content

sgl_imaging_challenge_2021_annual.thumb.jpg.3fc34f695a81b16210333189a3162ac7.jpg

Recommended Posts

Hi all, I've managed to get my Pi4 started with astroberry and linked to my Mac via direct ethernet cable. Not tested yet with mount connections.

One thing was that the INDIserver panel didn't show up so couldn't select drivers. Does KStars/Ekos on the Pi now control that?

Also, with Ekos do you set it on the Pi as Local or Remote or on my Mac as Local or Remote?

Edited by MarkAR
Link to post
Share on other sites
  • Replies 52
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

It's alive, the beast is awake. Huge thanks everyone it looks like I've got a working set up. Changed the last 255 to 0 in both Mac and Pi, opened a screen in Safari went to astroberry.local

Yes you do set it as remote Mark. I've found it's best to use the simulators profile on the Pi to experiment so you don't need to connect the Pi physically in the initial stages. Connect wit

Couple more hours work then I'll hopefully set it all up for a trial.

Posted Images

1 minute ago, MarkAR said:

Hi all, I've managed to get my Pi4 started with astroberry and linked to my Mac via direct ethernet cable. Not tested yet with mount connections.

One thing was that the INDIserver panel didn't show up so couldn't select drivers. Does KStars/Ekos on the Pi now control that?

When you go in to EKOS to set up a profile you just pick your kit from a dropdown list and it feeds all that into INDI.  When you hit 'Start' on the profile and your kit connects it does fire up the INDI control panel so you can tweak in there if needed..  Dead easy - any questions let me know as I've just set mine up so much of it is pretty fresh in my mind.

2020-08-10 (5).png

Link to post
Share on other sites

This is as per controlled from my PC.  I am not 100% sure what the remote option does but when I tried it I couldn't get it to work so I leave it set as local and it still controls just fine from my browsers.  The Stellermate vids are pretty good and explain this somewhat - ignore the fact it's Stellarmate as 99% of the stuff is to do with KStars/EKOS so works identically under Astroberry.  The one thing you do need to change is if you use PHD2 for guiding then you need to change the Host from 'localhost' to astroberry.local.  In PHD2 you pick the INDI camera and INDI mount.  For reasons underknown you also need to select an Aux mount which is INDI again for it to all register properly but then you just ignore the Aux mount going forward.  If you do choose PHD2 for guiding also you need to manually open it as well as EKOS does not trigger it.  I have not tried the internal guider but apparently it's very good.

When you get to it I use the ASTAP plate solver as it's near instant and I can't get Astrometry.net to work properly.

Link to post
Share on other sites

Thanks for the heads up on PHD2, I'm sticking with the internal guider as I really like the multi-star guiding. Ekos has been running pretty well on my Mac so far and ASTAP is brilliantly fast.

Will look up the Stellarmate options to see if there's anything relevant for setting up.

Link to post
Share on other sites

Yes you do set it as remote Mark.

I've found it's best to use the simulators profile on the Pi to experiment so you don't need to connect the Pi physically in the initial stages.

Connect with the triangular start button. All the devices will be automatically connected and the INDI control panel will be highlighted. Go to each tab in turn and select each Options tab and click Save under configuration

image.png.6ad8701eca4e3d04df160080b5612938.png

Then you can leave the PI running

Go to your Mac into Kstars and create a profile with similar devices. This time however select remote and then click Scan

image.png.32b9223561ff8d596b41ab898a2e7e51.png

The PI's web manager address will show up. Save the profile and connect. You can then control the PI from the Mac. (Windows Kstars shown above but the Mac one is very similar)

When you want to use the PI in anger setup a profile for your physicals on both the Pi and the Mac and you are away.

PHD2 works ok but calibrates after every slew or meridian flip. I don't believe that is an EKOS issue it's just the way that PHD2 works on Linux. You learn to live with the extra 3 minutes or so it adds to an imaging session.

Edited by TerryMcK
  • Like 2
Link to post
Share on other sites

Mark - you can access the Indi panel from the astroberry.local webpage, there's a bunch of icons on the left but I can't recall which one is the indipanel as I seldom (never) use it... I use the PI to do it all and just VNC in to it to check progress / setup stuff

Link to post
Share on other sites
17 minutes ago, TerryMcK said:

Yes you do set it as remote Mark.

I've found it's best to use the simulators profile on the Pi to experiment so you don't need to connect the Pi physically in the initial stages.

Connect with the triangular start button. All the devices will be automatically connected and the INDI control panel will be highlighted. Go to each tab in turn and select each Options tab and click Save under configuration

image.png.6ad8701eca4e3d04df160080b5612938.png

Then you can leave the PI running

Go to your Mac into Kstars and create a profile with similar devices. This time however select remote and then click Scan

image.png.32b9223561ff8d596b41ab898a2e7e51.png

The PI's web manager address will show up. Save the profile and connect. You can then control the PI from the Mac. (Windows Kstars shown above but the Mac one is very similar)

When you want to use the PI in anger setup a profile for your physicals on both the Pi and the Mac (Mac being remote of course) and you are away.

PHD2 works ok but calibrates after every slew or meridian flip. I don't believe that is an EKOS issue it's just the way that PHD2 works on Linux. You learn to live with the extra 3 minutes or so it adds to an imaging session.

If you are using in remote mode, that means that the pi is on the mount and you are connecting to that from your Mac, so the pi is the remote device, not the Mac, if you are running all the Kstars software on the rpi and just connecting to it with VNC from your Mac, that is local 

I think you got it the wrong way round....

Also you dont need a profile at all on the pi if you are running ekos from your Mac PC, as Kstars is not used on the pi and only on your Mac, in this setup the pi is just an Indi server and will start automatically when you start from ekos...

Link to post
Share on other sites
4 minutes ago, Stuart1971 said:

Also you dont need a profile at all on the pi if you are running ekos from your Mac PC, as Kstars is not used on the pi and only on your Mac, in this setup the pi is just an Indi server and will start automatically when you start from ekos...

Wow, that makes it easy.

Link to post
Share on other sites
1 hour ago, MarkAR said:

Wow, that makes it easy.

Yes, this is the way I run it, I have the PC Kstars version on my PC indoors, and the pi is on my mount with Stellarmate or Astroberry installed, and I select remote in ekos profile on the PC, and put the pi address in the box, stellarmate.local or Astroberry.local and then make sure the pi and your PC are on the same network or connect to the pi hotspot, and all done,...

The other option is to run ekos from on the pi, then you would need to connect to the pi via VNC or teamviewer, which are both installed on Stellarmate, not sure about Astroberry, and control all from there....the PC then is just a viewer for the pi as all done on that...

So the first option is the “remote” option, and the second is running it in “local” mode.... 👍😀

  • Like 1
Link to post
Share on other sites
2 hours ago, Stuart1971 said:

If you are using in remote mode, that means that the pi is on the mount and you are connecting to that from your Mac, so the pi is the remote device, not the Mac, if you are running all the Kstars software on the rpi and just connecting to it with VNC from your Mac, that is local 

I think you got it the wrong way round....

Also you dont need a profile at all on the pi if you are running ekos from your Mac PC, as Kstars is not used on the pi and only on your Mac, in this setup the pi is just an Indi server and will start automatically when you start from ekos...

I like to keep my setup simple and when not using the MAC/PC then Kstars/EKOS on the PI itself is identical if controlling it by iPad via VNC in the field for instance sans external control. :)

I think you will find that I actually stated the PI is a remote device (in my case on the ipaddress shown in the screen shot) when configuring the MAC client selecting Mode: Remote - the screenshot is from my PC Kstars.

Go to your Mac into Kstars and create a profile with similar devices. This time however select remote and then click Scan

image.png.32b9223561ff8d596b41ab898a2e7e51.png

 

 

Edited by TerryMcK
Link to post
Share on other sites
2 minutes ago, TerryMcK said:

I like to keep my setup simple and when not using the MAC/PC then Kstars/EKOS on the PI itself is identical if controlling it by iPad via VNC in the field for instance sans external control. :)

I think you will find that I actually stated the PI is a remote device (in my case on the ipaddress shown in the screen shot) when configuring the MAC client selecting Mode: Remote - the screenshot is from my PC Kstars.

Go to your Mac into Kstars and create a profile with similar devices. This time however select remote and then click Scan

image.png.32b9223561ff8d596b41ab898a2e7e51.png

 

 

 It was this comment was referring to...

“When you want to use the PI in anger setup a profile for your physicals on both the Pi and the Mac (Mac being remote of course)“

The MAC would never be the remote device, unless you leave that out on the mount and control from another PC.... 👍😉

  • Thanks 1
Link to post
Share on other sites

I'll be honest - I don't fully understand the remote/local aspect.  I just have all the software running on the Pi, the option set to 'local' and control the Pi via a web browser or iPad and it works.  So with this being the case I just leave it alone :D .

  • Like 2
Link to post
Share on other sites

Well I've sort of got it running but I can't connect to the mount. Indi Web Manager says EQMODMount is there and running. Cant alter any of the settings to scan for ports or change the Baud Rate !

 

Screenshot 2020-08-20 at 17.59.59.png

Link to post
Share on other sites

Set up a fresh profile and I can now change settings on the mount INDI control.

Set Baud to 115200 which worked before, scanned ports and /dev/ttyUSB1 and USB0 show up.

USB0 is in use , USB1 fails.

Trying other Baud rates.

12 minutes ago, Stuart1971 said:

Run the serial port mapper and set the serial ports

Not sure what you mean, if it's the Scan Ports in Ekos then I'm still getting the same results.

Link to post
Share on other sites
14 minutes ago, MarkAR said:

Set up a fresh profile and I can now change settings on the mount INDI control.

Set Baud to 115200 which worked before, scanned ports and /dev/ttyUSB1 and USB0 show up.

USB0 is in use , USB1 fails.

Trying other Baud rates.

Not sure what you mean, if it's the Scan Ports in Ekos then I'm still getting the same results.

You need 9600 baude rate...?

see here..

https://stellarmate.com/support.html?view=kb&kbartid=2

Edited by Stuart1971
Link to post
Share on other sites

Serial Port Assistant ensures that your serial device designations are saved permenantly. When you plug your mount, it is assigned a random port (e.g. COM2 or /dev/ttyUSB1). This port is required in order for INDI to communicate with your mount. Using the assistant, you can assign a permenant ID to your device (e.g. /dev/mount). Therefore, everytime you plug in your device, it is always assigned a designated port that INDI uses to communicate with the device.

To use the Serial Port Assistant, go to StellarMate Web Manager either from StellarMate App or from any browser and click on the Serial Port Assistant Icon at the bottom right. Simply follow the instructions in the Step-By-Step guided wizard to assign permenant designations to your Serial-To-USB devices.

Same for Astroberry too... 👍😀

 

Edited by Stuart1971
Link to post
Share on other sites

What mount are you using and how are you connecting to the mount?  Here are my settings for my SW AZ EQ6GT.  I have not had any issues swapping ports at random even mid-session, it has always picked the mount back up.  If you look at the bottom where the system ports are mine show ACM0 and for reasons I cannot quite remember this is important.

To get mine working I literally just when into EKOS on a fresh install, picked my kit from the dropdowns and hit connect and it just worked.  Have you changed the defaults to show like they do on your Mac perhaps?

2020-08-20.png

Link to post
Share on other sites

Trying again, stupid error earlier, mount wasn't turned on.

Trouble is it still won't connect, same errors as before.

AZ EQ6, SXCCD, SCWheel,  Altair GPCam3 all plugged in to Pegasus UPBV2 as they were before. Now instead of plugging in directly to my MacBook the Pegasus is plugged into the RPi4 then to laptop via Lan 10/100/1000 connection.

Changed the Baud to 115200 and it's connected, just running through everything to make sure it works.

Link to post
Share on other sites

I think it all works now. 

Only thing is making sure I get the remote connection right, IP seems to change.

Will drag out my rig next chance I get and give it more of a shakedown and confirm my start up method.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.