Jump to content


Meade ETX90 PE alignment help

Recommended Posts

I have just purchased the above telescope which is the premier edition (Blue Tube) model. It is the first telescope I have ever used and do not know how to set up the red dot alignment for the smart finder. The instructions tell me to hold down the MODE button for 2 seconds which should then display RA and dec. coordinates. This does not happen and the control simply asks the date, time and whether I wish it to align

Can someone please help and tell me how to get the Red dot on the smart finder so that I can initially align the scope.

Any help is appreciated.

Link to comment
Share on other sites

Not sure why it is not going into the Finder Menu. Have you pushed the mode button as soon as you have turned on the Autostar.

A couple of notes.

I have seen the finder on this scope it is very different from a standard RDF. On the same side as the plastic lens is mounted back along the angled part of the plastic mount there is a small bit of fibre optic sticking out - this provides the red dot.

When I was setting up one of these scopes for someone I noticed that the factory setting of the red dot brightness was set very dim, you need to increase it to maximum to be able to see it in daylight - have it set on continuous to do the initial alignment with a ground object.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.