Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

Recommended Posts

Morning! I've just taken delivery of a Sky-Watcher StarQuest 102 MC. It's all set up BUT apparently I need to polar align it to be able to see anything? Please don't eye-roll me but I'm a total beginner and my usual go-to for instructions is videos but there don't seem to be many on the StarQuest series. Do I have this right; the tripod needs to point north. Then put my latitude adjustment knob to my own latitude which is 51.

Should that be all I need to do?

Thank you so much in advance for any help or tips!

Share this post


Link to post
Share on other sites

Hi, I'm new to this also. I recently got the Starquest 130p. Great scope also and I think the same eq2 mount. I found this article really helpful to get started.

https://www.skyatnightmagazine.com/advice/equatorial-mounts-an-astronomers-guide/

 

And this video

Once I read this and watched that,  the supplied user guide made a lot more sense.

Good luck!

 

 

Share this post


Link to post
Share on other sites

Thank you so much - I'll give it a watch and a read and fingers crossed!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Leewfc
      Hi I'm hoping someone owns a scientific explorer 127 ED triplet scope. I purchased one over the summer to start astrophotography. I'm struggling to view anything with the scope. I've struggled to get anything in live view on my camera. And I'm also not getting anything through eyepieces when using them. I've tried using the 2 extension tube pieces but still no luck. I'm not sure if its something I'm doing or faulty scope. Any help much appreciated TiA
    • By BillKinn
      Hello everyone, I'm wondering if I could get some help, sort of ripping my hair out a little.
      I have the EXOS2 PMC-8 and last night I used Sharpcap to Polar align, I set the mount up as usual and adjusted until Sharpcap said excellent Polar alignment.
      So my next step was to do a 3 star alignment  I was using a program called Explorer Stars to achieve this, so when I asked the mount to slew to the first star it was way off even in the finder scope, is that normal? So I used the controls to get the star in my FOV and centred it, it was the same for the next two stars way off. so I did the same.
      I finished the 3 star alignment and when I asked the mount to find an object the object was not centred it was bottom right of the quick photo I took.
      I've made sure all the information is correct by setting my Longitude and Latitude and also made sure my time is correct, the mount is balanced and level and pointing North. I think I'm doing something wrong somewhere.
      Also may I ask should my counterweight bar be parallel with the mounts front leg? I have two little arrows on the mount that should be pointing at each other when in the home position but when they are the counterweight bar is pointing to the right quite a fair bit.
      I'm new to all this only been doing it for a few months so a lot of things are quite confusing.     
      Thanks in advance Bill. 
       
       
       
       
    • By isabe
      Hi,
      I’m looking for a polar scope for my skywatcher eq3-2 mount ASAP, please let me know.
    • By PlanetGazer
      Long storey short :
      the OTA slips dramtecly when vewing an object to 0 altitude.
      Details:
      So I bought the Skywatcher GoTo flextube 10 inch a year ago. It was nothing but great, until yesterday when I was just starting the session to level up the scope on the mount for alignment. I Went to get some equipment and when back noticed the scope has declined to a minus reading on the altitude! With no attachments on the OTA. 
      I re-leveled it to the horizon and it held itself, put on the nothing but stock attachments as usual. Switched on the GoTo and started aligning, when alignment is successful, I chose an object and notice the object is far off.  I check the battery voltage and it's 12.5 volts, which indicates it's not a battery issue.
      I turn it off to re-align again, this time when I press the up arrow to align to an object I notice the GoTo gears struggle to move the OTA upwards, but eventually the speed increase to normal and manage to points upwards to the object. I pick a second object which happens to be near the zenith and the GoTo goes out of control straight to zenith and carrying on above 90+ degrees on the altitude bearing. I try to stop the scope with the handset before the base of telescope hits the wood in the base, only to notice the handset is not showing light or responding. I turn the GoTo off.
      Start to align for the third time, this time aligns but still off target. I ignore and start viewing Jupiter which happens to be 40+ in altitude , after few minutes of viewing, the scope drops slowly to zero altitude with no hand or handset movement! Handset is still showing that the viewed object is still Jupiter!
      Note: I did notice weird sounds of the gears when trying to increase altitude. Not the common sound.
      Has anyone faced this issue and fixed it, should I return under guarantee? Is this a gear slippage? Or clutches not engaged? Your help will be much appreciated!
       
    • By Dimitry
      Hi all, 
      As I'm selecting a new scope with a great help and advice from this community!
      As the optical system is getting clearer, I'm now checking the model. And really puzzled with the new SkyWatcher line: StarQuest. It looks on the paper as exactly the same as the telescopes from the other lines, but costs less.
       
      Example:
      1. https://www.firstlightoptics.com/sky-watcher-az-eq-avant/sky-watcher-skymax-102-az-eq-avant.htm
      2. https://www.firstlightoptics.com/sky-watcher-starquest/sky-watcher-starquest-102mc-f127-maksutov-cassegrain-telescope.html
      Optical specs look identical, mounts are like twins, yet StarQuest is 20% cheaper.
      Have you had any experiences with these telescopes, are there any hidden tricks what aren't visible on the paper specs?
      Does it makes sense to pay extra for a SkyMax on Avant?
       
      And a similar question on a StarQuest refractor https://www.firstlightoptics.com/sky-watcher-starquest/sky-watcher-starquest-102r-f49-achromatic-refractor-telescope.html
      There is no direct comparison, but is the StarQuest is a copy of StarTravel 102 (https://www.firstlightoptics.com/startravel/skywatcher-startravel-102t-ota.html), or it's a different telescope optically and functionally? 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.