Jump to content

Banner.jpg.39bf5bb2e6bf87794d3e2a4b88f26f1b.jpg

Pixinsight importing Gray>?


tingting44
 Share

Recommended Posts

i do not mate, its a fresh cr2 file from my canon 7d, never had this before with PI so a bit puzzled to why its doing it now, i only loading it into PS to make sure i was not going crazy and there was colour in the image lol

Edited by tingting44
Link to comment
Share on other sites

I suppose if you are only loading in stacked picutres to Pixinsight previously, they would already have been deBayered so wouldnt throw that problem up. Otherwise, I really dont know what caused that.

To fix the green colour, a quick Background neutralization should take care of that.

  • Thanks 1
Link to comment
Share on other sites

You have a green image because you've autostretched the debayered file and you haven't aligned the RGB channels.

Easiest way to do this is LinearFit.

Do an image noise estimation on the debayered file, then check which one has the lowest noise.

Split the file into separate RGB channels, open LinearFit, and choose the image with the lowest noise (either R, G or B in the process window).

Apply the fit to the other 2 channels.

Combine the channels to an RGB image, the you should have the correct colour when you autostetch.

If you struggle, attach the raw file and I'll try it for you.

  • Thanks 1
Link to comment
Share on other sites

thanks a lot guys, you're right i normally work with stacked images in PI, ive been having a play about with old images tonight and they have been single subs, not stacks, so this is why i think, good to know for future if i want to work on single images, not really had much need to work on singles in PI as mostly my singles are for daytime photography which i just use PS, im pretty tired now, ill have a more in depth play tomorrow, thanks a lot for taking the time to help, have a good evening all

 

o7

  • Thanks 1
Link to comment
Share on other sites

My cr2 files open like yours.

The reason you’re seeing the strange green after debayering is because you haven’t applied background neutralisation and colour calibration. Or you could use the photometric colour calibration. 

However if you want a quick way of viewing the cr2 file as a colour image you can open it using the Camera Colour Balance. In View -format explorer - raw- edit settings, change it to the demosaiced RGB and then open the Cr2 file (without debayering it) and apply the STF. 

Link to comment
Share on other sites

I've tried to recreate an image similar to your but cant. My cr2 files are set to open in their raw format but nowhere near as bright as yours. Yours looks like a mono image with noise. below left is an uncalibrated cr2 file with half saturated sensor and right is debayered with unlinked stretch.

raw.PNG

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.